summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-02-14 11:33:00 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-14 11:33:00 +0100
commitd7ea913e51ebff7b8a80c8cac74a9ce7855e6f73 (patch)
treed043db6134ee61e07e3d5d3f4df6f446e67c703f /sci-astronomy/swarp/swarp-2.41.5.ebuild
parentnet-print/mtink: Fix build issues (diff)
downloadgentoo-d7ea913e51ebff7b8a80c8cac74a9ce7855e6f73.tar.gz
gentoo-d7ea913e51ebff7b8a80c8cac74a9ce7855e6f73.tar.bz2
gentoo-d7ea913e51ebff7b8a80c8cac74a9ce7855e6f73.zip
sci-astronomy/swarp: Bump to 2.41.5
* Fixes gcc-10 issues and AR call Closes: https://bugs.gentoo.org/707856 Closes: https://bugs.gentoo.org/725274 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-astronomy/swarp/swarp-2.41.5.ebuild')
-rw-r--r--sci-astronomy/swarp/swarp-2.41.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-astronomy/swarp/swarp-2.41.5.ebuild b/sci-astronomy/swarp/swarp-2.41.5.ebuild
new file mode 100644
index 000000000000..87ae8276154d
--- /dev/null
+++ b/sci-astronomy/swarp/swarp-2.41.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Resample and coadd astronomical FITS images"
+HOMEPAGE="http://www.astromatic.net/software/swarp"
+SRC_URI="https://github.com/astromatic/swarp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cfitsio doc threads"
+
+RDEPEND="cfitsio? ( sci-libs/cfitsio )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with cfistio) \
+ $(use_enable threads)
+}
+
+src_install() {
+ default
+ use doc && dodoc -r doc/.
+}