summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2022-10-09 11:13:49 +0100
committerJason Zaman <perfinion@gentoo.org>2022-11-04 18:32:23 -0700
commit3f8c2e83358874c6537eb37488e289c3d0e3284b (patch)
tree1b55831cd39855c888607a847e1c3576b3871dcf /sci-astronomy/calcmysky
parentdev-libs/qxlsx: new package, add 1.4.4 (diff)
downloadgentoo-3f8c2e83358874c6537eb37488e289c3d0e3284b.tar.gz
gentoo-3f8c2e83358874c6537eb37488e289c3d0e3284b.tar.bz2
gentoo-3f8c2e83358874c6537eb37488e289c3d0e3284b.zip
sci-astronomy/calcmysky: new package, add 0.2.1
Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sci-astronomy/calcmysky')
-rw-r--r--sci-astronomy/calcmysky/Manifest1
-rw-r--r--sci-astronomy/calcmysky/calcmysky-0.2.1.ebuild65
-rw-r--r--sci-astronomy/calcmysky/metadata.xml19
3 files changed, 85 insertions, 0 deletions
diff --git a/sci-astronomy/calcmysky/Manifest b/sci-astronomy/calcmysky/Manifest
new file mode 100644
index 000000000000..90a19e9a9852
--- /dev/null
+++ b/sci-astronomy/calcmysky/Manifest
@@ -0,0 +1 @@
+DIST calcmysky-0.2.1.tar.gz 2161314 BLAKE2B b0aa1abc75f59c9c16429749bb8669e49e17e3dc7716bb78f472a9181c7d77a2c82c2f3800529f620604f233f88855908b0b55d824bf259d0912e157b9537faf SHA512 3915b965ee656b259ce7f158dfdd3c9c11a6c3ff907307899ae55e88ad6c1ccfbec8e0a1f784f5232fb0cb2c8300422fa25b8b1d4d11639d3ebb8c76d67059e5
diff --git a/sci-astronomy/calcmysky/calcmysky-0.2.1.ebuild b/sci-astronomy/calcmysky/calcmysky-0.2.1.ebuild
new file mode 100644
index 000000000000..47c8b4a34689
--- /dev/null
+++ b/sci-astronomy/calcmysky/calcmysky-0.2.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multibuild cmake
+
+DESCRIPTION="Simulator of light scattering by planetary atmospheres"
+HOMEPAGE="https://github.com/10110111/CalcMySky"
+SRC_URI="
+ https://github.com/10110111/CalcMySky/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-3"
+# subslot is soversion
+SLOT="0/14"
+KEYWORDS="~amd64"
+
+IUSE="qt5 qt6"
+REQUIRED_USE="|| ( qt5 qt6 )"
+
+DEPEND="
+ dev-cpp/eigen:3
+ media-libs/glm
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5[-gles2-only]
+ dev-qt/qtopengl:5[-gles2-only]
+ dev-qt/qtwidgets:5[-gles2-only]
+ )
+ qt6? (
+ dev-qt/qtbase:6[gui,opengl,widgets,-gles2-only]
+ )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/CalcMySky-${PV}"
+
+pkg_setup() {
+ MULTIBUILD_VARIANTS=( $(usev qt5) $(usev qt6) )
+}
+
+src_configure() {
+ my_src_configure() {
+ local mycmakeargs=(
+ -DQT_VERSION="${MULTIBUILD_VARIANT/qt/}"
+ )
+
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant my_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_test() {
+ multibuild_foreach_variant cmake_build check
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+}
diff --git a/sci-astronomy/calcmysky/metadata.xml b/sci-astronomy/calcmysky/metadata.xml
new file mode 100644
index 000000000000..ef26156cdf6d
--- /dev/null
+++ b/sci-astronomy/calcmysky/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>alexey+gentoo@asokolov.org</email>
+ <name>Alexey Sokolov</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-astronomy@gentoo.org</email>
+ <name>Gentoo Astronomy Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">10110111/CalcMySky</remote-id>
+ </upstream>
+</pkgmetadata>