summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-05-29 23:12:13 -0400
committerRick Farina <zerochaos@gentoo.org>2020-06-01 16:43:09 -0400
commit189ac42416a5d82a21b15ebeae36d78b4973caf7 (patch)
treed073296b473636e4a026e6091606bf4d79475915 /net-wireless
parentnet-wireless/gr-osmosdr: bump (diff)
downloadgentoo-189ac42416a5d82a21b15ebeae36d78b4973caf7.tar.gz
gentoo-189ac42416a5d82a21b15ebeae36d78b4973caf7.tar.bz2
gentoo-189ac42416a5d82a21b15ebeae36d78b4973caf7.zip
net-wireless/gr-ieee802154: bump
prep for gr3.8 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/gr-ieee802154/Manifest3
-rw-r--r--net-wireless/gr-ieee802154/gr-ieee802154-0.0_p20190606.ebuild (renamed from net-wireless/gr-ieee802154/gr-ieee802154-0.0_p20180402.ebuild)14
-rw-r--r--net-wireless/gr-ieee802154/gr-ieee802154-0.0_p20191006.ebuild51
-rw-r--r--net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild16
4 files changed, 70 insertions, 14 deletions
diff --git a/net-wireless/gr-ieee802154/Manifest b/net-wireless/gr-ieee802154/Manifest
index 1419ea0abdff..7cf49226bddd 100644
--- a/net-wireless/gr-ieee802154/Manifest
+++ b/net-wireless/gr-ieee802154/Manifest
@@ -1 +1,2 @@
-DIST gr-ieee802154-0.0_p20180402.tar.gz 195464 BLAKE2B 391bd4eefb5a90135a084a94c2edd83e6f2c2bd6dca26be4d9a54448382d5ee463e1740c305e9583be0107b424c67e74fac84ece147844e7c2a63f6096c7dd36 SHA512 90f164bdcd636dee68a49fe844901ca73e1f743fdeacd8019edddc57c681ec3d1fcfe209d8abd89e2013c2c2c436b7992fe0b0dbe9c88c04352aebc0813a9d96
+DIST gr-ieee802154-0.0_p20190606.tar.gz 195541 BLAKE2B f565808788c463816633774362be0bf6e6900db52051ef4f8e2eed5b110c7b9edcf05458f8a4a8e3afef59c4a76101a5606ea9c9023ad922162ee9466cc7e343 SHA512 b430ee6c16356307566619cd50258c3fd05ca198a67f0b47eea6b8d1038de6cc070823dd7392a56c4308cd74495802b4b52a4a425ce43ce4afb56386ec5fa39a
+DIST gr-ieee802154-0.0_p20191006.tar.gz 94443 BLAKE2B f561b401b97741e6a06d36b97be765f66778002c6ea7814ffcc08e7aa93d6236705a25c1f32d536d3e2d2193b92608cdd469ba086f459f0f8290c74f52297d6a SHA512 1c552cfe3739165382c36aeb8f556b17ee7925459d74c96d36a7b1f821e177860ddab601c87184cd33db9c97d1231edeb4267bbfbf9df198708db692e27a1a86
diff --git a/net-wireless/gr-ieee802154/gr-ieee802154-0.0_p20180402.ebuild b/net-wireless/gr-ieee802154/gr-ieee802154-0.0_p20190606.ebuild
index e99620f1b2aa..89e8afbf67b3 100644
--- a/net-wireless/gr-ieee802154/gr-ieee802154-0.0_p20180402.ebuild
+++ b/net-wireless/gr-ieee802154/gr-ieee802154-0.0_p20190606.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 )
inherit cmake-utils python-single-r1
@@ -14,7 +14,7 @@ if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/bastibl/gr-ieee802-15-4.git"
KEYWORDS=""
else
- COMMIT="c969b3fd2059472a28dee6f911083dd03d1dd569"
+ COMMIT="d3d94023c71af9e6d7721f7412fba88ff5325234"
SRC_URI="https://github.com/bastibl/gr-ieee802-15-4/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/gr-ieee802-15-4-${COMMIT}"
KEYWORDS="~amd64 ~x86"
@@ -23,15 +23,13 @@ fi
LICENSE="GPL-3"
SLOT="0/${PV}"
-RDEPEND=">=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_SINGLE_USEDEP}]
+RDEPEND="=net-wireless/gnuradio-3.7*:0=[${PYTHON_SINGLE_USEDEP}]
$(python_gen_cond_dep '
dev-libs/boost:=[${PYTHON_MULTI_USEDEP}]
')
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
dev-lang/swig:0"
-#cppunit is listed in cmake, but only needed for tests and there are no tests
-# dev-util/cppunit"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -40,10 +38,14 @@ src_prepare() {
sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt
sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt
sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt
+ sed -i '/GR_PKG_DOC_DIR/d' CMakeLists.txt
cmake-utils_src_prepare
}
src_configure() {
- mycmakeargs=( -DPYTHON_EXECUTABLE="${PYTHON}" )
+ mycmakeargs=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DGR_PKG_DOC_DIR="/usr/share/doc/${P}"
+ )
cmake-utils_src_configure
}
diff --git a/net-wireless/gr-ieee802154/gr-ieee802154-0.0_p20191006.ebuild b/net-wireless/gr-ieee802154/gr-ieee802154-0.0_p20191006.ebuild
new file mode 100644
index 000000000000..f398a0ebda3d
--- /dev/null
+++ b/net-wireless/gr-ieee802154/gr-ieee802154-0.0_p20191006.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake-utils python-single-r1
+
+DESCRIPTION="IEEE 802.15.4 ZigBee Transceiver"
+HOMEPAGE="https://github.com/bastibl/gr-ieee802-15-4"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/bastibl/gr-ieee802-15-4.git"
+ KEYWORDS=""
+else
+ COMMIT="a3c79af96e18de3eb3a76659e1669a370efccf17"
+ SRC_URI="https://github.com/bastibl/gr-ieee802-15-4/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/gr-ieee802-15-4-${COMMIT}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+
+RDEPEND="=net-wireless/gnuradio-3.8*:0=[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-libs/boost:=[${PYTHON_MULTI_USEDEP}]
+ ')
+ ${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-lang/swig:0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_prepare() {
+ #although cppunit is not used, it fails if it isn't there, fix it
+ sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt
+ sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt
+ sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt
+ sed -i '/GR_PKG_DOC_DIR/d' CMakeLists.txt
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DGR_PKG_DOC_DIR="/usr/share/doc/${P}"
+ )
+ cmake-utils_src_configure
+}
diff --git a/net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild b/net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild
index e99620f1b2aa..f398a0ebda3d 100644
--- a/net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild
+++ b/net-wireless/gr-ieee802154/gr-ieee802154-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit cmake-utils python-single-r1
@@ -14,7 +14,7 @@ if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/bastibl/gr-ieee802-15-4.git"
KEYWORDS=""
else
- COMMIT="c969b3fd2059472a28dee6f911083dd03d1dd569"
+ COMMIT="a3c79af96e18de3eb3a76659e1669a370efccf17"
SRC_URI="https://github.com/bastibl/gr-ieee802-15-4/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/gr-ieee802-15-4-${COMMIT}"
KEYWORDS="~amd64 ~x86"
@@ -23,15 +23,13 @@ fi
LICENSE="GPL-3"
SLOT="0/${PV}"
-RDEPEND=">=net-wireless/gnuradio-3.7_rc:0=[${PYTHON_SINGLE_USEDEP}]
+RDEPEND="=net-wireless/gnuradio-3.8*:0=[${PYTHON_SINGLE_USEDEP}]
$(python_gen_cond_dep '
dev-libs/boost:=[${PYTHON_MULTI_USEDEP}]
')
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
dev-lang/swig:0"
-#cppunit is listed in cmake, but only needed for tests and there are no tests
-# dev-util/cppunit"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -40,10 +38,14 @@ src_prepare() {
sed -i 's#FATAL_ERROR "CppUnit#MESSAGE "CppUnit#' CMakeLists.txt
sed -i '/${CPPUNIT_INCLUDE_DIRS}/d' CMakeLists.txt
sed -i '/${CPPUNIT_LIBRARY_DIRS}/d' CMakeLists.txt
+ sed -i '/GR_PKG_DOC_DIR/d' CMakeLists.txt
cmake-utils_src_prepare
}
src_configure() {
- mycmakeargs=( -DPYTHON_EXECUTABLE="${PYTHON}" )
+ mycmakeargs=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DGR_PKG_DOC_DIR="/usr/share/doc/${P}"
+ )
cmake-utils_src_configure
}