summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-wireless/chillispot
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-wireless/chillispot')
-rw-r--r--net-wireless/chillispot/Manifest1
-rw-r--r--net-wireless/chillispot/chillispot-1.1.0.ebuild34
-rw-r--r--net-wireless/chillispot/files/chillispot33
-rw-r--r--net-wireless/chillispot/files/chillispot-1.1.0-gcc44.patch81
-rw-r--r--net-wireless/chillispot/metadata.xml15
5 files changed, 164 insertions, 0 deletions
diff --git a/net-wireless/chillispot/Manifest b/net-wireless/chillispot/Manifest
new file mode 100644
index 000000000000..a38daa9d8fa6
--- /dev/null
+++ b/net-wireless/chillispot/Manifest
@@ -0,0 +1 @@
+DIST chillispot-1.1.0.tar.gz 452749 SHA256 b505ab963af8423ef8ae844951ef05fe1554630b448f1174074e9881cb474a01 SHA512 f0ea3c50983cb1d23da542d63be989a6ccb1e81d5e3a20b143f66414fad035f54531174d4cec49d1f8c9d27f0cffc5a3ed0f4ca64f4cf8b58035d561ce59cab2 WHIRLPOOL 5ab73a04e3127570a0f1cffbf167cba877f3f0bbd45c094a3b1a01fa5ffac70efd2fbfbf9c3bebb064abaef90f6774f375f45bb8f1465bbf878d6ab54e200805
diff --git a/net-wireless/chillispot/chillispot-1.1.0.ebuild b/net-wireless/chillispot/chillispot-1.1.0.ebuild
new file mode 100644
index 000000000000..dfad34356932
--- /dev/null
+++ b/net-wireless/chillispot/chillispot-1.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="open source captive portal or wireless LAN access point controller"
+HOMEPAGE="http://www.chillispot.info/"
+SRC_URI="http://www.chillispot.info/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ~ppc s390 sh ~sparc x86"
+IUSE=""
+
+DEPEND=">=sys-apps/sed-4"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ chmod 644 doc/*.conf
+ find . -exec chmod go-w '{}' \;
+
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" STRIPPROG=true install || die "emake install failed"
+ cd doc && dodoc chilli.conf freeradius.users hotspotlogin.cgi firewall.iptables
+
+ # init script provided by Michele Beltrame bug #124698
+ newinitd "${FILESDIR}"/${PN} ${PN} || die
+}
diff --git a/net-wireless/chillispot/files/chillispot b/net-wireless/chillispot/files/chillispot
new file mode 100644
index 000000000000..9c6b6cb7663e
--- /dev/null
+++ b/net-wireless/chillispot/files/chillispot
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use net logger
+}
+
+
+checkconfig() {
+ if [ -f /etc/chilli.conf ]; then
+ return 0;
+ else
+ eerror "Error starting chillispot. Please create /etc/chilli.conf before."
+ return 1;
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting Chillispot"
+
+ start-stop-daemon --start --quiet \
+ --exec /usr/sbin/chilli
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping Chillispot"
+ start-stop-daemon --stop --pidfile /var/run/chilli.pid --quiet
+ eend $?
+}
diff --git a/net-wireless/chillispot/files/chillispot-1.1.0-gcc44.patch b/net-wireless/chillispot/files/chillispot-1.1.0-gcc44.patch
new file mode 100644
index 000000000000..aa296b8828ac
--- /dev/null
+++ b/net-wireless/chillispot/files/chillispot-1.1.0-gcc44.patch
@@ -0,0 +1,81 @@
+diff -NrU5 chillispot-1.1.0.original/src/tun.c chillispot-1.1.0/src/tun.c
+--- chillispot-1.1.0.original/src/tun.c 2009-07-18 20:50:38.000000000 +0000
++++ chillispot-1.1.0/src/tun.c 2009-07-18 21:06:53.000000000 +0000
+@@ -364,11 +364,11 @@
+ tun_sifflags(this, IFF_UP | IFF_RUNNING); /* TODO */
+ close(fd);
+ this->addrs++;
+ return 0;
+
+-#elif defined (__FreeBSD__) defined (__OpenBSD__) || defined (__NetBSD__) || defined (__APPLE__)
++#elif defined (__FreeBSD__) || defined (__OpenBSD__) || defined (__NetBSD__) || defined (__APPLE__)
+
+ int fd;
+ struct ifaliasreq areq;
+
+ /* TODO: Is this needed on FreeBSD? */
+@@ -443,11 +443,11 @@
+ ifr.ifr_dstaddr.sa_family = AF_INET;
+
+ #if defined(__linux__)
+ ifr.ifr_netmask.sa_family = AF_INET;
+
+-#elif defined(__FreeBSD__) defined (__OpenBSD__) || defined (__NetBSD__) || defined (__APPLE__)
++#elif defined(__FreeBSD__) || defined (__OpenBSD__) || defined (__NetBSD__) || defined (__APPLE__)
+ ((struct sockaddr_in *) &ifr.ifr_addr)->sin_len =
+ sizeof (struct sockaddr_in);
+ ((struct sockaddr_in *) &ifr.ifr_dstaddr)->sin_len =
+ sizeof (struct sockaddr_in);
+ #endif
+@@ -495,11 +495,11 @@
+ this->netmask.s_addr = netmask->s_addr;
+ #if defined(__linux__)
+ ((struct sockaddr_in *) &ifr.ifr_netmask)->sin_addr.s_addr =
+ netmask->s_addr;
+
+-#elif defined(__FreeBSD__) defined (__OpenBSD__) || defined (__NetBSD__) || defined (__APPLE__)
++#elif defined(__FreeBSD__) || defined (__OpenBSD__) || defined (__NetBSD__) || defined (__APPLE__)
+ ((struct sockaddr_in *) &ifr.ifr_addr)->sin_addr.s_addr =
+ netmask->s_addr;
+
+ #elif defined(__sun__)
+ ((struct sockaddr_in *) &ifr.ifr_addr)->sin_addr.s_addr =
+@@ -583,11 +583,11 @@
+ }
+ }
+ close(fd);
+ return 0;
+
+-#elif defined(__FreeBSD__) defined (__OpenBSD__) || defined (__NetBSD__) || defined (__APPLE__)
++#elif defined(__FreeBSD__) || defined (__OpenBSD__) || defined (__NetBSD__) || defined (__APPLE__)
+
+ struct {
+ struct rt_msghdr rt;
+ struct sockaddr_in dst;
+ struct sockaddr_in gate;
+@@ -672,11 +672,11 @@
+ {
+
+ #if defined(__linux__)
+ struct ifreq ifr;
+
+-#elif defined(__FreeBSD__) defined (__OpenBSD__) || defined (__NetBSD__) || defined (__APPLE__)
++#elif defined(__FreeBSD__) || defined (__OpenBSD__) || defined (__NetBSD__) || defined (__APPLE__)
+ char devname[IFNAMSIZ+5]; /* "/dev/" + ifname */
+ int devnum;
+ struct ifaliasreq areq;
+ int fd;
+
+@@ -720,11 +720,11 @@
+ (*tun)->devname[IFNAMSIZ] = 0;
+
+ ioctl((*tun)->fd, TUNSETNOCSUM, 1); /* Disable checksums */
+ return 0;
+
+-#elif defined(__FreeBSD__) defined (__OpenBSD__) || defined (__NetBSD__) || defined (__APPLE__)
++#elif defined(__FreeBSD__) || defined (__OpenBSD__) || defined (__NetBSD__) || defined (__APPLE__)
+
+ /* Find suitable device */
+ for (devnum = 0; devnum < 255; devnum++) { /* TODO 255 */
+ snprintf(devname, sizeof(devname), "/dev/tun%d", devnum);
+ devname[sizeof(devname)] = 0;
diff --git a/net-wireless/chillispot/metadata.xml b/net-wireless/chillispot/metadata.xml
new file mode 100644
index 000000000000..8160ef2ff55d
--- /dev/null
+++ b/net-wireless/chillispot/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+
+<longdescription>ChilliSpot is an open source captive portal or wireless
+LAN access point controller. It is used for authenticating users of a
+wireless LAN. It supports web based login which is today's standard for
+public HotSpots and it supports Wireless Protected Access (WPA) which is
+the standard of the future. Authentication, authorization and accounting
+(AAA) is handled by your favorite radius server.</longdescription>
+
+</pkgmetadata>