summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2019-06-24 09:25:47 +0000
committerYixun Lan <dlan@gentoo.org>2019-06-24 09:27:15 +0000
commit7a4f60ea4e7e36a8ad3513e514223317c2bf030a (patch)
treef2348390f92d1cbb39c1c4c87169dd3f1adec7a8 /net-proxy
parentnet-libs/libssh2: Clean up patch (diff)
downloadgentoo-7a4f60ea4e7e36a8ad3513e514223317c2bf030a.tar.gz
gentoo-7a4f60ea4e7e36a8ad3513e514223317c2bf030a.tar.bz2
gentoo-7a4f60ea4e7e36a8ad3513e514223317c2bf030a.zip
net-proxy/shadowsocks-libev: version bump 3.3.0
Closes: https://bugs.gentoo.org/688180 Package-Manager: Portage-2.3.67, Repoman-2.3.13 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/shadowsocks-libev/Manifest1
-rw-r--r--net-proxy/shadowsocks-libev/files/shadowsocks.initd2
-rw-r--r--net-proxy/shadowsocks-libev/shadowsocks-libev-3.3.0.ebuild84
3 files changed, 86 insertions, 1 deletions
diff --git a/net-proxy/shadowsocks-libev/Manifest b/net-proxy/shadowsocks-libev/Manifest
index e6839557c35f..560e73e6326b 100644
--- a/net-proxy/shadowsocks-libev/Manifest
+++ b/net-proxy/shadowsocks-libev/Manifest
@@ -1,2 +1,3 @@
DIST shadowsocks-libev-3.2.4.tar.gz 277679 BLAKE2B 32d4d48c22951894e9aa64cd6d34f7586c61ab5ae994b263b272c07a05a019f9c493909f50f3ec027af29681885a65f51afe97dc959c508f107a5010974c8e11 SHA512 f8bd19d4f3f70cedd0f34a6a16975c3694ef36e85b278d4a7bb10520a43d71c83f81ceebcf20530cdd04b5000a8c742e0789fdbefa70fef6b5d1dc799ce34528
DIST shadowsocks-libev-3.2.5.tar.gz 278138 BLAKE2B 874471f134371d274ce274c096286dfe8a755e5423624df80df70321f017d9344516fd38f82df43033870588664dc626595157ab6c5022c9953bd9ce59dee2b8 SHA512 b4ca9f7c303c85a5bba9bf5d7a093c6dfde7a147d0335b449d4ee213cd3b9004c5220a099dcc78464a35c55f9cfe280d817daf934e2fda100f5e784f70091c0b
+DIST shadowsocks-libev-3.3.0.tar.gz 278818 BLAKE2B e2f00082d6fe697560dc282f31ed98368390e750a7be33fd3230f4d4635b4aa8a8ace3bd82da8000defee468ae167c2b4fa1e836e79580deeeff3a53dc7b793c SHA512 7c93bddef07af9e79a7c6757a89f301000a6137e0951ee622c66c2e8d3aa70e157cfdf7798a718074f956f7c22dde0af1073781cf0b36d7e185dfd45a87f354b
diff --git a/net-proxy/shadowsocks-libev/files/shadowsocks.initd b/net-proxy/shadowsocks-libev/files/shadowsocks.initd
index e980bb2636e8..2ccd114485bb 100644
--- a/net-proxy/shadowsocks-libev/files/shadowsocks.initd
+++ b/net-proxy/shadowsocks-libev/files/shadowsocks.initd
@@ -1,5 +1,5 @@
#!/sbin/openrc-run
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
SS_CONFIG="/etc/shadowsocks-libev/shadowsocks.json"
diff --git a/net-proxy/shadowsocks-libev/shadowsocks-libev-3.3.0.ebuild b/net-proxy/shadowsocks-libev/shadowsocks-libev-3.3.0.ebuild
new file mode 100644
index 000000000000..65c0bfdfa56d
--- /dev/null
+++ b/net-proxy/shadowsocks-libev/shadowsocks-libev-3.3.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV="v${PV}"
+inherit autotools eutils systemd
+
+DESCRIPTION="A lightweight secured SOCKS5 proxy for embedded devices and low end boxes"
+HOMEPAGE="https://github.com/shadowsocks/shadowsocks-libev"
+
+#repack with git submodule populated: libbloom, libcork, libipset
+#SRC_URI="https://dev.gentoo.org/~dlan/distfiles/${P}.tar.xz"
+
+SRC_URI="https://github.com/shadowsocks/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="net-libs/mbedtls:=
+ net-libs/libbloom
+ net-libs/libcork
+ net-libs/libcorkipset
+ >=dev-libs/libsodium-1.0.8:=
+ dev-libs/libev
+ net-dns/c-ares
+ dev-libs/libpcre
+ "
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ )
+ "
+
+src_prepare() {
+ sed -i 's|AC_CONFIG_FILES(\[libbloom/Makefile libcork/Makefile libipset/Makefile\])||' \
+ configure.ac || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf="
+ $(use_enable debug assert)
+ --enable-system-shared-lib
+ "
+ use doc || myconf+="--disable-documentation"
+ econf ${myconf}
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -type f -delete || die
+
+ dodir "/etc/${PN}"
+ insinto "/etc/${PN}"
+ newins "${FILESDIR}/shadowsocks.json" shadowsocks.json
+
+ newinitd "${FILESDIR}/shadowsocks.initd" shadowsocks
+ dosym shadowsocks /etc/init.d/shadowsocks.server
+ dosym shadowsocks /etc/init.d/shadowsocks.client
+ dosym shadowsocks /etc/init.d/shadowsocks.redir
+ dosym shadowsocks /etc/init.d/shadowsocks.tunnel
+
+ dodoc -r acl
+
+ systemd_newunit "${FILESDIR}/${PN}-local_at.service" "${PN}-local@.service"
+ systemd_newunit "${FILESDIR}/${PN}-server_at.service" "${PN}-server@.service"
+ systemd_newunit "${FILESDIR}/${PN}-redir_at.service" "${PN}-redir@.service"
+ systemd_newunit "${FILESDIR}/${PN}-tunnel_at.service" "${PN}-tunnel@.service"
+}
+
+pkg_setup() {
+ elog "You need to choose the mode"
+ elog " server: rc-update add shadowsocks.server default"
+ elog " client: rc-update add shadowsocks.client default"
+ elog " redir: rc-update add shadowsocks.redir default"
+ elog " tunnel: rc-update add shadowsocks.tunnel default"
+}