summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Wilson <sam@binarycake.ca>2024-07-09 12:59:09 -0400
committerJoonas Niilola <juippis@gentoo.org>2024-07-30 19:09:09 +0300
commitc4834625a1a484e53458542c8420a0a67b97bc67 (patch)
treefa1355fc1d63b7a039ad712c373f336ac323422e /net-p2p
parentmedia-gfx/oxipng: add QA_PRESTRIPPED to 9.1.2 (diff)
downloadgentoo-c4834625a1a484e53458542c8420a0a67b97bc67.tar.gz
gentoo-c4834625a1a484e53458542c8420a0a67b97bc67.tar.bz2
gentoo-c4834625a1a484e53458542c8420a0a67b97bc67.zip
net-p2p/go-ethereum: add 1.14.6
Closes: https://bugs.gentoo.org/935792 Signed-off-by: Sam Wilson <sam@binarycake.ca> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/go-ethereum/Manifest2
-rw-r--r--net-p2p/go-ethereum/go-ethereum-1.14.6.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/net-p2p/go-ethereum/Manifest b/net-p2p/go-ethereum/Manifest
index f309c4d399f4..ff91f623aa82 100644
--- a/net-p2p/go-ethereum/Manifest
+++ b/net-p2p/go-ethereum/Manifest
@@ -2,3 +2,5 @@ DIST go-ethereum-1.10.18-deps.tar.xz 77657628 BLAKE2B fa4ebb250668489d6d72ac1284
DIST go-ethereum-1.10.18.tar.gz 13084436 BLAKE2B 4918f13b131796f928c17e6cbd3ab42095d4a52874865a2e9b9c6e8b8e4528af0152055c8d8556c795079bd2bc044e9a0fd028d4a90c66181c0cafddb41cf7ae SHA512 ba2b7091ac4ffd5bf02dbc27769ebd138b82dd9d79fb613e727f56f6cfaf969183f343511478e88fbead627141101e77206a4c2449b0ced9a7a2090b4c77d996
DIST go-ethereum-1.13.14-deps.tar.xz 70373740 BLAKE2B 6bc403f85e024fdeeab8f41ef7f2940cceee11b8f6a1f97dc53cc5dda997f3c97ddcaefac61df196508f00fe61152f21bedc8de9e380fa91245a049c0a93ab58 SHA512 0d6cc6b846dab05acabfa0fc840f2db450a3138f863bf3f99ef83040071260a42fa2dccb88877a0d340e2532241653c32efb783bc67698f316ab1c9291d75330
DIST go-ethereum-1.13.14.tar.gz 13500798 BLAKE2B f5cf0c3f72aedc7d149c5342c2edbcb4310301b4c9b164d65e1e281b8db78c79ca884e9cb41ecd72ed6fbbed34e198cb13fe7cc726856c9f323a4aacc4a2dc17 SHA512 80a410dbeb06e8a46bd5b4e962fcf030fa8787eef192dbcd01c3d98bf31e822a8c3b92c35251876e122eac3fad707faf95b5e5c0baed8e29aa024c856b6f54bc
+DIST go-ethereum-1.14.6-deps.tar.xz 175532036 BLAKE2B e70c06efb1c480e65c56f2bd7dadff18cffc8a31bb3f74994110dda6fccf769d95bf83560e606e443590eb981abcd4dd2108185414cdf68af77911252200e9c0 SHA512 ba18e585e69b7623f8277abffaaf762e0f1c35280e32b6fa7e44185f22324618bb8c2793508e648d21d7f366a2694c70384166d11fe79a1e863b209f4a065601
+DIST go-ethereum-1.14.6.tar.gz 13978474 BLAKE2B eafc01fdc2a98a7b271c5604bdb627e1fb0d72afefa03f1f677d62b5f210de240d9acb00166629071d6862d1df94bf46709f86f91a979a319e2c27feee4f9acb SHA512 8b9b887bf2d3c620079a6f92c347a57a9aec657353edbaeb74be0333e96631704f45fd7bdcd428f05de0a72963e10e0f85b51b93af224ff28c46b19eaee3fa71
diff --git a/net-p2p/go-ethereum/go-ethereum-1.14.6.ebuild b/net-p2p/go-ethereum/go-ethereum-1.14.6.ebuild
new file mode 100644
index 000000000000..f5562b6dbf14
--- /dev/null
+++ b/net-p2p/go-ethereum/go-ethereum-1.14.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Official golang implementation of the Ethereum protocol"
+HOMEPAGE="https://github.com/ethereum/go-ethereum"
+SRC_URI="https://github.com/ethereum/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="GPL-3+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="devtools"
+
+# Does all kinds of wonky stuff like connecting to Docker daemon, network activity, ...
+RESTRICT+=" test"
+
+src_compile() {
+ emake $(usex devtools all geth)
+}
+
+src_install() {
+ einstalldocs
+
+ dobin build/bin/geth
+
+ # TODO: replace with wildcard
+ if use devtools; then
+ dobin build/bin/abidump
+ dobin build/bin/abigen
+ dobin build/bin/bootnode
+ dobin build/bin/clef
+ dobin build/bin/devp2p
+ dobin build/bin/ethkey
+ dobin build/bin/evm
+ dobin build/bin/p2psim
+ dobin build/bin/rlpdump
+ fi
+}