summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-01 05:01:40 +0000
committerSam James <sam@gentoo.org>2020-11-01 05:10:19 +0000
commita1e12b78372b32130e849b458f6dbdf2df363e7a (patch)
tree08299a630802e55be244c76742490d3d1b03e678 /net-misc/wput
parentx11-plugins/asmon: fix build with gcc 10 (diff)
downloadgentoo-a1e12b78372b32130e849b458f6dbdf2df363e7a.tar.gz
gentoo-a1e12b78372b32130e849b458f6dbdf2df363e7a.tar.bz2
gentoo-a1e12b78372b32130e849b458f6dbdf2df363e7a.zip
net-misc/wput: fix build with gcc 10
Closes: https://bugs.gentoo.org/706954 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/wput')
-rw-r--r--net-misc/wput/files/wput-0.6-gentoo.diff5
-rw-r--r--net-misc/wput/files/wput-0.6-respectldflags.patch4
-rw-r--r--net-misc/wput/files/wput-0.6.2-fno-common.patch25
-rw-r--r--net-misc/wput/files/wput-0.6.2-respect-destdir.patch2
-rw-r--r--net-misc/wput/files/wput-fix-crash.patch5
-rw-r--r--net-misc/wput/wput-0.6.1-r1.ebuild15
-rw-r--r--net-misc/wput/wput-0.6.2.ebuild9
7 files changed, 39 insertions, 26 deletions
diff --git a/net-misc/wput/files/wput-0.6-gentoo.diff b/net-misc/wput/files/wput-0.6-gentoo.diff
index 312172348d02..7ddf0ba3ba19 100644
--- a/net-misc/wput/files/wput-0.6-gentoo.diff
+++ b/net-misc/wput/files/wput-0.6-gentoo.diff
@@ -1,6 +1,5 @@
-diff -urN wput/Makefile.in wput/Makefile.in
---- wput/Makefile.in 2006-04-04 18:16:52.000000000 +0100
-+++ wput/Makefile.in 2006-11-07 17:31:10.000000000 +0000
+--- a/Makefile.in
++++ b/Makefile.in
@@ -15,8 +15,12 @@
install: all
diff --git a/net-misc/wput/files/wput-0.6-respectldflags.patch b/net-misc/wput/files/wput-0.6-respectldflags.patch
index d2b460b339b3..9f0e09c4a78d 100644
--- a/net-misc/wput/files/wput-0.6-respectldflags.patch
+++ b/net-misc/wput/files/wput-0.6-respectldflags.patch
@@ -1,6 +1,4 @@
-Index: wput/src/Makefile.in
-===================================================================
---- wput.orig/src/Makefile.in
+--- wput/src/Makefile.in
+++ wput/src/Makefile.in
@@ -23,7 +23,7 @@ ftplib.o: socketlib.h ftplib.h
ftp-ls.o: ftp.h wget.h url.h
diff --git a/net-misc/wput/files/wput-0.6.2-fno-common.patch b/net-misc/wput/files/wput-0.6.2-fno-common.patch
new file mode 100644
index 000000000000..f188141aa87b
--- /dev/null
+++ b/net-misc/wput/files/wput-0.6.2-fno-common.patch
@@ -0,0 +1,25 @@
+https://sources.debian.org/patches/wput/0.6.2+git20130413-9/single-declaration.patch/
+https://bugs.gentoo.org/706954
+--- a/src/wput.h
++++ b/src/wput.h
+@@ -140,7 +140,9 @@
+
+ unsigned short int retry_interval;
+ unsigned int speed_limit;
+-} opt;
++};
++
++extern struct global_options opt;
+
+ extern _fsession * fsession_queue_entry_point;
+ extern char * email_address;
+--- a/src/wput.c
++++ b/src/wput.c
+@@ -55,6 +55,7 @@
+ #include "utils.h"
+
+ extern char *optarg;
++struct global_options opt;
+
+ #ifdef WIN32
+ const static char * version = "0.6.2-w32";
diff --git a/net-misc/wput/files/wput-0.6.2-respect-destdir.patch b/net-misc/wput/files/wput-0.6.2-respect-destdir.patch
index f0cbfcdebd69..9cece1f388f8 100644
--- a/net-misc/wput/files/wput-0.6.2-respect-destdir.patch
+++ b/net-misc/wput/files/wput-0.6.2-respect-destdir.patch
@@ -1,5 +1,3 @@
-diff --git a/Makefile.in b/Makefile.in
-index 6756cd2..6debea8 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -16,12 +16,12 @@ win-clean:
diff --git a/net-misc/wput/files/wput-fix-crash.patch b/net-misc/wput/files/wput-fix-crash.patch
index 2afab8e59913..3d0efc9fd37f 100644
--- a/net-misc/wput/files/wput-fix-crash.patch
+++ b/net-misc/wput/files/wput-fix-crash.patch
@@ -1,6 +1,5 @@
-diff -ur wput-0.6.2+git20130413.orig/src/progress.c wput-0.6.2+git20130413/src/progress.c
---- wput-0.6.2+git20130413.orig/src/progress.c 2013-07-15 00:05:50.000000000 +0200
-+++ wput-0.6.2+git20130413/src/progress.c 2016-10-25 16:48:05.909105000 +0200
+--- a/src/progress.c
++++ b/src/progress.c
@@ -181,7 +181,7 @@
static char output[15];
time_t secs = time (NULL);
diff --git a/net-misc/wput/wput-0.6.1-r1.ebuild b/net-misc/wput/wput-0.6.1-r1.ebuild
index 4622df777968..4121f54eca36 100644
--- a/net-misc/wput/wput-0.6.1-r1.ebuild
+++ b/net-misc/wput/wput-0.6.1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-DESCRIPTION="Tiny program like wget, to upload files/whole directories via FTP"
+DESCRIPTION="Tiny program like wget to upload files/whole directories via FTP"
HOMEPAGE="http://wput.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
@@ -12,15 +12,14 @@ SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86"
IUSE="debug nls ssl"
+BDEPEND="nls? ( sys-devel/gettext )"
RDEPEND="ssl? ( net-libs/gnutls )"
-
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-0.6-gentoo.diff"
"${FILESDIR}/${PN}-0.6-respectldflags.patch"
+ "${FILESDIR}/${PN}-0.6.2-fno-common.patch"
)
DOCS=( ChangeLog INSTALL TODO )
@@ -33,7 +32,3 @@ src_configure() {
$(use_with ssl) \
"${myconf}"
}
-
-src_install() {
- default
-}
diff --git a/net-misc/wput/wput-0.6.2.ebuild b/net-misc/wput/wput-0.6.2.ebuild
index c95956b3e7b1..dd45712ffb43 100644
--- a/net-misc/wput/wput-0.6.2.ebuild
+++ b/net-misc/wput/wput-0.6.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DESCRIPTION="Tiny program like wget, to upload files/whole directories via FTP"
HOMEPAGE="http://wput.sourceforge.net/"
@@ -12,16 +12,15 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE="debug nls ssl"
+BDEPEND="nls? ( sys-devel/gettext )"
RDEPEND="ssl? ( net-libs/gnutls )"
-
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-0.6.2-respect-destdir.patch"
"${FILESDIR}/${PN}-0.6-respectldflags.patch"
"${FILESDIR}/${PN}-fix-crash.patch"
+ "${FILESDIR}/${PN}-0.6.2-fno-common.patch"
)
DOCS=( ChangeLog INSTALL TODO )