summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-31 05:00:07 +0100
committerSam James <sam@gentoo.org>2022-08-31 05:00:07 +0100
commit911a412a193cc5b347d57e2e662722a568412bf7 (patch)
tree7ae7c6a690fea01b22d94afd4d27f15362a02a37 /net-misc/udpcast
parentnet-proxy/squid: use Bash tests (diff)
downloadgentoo-911a412a193cc5b347d57e2e662722a568412bf7.tar.gz
gentoo-911a412a193cc5b347d57e2e662722a568412bf7.tar.bz2
gentoo-911a412a193cc5b347d57e2e662722a568412bf7.zip
net-misc/udpcast: add 20211207
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/udpcast')
-rw-r--r--net-misc/udpcast/Manifest1
-rw-r--r--net-misc/udpcast/files/udpcast-20211207-musl.patch33
-rw-r--r--net-misc/udpcast/udpcast-20211207.ebuild32
3 files changed, 66 insertions, 0 deletions
diff --git a/net-misc/udpcast/Manifest b/net-misc/udpcast/Manifest
index c3f55e7d574d..478a3604e175 100644
--- a/net-misc/udpcast/Manifest
+++ b/net-misc/udpcast/Manifest
@@ -1 +1,2 @@
DIST udpcast-20200328.tar.gz 169252 BLAKE2B df760dea814fabf951a65dc191a88355dec864d9c0f1be99ea60c742862d0b9944e51a45dd462ffce5c4b56a8d94f719796e3c725b42edae8cb9a19b1d3bc147 SHA512 b1ce4f0cade5db6bc69d3a154c354565675f44e97f9e3d90152f9594fd4f17fff2891eb1cb8d73c59e0d24eeb85e485e96b7a64fa9f1b6d2f005c4cece377bc7
+DIST udpcast-20211207.tar.gz 171148 BLAKE2B 96a7b1a30e19a2b83ce2ab7d8491ad430838f1305b83b728e6b43343404440b5a7fa9ee0afd0c00f8203937803a691065af31d7dc51633f26d019955e9ac8ed0 SHA512 89010c781d99a60e335213e88867c9114b51f3d75bd4ebfa38bcd1382e5925be4f316faf8c24ea55b087edb2115e18b5fd3cceac70a65371f91227528d218e89
diff --git a/net-misc/udpcast/files/udpcast-20211207-musl.patch b/net-misc/udpcast/files/udpcast-20211207-musl.patch
new file mode 100644
index 000000000000..9b0aaae59032
--- /dev/null
+++ b/net-misc/udpcast/files/udpcast-20211207-musl.patch
@@ -0,0 +1,33 @@
+https://git.busybox.net/buildroot/tree/package/udpcast/0001-fix-musl-build.patch?id=8d7be66f70cccbaf61e5cb6b2414b9d9ce162f48
+
+fix musl build
+
+Fix the following musl build failure:
+
+receivedata.c: In function 'findSlice':
+receivedata.c:348:2: error: unknown type name 'ptrdiff_t'
+ 348 | ptrdiff_t pos = slice - clst->slices;
+ | ^~~~~~~~~
+receivedata.c:17:1: note: 'ptrdiff_t' is defined in header '<stddef.h>'; did you forget to '#include <stddef.h>'?
+ 16 | #include "fec.h"
+ +++ |+#include <stddef.h>
+ 17 |
+
+Fixes:
+ - http://autobuild.buildroot.org/results/30208c6f175967fed6de690447a09e0c86547b24
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+[Upstream status:
+https://udpcast.linux.lu/mailman3/hyperkitty/list/udpcast@udpcast.linux.lu/thread/4MBES2CPUSUNIZTC7NXCQYS2GAE4DQSG/]
+
+--- a/receivedata.c
++++ b/receivedata.c
+@@ -1,6 +1,7 @@
+ #include <assert.h>
+ #include <sys/types.h>
+ #include <unistd.h>
++#include <stddef.h>
+ #include <stdlib.h>
+ #include <sys/time.h>
+ #include <errno.h>
+
diff --git a/net-misc/udpcast/udpcast-20211207.ebuild b/net-misc/udpcast/udpcast-20211207.ebuild
new file mode 100644
index 000000000000..e2165f829f27
--- /dev/null
+++ b/net-misc/udpcast/udpcast-20211207.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Multicast file transfer tool"
+HOMEPAGE="https://www.udpcast.linux.lu/"
+SRC_URI="https://www.udpcast.linux.lu/download/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hardened"
+
+BDEPEND="dev-lang/perl"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-musl.patch
+)
+
+src_configure() {
+ use hardened || append-cppflags -DUSE_ASSEMBLER
+
+ default
+}
+
+src_install() {
+ default
+ dodoc *.txt
+}