summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2016-08-17 16:13:30 -0400
committerIan Stakenvicius <axs@gentoo.org>2016-08-17 16:13:53 -0400
commitc772ac4e3d9c439779e97994d752a4b7afb645c4 (patch)
treebe5784896ed4b5c441887db0f663201c6fe3ba0d /net-misc/spice-gtk
parentdev-db/mysql: Verison bump for 5.6.32 (diff)
downloadgentoo-c772ac4e3d9c439779e97994d752a4b7afb645c4.tar.gz
gentoo-c772ac4e3d9c439779e97994d752a4b7afb645c4.tar.bz2
gentoo-c772ac4e3d9c439779e97994d752a4b7afb645c4.zip
net-misc/spice-gtk: explicitly link libX11 the right way for ld.gold
Bug: http://bugs.gentoo.org/585118 Package-Manager: portage-2.2.28
Diffstat (limited to 'net-misc/spice-gtk')
-rw-r--r--net-misc/spice-gtk/files/spice-gtk-0.31-x11-libs.patch34
-rw-r--r--net-misc/spice-gtk/files/spice-gtk-0.32-x11-libs.patch34
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.31.ebuild2
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.32-r1.ebuild1
-rw-r--r--net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild1
5 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/spice-gtk/files/spice-gtk-0.31-x11-libs.patch b/net-misc/spice-gtk/files/spice-gtk-0.31-x11-libs.patch
new file mode 100644
index 000000000000..0d7e715db4c1
--- /dev/null
+++ b/net-misc/spice-gtk/files/spice-gtk-0.31-x11-libs.patch
@@ -0,0 +1,34 @@
+--- a/configure.ac 2016-08-17 14:16:14.671302073 -0400
++++ b/configure.ac 2016-08-17 14:14:57.351587309 -0400
+@@ -151,8 +151,12 @@
+ SPICE_GTK_REQUIRES="${SPICE_GTK_REQUIRES} gtk+-$GTK_API_VERSION >= $GTK_REQUIRED"
+
+ PKG_CHECK_EXISTS([gtk+-x11-$with_gtk], [have_x11=yes], [have_x11=no])
+-AS_IF([test "x$have_x11" = "xyes"], [AC_DEFINE([HAVE_X11], 1, [Have x11?])])
++AS_IF([test "x$have_x11" = "xyes"], [
++AC_DEFINE([HAVE_X11], 1, [Have x11?])
++PKG_CHECK_MODULES(X11, x11)])
+ AM_CONDITIONAL([WITH_DISPLAY_X11], [test "x$have_x11" = "xyes"])
++AC_SUBST(X11_CFLAGS)
++AC_SUBST(X11_LIBS)
+
+ PKG_CHECK_EXISTS([gtk+-quartz-$with_gtk], [have_quartz=yes], [have_quartz=no])
+ AS_IF([test "x$have_quartz" = "xyes"], [AC_DEFINE([HAVE_QUARTZ], 1, [Have Quartz?])])
+--- a/src/Makefile.am 2016-02-18 10:29:04.000000000 -0500
++++ b/src/Makefile.am 2016-08-17 14:18:46.340742557 -0400
+@@ -103,6 +103,7 @@
+ $(GUDEV_CFLAGS) \
+ $(SOUP_CFLAGS) \
+ $(PHODAV_CFLAGS) \
++ $(X11_CFLAGS) \
+ $(LZ4_CFLAGS) \
+ $(NULL)
+
+@@ -123,6 +124,7 @@
+ $(GTK_LIBS) \
+ $(CAIRO_LIBS) \
+ $(EPOXY_LIBS) \
++ $(X11_LIBS) \
+ $(LIBM) \
+ $(NULL)
+
diff --git a/net-misc/spice-gtk/files/spice-gtk-0.32-x11-libs.patch b/net-misc/spice-gtk/files/spice-gtk-0.32-x11-libs.patch
new file mode 100644
index 000000000000..02ea218e5457
--- /dev/null
+++ b/net-misc/spice-gtk/files/spice-gtk-0.32-x11-libs.patch
@@ -0,0 +1,34 @@
+--- a/configure.ac 2016-06-16 07:34:31.000000000 -0400
++++ b/configure.ac 2016-08-17 15:41:03.322532729 -0400
+@@ -163,6 +163,13 @@
+ AM_CONDITIONAL([WITH_DISPLAY_WINDOWS], [test "x$have_win32" = "xyes"])
+
+ AC_CHECK_HEADERS([X11/XKBlib.h])
++AS_IF([test "x$have_quartz" != "xyes"],[
++ AS_IF([test "x$have_win32" != "xyes"],[
++ PKG_CHECK_MODULES(X11,x11)
++ ])
++])
++AC_SUBST(X11_CFLAGS)
++AC_SUBST(X11_LIBS)
+
+ AC_ARG_WITH([pnp-ids-path],
+ AC_HELP_STRING([--with-pnp-ids-path],
+--- a/src/Makefile.am 2016-08-17 15:44:42.081663331 -0400
++++ b/src/Makefile.am 2016-08-17 15:45:24.701493950 -0400
+@@ -100,6 +100,7 @@
+ $(GUDEV_CFLAGS) \
+ $(SOUP_CFLAGS) \
+ $(PHODAV_CFLAGS) \
++ $(X11_CFLAGS) \
+ $(LZ4_CFLAGS) \
+ $(NULL)
+
+@@ -119,6 +120,7 @@
+ libspice-client-glib-2.0.la \
+ $(GTK_LIBS) \
+ $(CAIRO_LIBS) \
++ $(X11_LIBS) \
+ $(LIBM) \
+ $(NULL)
+
diff --git a/net-misc/spice-gtk/spice-gtk-0.31.ebuild b/net-misc/spice-gtk/spice-gtk-0.31.ebuild
index 332eca91a944..3682e02a36a3 100644
--- a/net-misc/spice-gtk/spice-gtk-0.31.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.31.ebuild
@@ -45,6 +45,7 @@ RDEPEND="
x11-libs/gtk+:2[introspection?]
>=dev-libs/glib-2.28:2
>=x11-libs/cairo-1.2
+ x11-libs/libX11
virtual/jpeg:0=
sys-libs/zlib
introspection? ( dev-libs/gobject-introspection )
@@ -89,6 +90,7 @@ DEPEND="${RDEPEND}
addpredict /dev
src_prepare() {
+ epatch "${FILESDIR}"/${P}-x11-libs.patch
epatch_user
AT_NO_RECURSIVE="yes" eautoreconf
diff --git a/net-misc/spice-gtk/spice-gtk-0.32-r1.ebuild b/net-misc/spice-gtk/spice-gtk-0.32-r1.ebuild
index 78477567311b..0fac3468ebeb 100644
--- a/net-misc/spice-gtk/spice-gtk-0.32-r1.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.32-r1.ebuild
@@ -80,6 +80,7 @@ DEPEND="${RDEPEND}
addpredict /dev
src_prepare() {
+ epatch "${FILESDIR}"/${P}-x11-libs.patch
epatch_user
AT_NO_RECURSIVE="yes" eautoreconf
diff --git a/net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild b/net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild
index 33d4a5b829ed..ea87c5ac53e0 100644
--- a/net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild
+++ b/net-misc/spice-gtk/spice-gtk-0.32-r2.ebuild
@@ -84,6 +84,7 @@ DEPEND="${RDEPEND}
addpredict /dev
src_prepare() {
+ epatch "${FILESDIR}"/${P}-x11-libs.patch
epatch_user
AT_NO_RECURSIVE="yes" eautoreconf