summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-02 23:50:39 +0000
committerSam James <sam@gentoo.org>2021-11-02 23:50:39 +0000
commitd6c27e19c12facf2816d715ba475eb1193af316a (patch)
treef2e5042e1cf3327dbbc0fe8dbc428bd1374eebea /net-misc/socat
parentwww-client/firefox: bump to v91.3.0 ESR (diff)
downloadgentoo-d6c27e19c12facf2816d715ba475eb1193af316a.tar.gz
gentoo-d6c27e19c12facf2816d715ba475eb1193af316a.tar.bz2
gentoo-d6c27e19c12facf2816d715ba475eb1193af316a.zip
net-misc/socat: add 1.7.4.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/socat')
-rw-r--r--net-misc/socat/Manifest1
-rw-r--r--net-misc/socat/socat-1.7.4.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/net-misc/socat/Manifest b/net-misc/socat/Manifest
index a47d4af7a88d..6a41e2eecbf2 100644
--- a/net-misc/socat/Manifest
+++ b/net-misc/socat/Manifest
@@ -1,3 +1,4 @@
DIST socat-1.7.3.4.tar.bz2 490552 BLAKE2B 68db1674a3156b28c10340e515f346de83d4e953570f3a3cdee9402db9f276285a8f46db14978b4651df6d0fa90fb496696f151afb3e826172daa444ee35e666 SHA512 f338d28e5fd9d7ebb9e30b0fa700bcd5ff50ff9e668403474963a3310ba2b5f68b5236b928872c18e4b1ee95328374987e7e263ac7655a0d9b3fc9da77281123
DIST socat-1.7.4.1.tar.bz2 510101 BLAKE2B 9b7ca0a0add173c39d736d470079bf8e1330a8b11497128cc2b5edb019277682697f1f71f6d3d4a526a74a7297e4aace25493acea98ea95a885c52e5a9c34568 SHA512 7fa069bff294a01baebfd790faed027391ab1f47f09f0990e6dcb1c7cce5f3cdc20638fecb10e82c10b6342d903de9481f6d85a0debcc0368c882417dafbc756
+DIST socat-1.7.4.2.tar.gz 653068 BLAKE2B 0eba89e2f8993e6c5f2ffaa57ca9e93ae89cb01bf9d6f0f0d5e9550d4cd7e6aa390b26120a47e3661772550f4fb189807bedd31d1477ff0065f478ef2be062ab SHA512 c331a6348e0febb35cd8adc2b116e3b8896cd7f64bcd93e507df4b8197ee1e6738ca256abf74c9b225e7a3769cf9643f0e237826125c6f390b5124ce0f10c972
DIST socat-2.0.0-b9.tar.bz2 516673 BLAKE2B 808c8821b89ae2463074f87915dfae10f82b66ac6cd0b6ff56ab18f57c704e5a2a3ce76650152dccce41e4bd00e3a937948d4ade0a915b1f0e917c7543c6fc31 SHA512 f728bd634feeeacd2f0e4020c1c6aafdadaef3ba9da818d9ae1195e9f48fb693b2bea8dbbb208af8daddd8d6405217113d5ce31d05c2e9b27f5d2fba6b1cc834
diff --git a/net-misc/socat/socat-1.7.4.2.ebuild b/net-misc/socat/socat-1.7.4.2.ebuild
new file mode 100644
index 000000000000..fbf589fadca9
--- /dev/null
+++ b/net-misc/socat/socat-1.7.4.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+MY_P=${P/_beta/-b}
+DESCRIPTION="Multipurpose relay (SOcket CAT)"
+HOMEPAGE="http://www.dest-unreach.org/socat/ https://repo.or.cz/socat.git"
+SRC_URI="http://www.dest-unreach.org/socat/download/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="bindist ipv6 readline ssl tcpd"
+
+DEPEND="ssl? ( dev-libs/openssl:0= )
+ readline? ( sys-libs/readline:= )
+ tcpd? ( sys-apps/tcp-wrappers )"
+RDEPEND="${DEPEND}"
+
+# Tests are a large bash script
+# Hard to disable individual tests needing network or privileges
+# in 1.7.4.2: FAILED: 59 329
+RESTRICT="test ssl? ( readline? ( bindist ) )"
+
+DOCS=( BUGREPORTS CHANGES DEVELOPMENT EXAMPLES FAQ FILES PORTING README SECURITY )
+
+pkg_setup() {
+ # bug #587740
+ if use readline && use ssl ; then
+ elog "You are enabling both readline and openssl USE flags, the licenses"
+ elog "for these packages conflict. You may not be able to legally"
+ elog "redistribute the resulting binary."
+ fi
+}
+
+src_configure() {
+ # bug #293324
+ filter-flags '-Wno-error*'
+
+ tc-export AR
+
+ econf \
+ $(use_enable ssl openssl) \
+ $(use_enable readline) \
+ $(use_enable ipv6 ip6) \
+ $(use_enable tcpd libwrap)
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc doc/*.html doc/*.css
+}