summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-08 19:35:43 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-08 19:36:00 +0200
commite0555bdfc4695a025541918c967e3e415f026397 (patch)
tree92be210712b7f5ae311df48b19d996cb19a1867c /net-misc/sks/files
parentx11-libs/gtk+: remove old (diff)
downloadgentoo-e0555bdfc4695a025541918c967e3e415f026397.tar.gz
gentoo-e0555bdfc4695a025541918c967e3e415f026397.tar.bz2
gentoo-e0555bdfc4695a025541918c967e3e415f026397.zip
net-misc/sks: use ocamlfind for link and build.
Fixes build with latest cryptokit. Improve a bit dependencies too. Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-misc/sks/files')
-rw-r--r--net-misc/sks/files/sks-1.1.6-use-ocamlfind.patch39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-misc/sks/files/sks-1.1.6-use-ocamlfind.patch b/net-misc/sks/files/sks-1.1.6-use-ocamlfind.patch
new file mode 100644
index 000000000000..c9afc2594091
--- /dev/null
+++ b/net-misc/sks/files/sks-1.1.6-use-ocamlfind.patch
@@ -0,0 +1,39 @@
+Use ocamlfind for finding dependencies, esp. for doing their transitive closure.
+
+Ideally the build system should be converted to something more modern like
+jbuilder.
+
+Index: sks-1.1.6/Makefile
+===================================================================
+--- sks-1.1.6.orig/Makefile
++++ sks-1.1.6/Makefile
+@@ -21,10 +21,10 @@ CFLAGS=-O3 $(CINCLUDES) -I .
+ CXXFLAGS=-O3 $(CINCLUDES) -I .
+
+ ifndef OCAMLC
+- OCAMLC=ocamlc
++ OCAMLC=ocamlfind ocamlc
+ endif
+ ifndef OCAMLOPT
+- OCAMLOPT=ocamlopt
++ OCAMLOPT=ocamlfind ocamlopt
+ endif
+ ifndef CAMLP4O
+ CAMLP4O=camlp4o
+@@ -55,12 +55,12 @@ WARNERR=-warn-error A
+ endif
+
+ CAMLP4=-pp $(CAMLP4O)
+-CAMLINCLUDE= -I lib -I bdb -I +cryptokit
++CAMLINCLUDE= -package cryptokit,unix,str,bigarray -I lib -I bdb
+ COMMONCAMLFLAGS=$(CAMLINCLUDE) $(OCAMLLIB) $(CAMLLDFLAGS) -ccopt -Lbdb -dtypes $(WARNERR)
+ OCAMLDEP=ocamldep $(CAMLP4)
+-CAMLLIBS=unix.cma str.cma bdb.cma nums.cma bigarray.cma cryptokit.cma
+-OCAMLFLAGS=$(COMMONCAMLFLAGS) -g $(CAMLLIBS)
+-OCAMLOPTFLAGS=$(COMMONCAMLFLAGS) -inline 40 $(CAMLLIBS:.cma=.cmxa)
++CAMLLIBS=bdb.cma nums.cma
++OCAMLFLAGS=$(COMMONCAMLFLAGS) -linkpkg -g $(CAMLLIBS)
++OCAMLOPTFLAGS=$(COMMONCAMLFLAGS) -linkpkg -inline 40 $(CAMLLIBS:.cma=.cmxa)
+
+ EXE=sks sks_add_mail
+ ALL=$(EXE) sks.8.gz