summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2020-08-24 09:31:59 -0400
committerRichard Freeman <rich0@gentoo.org>2020-08-24 09:35:57 -0400
commit5c97602245546d9aec9831d21640e6d1c38c1247 (patch)
tree4c8f0b005fe67a849e6610e484e3bd0172681ced /net-misc/s3cmd
parentdev-python/inflection: bump to 0.5.1 (diff)
downloadgentoo-5c97602245546d9aec9831d21640e6d1c38c1247.tar.gz
gentoo-5c97602245546d9aec9831d21640e6d1c38c1247.tar.bz2
gentoo-5c97602245546d9aec9831d21640e6d1c38c1247.zip
net-misc/s3cmd: bump, python3.7+ support
Closes: https://bugs.gentoo.org/718450 Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'net-misc/s3cmd')
-rw-r--r--net-misc/s3cmd/Manifest1
-rw-r--r--net-misc/s3cmd/metadata.xml4
-rw-r--r--net-misc/s3cmd/s3cmd-2.1.0.ebuild23
3 files changed, 28 insertions, 0 deletions
diff --git a/net-misc/s3cmd/Manifest b/net-misc/s3cmd/Manifest
index bfe21ffa3f4b..1c0623b6a94d 100644
--- a/net-misc/s3cmd/Manifest
+++ b/net-misc/s3cmd/Manifest
@@ -1 +1,2 @@
DIST s3cmd-2.0.2.tar.gz 124266 BLAKE2B ab5921f22af05007c57df84ab4df559f31a8b7f05427fa06fa7428d41de788e4824b6285b69de592ed84d72733d3ae455a20c017dd9cecf2e4e073bff5016fb0 SHA512 4cd155f4e24e462fcab009b5ae0844718b728134cf436a4c43a9380c178c2172bb5bccc780f0f174cb43793554cb4f9b5ca432c757c9e5a4a8eaa4efe656133d
+DIST s3cmd-2.1.0.tar.gz 127120 BLAKE2B 4282f616eb7ca97fa0d529a2c5acc1359f88888d182b62e1fa7d3f7401a93852a4e0724363a4c6f0a6520d6aef290d64e1775cb252fc0fbaa4b94762402c381e SHA512 98156218c4379e233185662d29fa4299b4a4e45a0fe143a145f30ff7d03362a4558b5fff5e5da0da850f5cce2c760fcd031bcf5ff7a6bd2c6352259e791d65e6
diff --git a/net-misc/s3cmd/metadata.xml b/net-misc/s3cmd/metadata.xml
index a669dac0de29..8d26ba9964fb 100644
--- a/net-misc/s3cmd/metadata.xml
+++ b/net-misc/s3cmd/metadata.xml
@@ -9,6 +9,10 @@
<email>titanofold@gentoo.org</email>
<name>Aaron W. Swenson</name>
</maintainer>
+ <maintainer type="person">
+ <email>rich0@gentoo.org</email>
+ <name>Rich Freeman</name>
+ </maintainer>
<maintainer type="project">
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
diff --git a/net-misc/s3cmd/s3cmd-2.1.0.ebuild b/net-misc/s3cmd/s3cmd-2.1.0.ebuild
new file mode 100644
index 000000000000..52463ca60029
--- /dev/null
+++ b/net-misc/s3cmd/s3cmd-2.1.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 python3_9 )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Command line client for Amazon S3"
+HOMEPAGE="https://s3tools.org/s3cmd"
+SRC_URI="mirror://sourceforge/s3tools/${P/_/-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86 ~amd64-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-magic[${PYTHON_USEDEP}]"
+
+S="$WORKDIR/${P/_/-}"