summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-06-18 08:26:45 -0500
committerBen Kohler <bkohler@gentoo.org>2020-06-18 08:27:28 -0500
commit0eae940a426b85831abb2deea89fdcbbcd55b4e4 (patch)
treecff7151735ab47537fa76074e03b51e04534ac81 /net-misc/remmina
parentdev-perl/Class-DBI-Plugin-DeepAbstractSearch: -r bump for EAPI7 (diff)
downloadgentoo-0eae940a426b85831abb2deea89fdcbbcd55b4e4.tar.gz
gentoo-0eae940a426b85831abb2deea89fdcbbcd55b4e4.tar.bz2
gentoo-0eae940a426b85831abb2deea89fdcbbcd55b4e4.zip
net-misc/remmina: add patch for USE=examples
Also drop (afaik) unneeded xdg_src_prepare as it caused double-applied patches & is not needed. Closes: https://bugs.gentoo.org/727870 Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-misc/remmina')
-rw-r--r--net-misc/remmina/files/remmina-1.4.6-with-examples.patch34
-rw-r--r--net-misc/remmina/remmina-1.4.6.ebuild2
2 files changed, 35 insertions, 1 deletions
diff --git a/net-misc/remmina/files/remmina-1.4.6-with-examples.patch b/net-misc/remmina/files/remmina-1.4.6-with-examples.patch
new file mode 100644
index 000000000000..259ef19e0fc8
--- /dev/null
+++ b/net-misc/remmina/files/remmina-1.4.6-with-examples.patch
@@ -0,0 +1,34 @@
+diff -Nupr a/plugins/tool_hello_world/plugin.c b/plugins/tool_hello_world/plugin.c
+--- a/plugins/tool_hello_world/plugin.c 2020-06-08 22:07:44.000000000 +0200
++++ b/plugins/tool_hello_world/plugin.c 2020-06-10 20:18:48.495507560 +0200
+@@ -42,17 +42,19 @@
+ #include <gdk/gdkx.h>
+
+ static RemminaPluginService *remmina_plugin_service = NULL;
++#define remmina_plugin_debug(fmt, ...) remmina_plugin_service->_remmina_debug(__func__, fmt __VA_OPT__(,) __VA_ARGS__)
++
+
+ static void remmina_plugin_tool_init(RemminaProtocolWidget *gp)
+ {
+ TRACE_CALL(__func__);
+- remmina_plugin_service->_debug("[%s] Plugin init", PLUGIN_NAME);
++ remmina_plugin_debug("[%s] Plugin init", PLUGIN_NAME);
+ }
+
+ static gboolean remmina_plugin_tool_open_connection(RemminaProtocolWidget *gp)
+ {
+ TRACE_CALL(__func__);
+- remmina_plugin_service->_debug("[%s] Plugin open connection", PLUGIN_NAME);
++ remmina_plugin_debug("[%s] Plugin open connection", PLUGIN_NAME);
+
+ GtkDialog *dialog;
+ dialog = GTK_DIALOG(gtk_message_dialog_new(NULL, GTK_DIALOG_MODAL | GTK_DIALOG_USE_HEADER_BAR,
+@@ -65,7 +67,7 @@ static gboolean remmina_plugin_tool_open
+ static gboolean remmina_plugin_tool_close_connection(RemminaProtocolWidget *gp)
+ {
+ TRACE_CALL(__func__);
+- remmina_plugin_service->_debug("[%s] Plugin close connection", PLUGIN_NAME);
++ remmina_plugin_debug("[%s] Plugin close connection", PLUGIN_NAME);
+ remmina_plugin_service->protocol_plugin_emit_signal(gp, "disconnect");
+ return FALSE;
+ }
diff --git a/net-misc/remmina/remmina-1.4.6.ebuild b/net-misc/remmina/remmina-1.4.6.ebuild
index f429622f2dc7..b1bcb852ddfc 100644
--- a/net-misc/remmina/remmina-1.4.6.ebuild
+++ b/net-misc/remmina/remmina-1.4.6.ebuild
@@ -54,12 +54,12 @@ RDEPEND="
"
DOCS=( AUTHORS CHANGELOG.md README.md THANKS.md )
+PATCHES=( "${FILESDIR}"/${P}-with-examples.patch )
S="${WORKDIR}/${MY_P}"
src_prepare() {
cmake_src_prepare
- xdg_src_prepare
}
src_configure() {