summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKai-Chun Ning <kaichun.ning@gmail.com>2022-12-15 03:59:58 +0100
committerSam James <sam@gentoo.org>2023-02-03 20:00:56 +0000
commit63b92751efdec4243fb8b2b528d121213e307de1 (patch)
treef1d06e45358222cc077084ee06658eadd15715bb /net-misc/pssh
parentmedia-gfx/scour: update EAPI 7 -> 8 (diff)
downloadgentoo-63b92751efdec4243fb8b2b528d121213e307de1.tar.gz
gentoo-63b92751efdec4243fb8b2b528d121213e307de1.tar.bz2
gentoo-63b92751efdec4243fb8b2b528d121213e307de1.zip
net-misc/pssh: bump PYTHON_COMPAT to 3.11
Signed-off-by: Kai-Chun Ning <kaichun.ning@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28667 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/pssh')
-rw-r--r--net-misc/pssh/pssh-2.3.4-r2.ebuild (renamed from net-misc/pssh/pssh-2.3.4-r1.ebuild)16
1 files changed, 6 insertions, 10 deletions
diff --git a/net-misc/pssh/pssh-2.3.4-r1.ebuild b/net-misc/pssh/pssh-2.3.4-r2.ebuild
index 7a23ad7b74d7..69f1cc97ee51 100644
--- a/net-misc/pssh/pssh-2.3.4-r1.ebuild
+++ b/net-misc/pssh/pssh-2.3.4-r2.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{9,10} )
DISTUTILS_SINGLE_IMPL=1
-
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
DESCRIPTION="PSSH provides parallel versions of OpenSSH and related tools"
@@ -15,19 +14,16 @@ SRC_URI="https://github.com/lilydjwg/pssh/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-RDEPEND="net-misc/openssh
- !net-misc/putty"
+RDEPEND="
+ !net-misc/putty
+ net-misc/openssh
+"
DEPEND="${RDEPEND}"
# Requires ssh access to run.
RESTRICT="test"
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
python_prepare_all() {
sed -i -e "s|man/man1'|share/&|g" setup.py || die
distutils-r1_python_prepare_all