summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-02-14 10:01:19 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-02-14 10:01:19 +0100
commit2d40f41f21e25e926e62d451f054fa1dd94e6480 (patch)
tree510980b16c3bf04883ba17134a09eca8635d2dcf /net-misc/pps-tools
parentdev-ruby/capybara: add 2.18.0 (diff)
downloadgentoo-2d40f41f21e25e926e62d451f054fa1dd94e6480.tar.gz
gentoo-2d40f41f21e25e926e62d451f054fa1dd94e6480.tar.bz2
gentoo-2d40f41f21e25e926e62d451f054fa1dd94e6480.zip
net-misc/pps-tools: Bump to version 1.0.2
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-misc/pps-tools')
-rw-r--r--net-misc/pps-tools/Manifest1
-rw-r--r--net-misc/pps-tools/files/pps-tools-1.0.2-build.patch50
-rw-r--r--net-misc/pps-tools/pps-tools-1.0.2.ebuild25
3 files changed, 76 insertions, 0 deletions
diff --git a/net-misc/pps-tools/Manifest b/net-misc/pps-tools/Manifest
index 528ecf65b9aa..b825b2142ec9 100644
--- a/net-misc/pps-tools/Manifest
+++ b/net-misc/pps-tools/Manifest
@@ -1,2 +1,3 @@
DIST pps-tools-1.0.1.tar.gz 12695 BLAKE2B 8c05f037b03efc2685bf303f521e168e6c56c203665482fa456278e3580fba8d2fc04935b7f32b70b6ac50c28d4f998a2808f5e3034dcffad4ff1589fd8f2907 SHA512 6fe7eba2a1a073a64d40bcc7aef12981414b43656f05fbd84e3ffadf1a074c5aa8d032b39a37095e6846194558b685092b51799fe724fe50cce8f3cbe163f784
+DIST pps-tools-1.0.2.tar.gz 12701 BLAKE2B bc60a9ea94bb57bcc2b7870da433ef04fbbc30e5c4d880b719a8e7fcabba0bef2996c086e6993b879f2515cd0c685659bfed5371904401e35120ae1e9dc0891a SHA512 fa86455ece83700d5a1c522082f78ed324927fb9f53d3cf5f615a566a39e54938a41e82b6d4ae23d57c273fb923f96db4ca2d071199795d020952703afa53fcb
DIST pps-tools-git-0.0.20120407.tar.gz 13619 BLAKE2B 9be7aacbcdb1c5ac2e53c66f97ba6c41f30c67b7d229f4f9797260d9b880a921e679e1c6cf847051fab0746cb2d9da0f4450411f4e992e42b0b5314bf6acf7cd SHA512 d2014262b0594959f337c25df859591d0737994decec663389392d3c7e53376ded2485713f6364c4833d8d7c40b4b0c3b88865ab85e481bcc2e81e35931d84de
diff --git a/net-misc/pps-tools/files/pps-tools-1.0.2-build.patch b/net-misc/pps-tools/files/pps-tools-1.0.2-build.patch
new file mode 100644
index 000000000000..a62a6bb561cf
--- /dev/null
+++ b/net-misc/pps-tools/files/pps-tools-1.0.2-build.patch
@@ -0,0 +1,50 @@
+From 5deb13d9d980a595946ff58e4e6d83f9d770ff10 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Wed, 14 Feb 2018 09:35:34 +0100
+Subject: [PATCH] fix up makefile
+
+Make sure we respect CFLAGS/CPPFLAGS properly.
+
+Also fix up the depend include so we get reproducible behavior --
+the depend file is generated & included first, and we don't get
+weird behavior when we run:
+ git clean -x -d
+ make
+ make
+---
+ Makefile | 11 +++++------
+ 1 file changed, 5 insertions(+), 6 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 9394668..af3ae56 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,8 +1,9 @@
+ TARGETS = ppstest ppsctl ppswatch ppsldisc
+
+-CFLAGS += -Wall -O2 -D_GNU_SOURCE
+-CFLAGS += -ggdb
++CFLAGS ?= -O2 -ggdb
++CFLAGS += -Wall
+ CFLAGS += -fPIC
++CPPFLAGS += -D_GNU_SOURCE
+ LDLIBS += -lm
+
+ # -- Actions section --
+@@ -12,11 +13,9 @@ LDLIBS += -lm
+ all : .depend $(TARGETS)
+
+ .depend depend dep :
+- $(CC) $(CFLAGS) -M $(TARGETS:=.c) > .depend
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -M $(TARGETS:=.c) > .depend
+
+-ifeq (.depend,$(wildcard .depend))
+-include .depend
+-endif
++-include .depend
+
+ install : all
+ install -m 755 -t $(DESTDIR)/usr/bin ppsfind $(TARGETS)
+--
+2.16.1
+
diff --git a/net-misc/pps-tools/pps-tools-1.0.2.ebuild b/net-misc/pps-tools/pps-tools-1.0.2.ebuild
new file mode 100644
index 000000000000..7291f8a36e61
--- /dev/null
+++ b/net-misc/pps-tools/pps-tools-1.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit toolchain-funcs
+
+DESCRIPTION="User-space tools for LinuxPPS"
+HOMEPAGE="https://github.com/redlab-i/pps-tools"
+SRC_URI="https://github.com/redlab-i/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.2-build.patch
+ "${FILESDIR}"/${PN}-1.0.1-install.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}