summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-27 05:38:26 +0100
committerSam James <sam@gentoo.org>2022-08-27 05:38:41 +0100
commit44fb159ff248f157e6808603edeae25719310751 (patch)
tree3fe74a0d67068b651e9d58a00c448508be6aedfe /net-misc/openrsync/openrsync-0.5.0_p20220508.ebuild
parentmedia-sound/pianobar: dropped obsolete 2020.04.05 (diff)
downloadgentoo-44fb159ff248f157e6808603edeae25719310751.tar.gz
gentoo-44fb159ff248f157e6808603edeae25719310751.tar.bz2
gentoo-44fb159ff248f157e6808603edeae25719310751.zip
net-misc/openrsync: new package, add 0.5.0_p20220508
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/openrsync/openrsync-0.5.0_p20220508.ebuild')
-rw-r--r--net-misc/openrsync/openrsync-0.5.0_p20220508.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/openrsync/openrsync-0.5.0_p20220508.ebuild b/net-misc/openrsync/openrsync-0.5.0_p20220508.ebuild
new file mode 100644
index 000000000000..bfbf341c0781
--- /dev/null
+++ b/net-misc/openrsync/openrsync-0.5.0_p20220508.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="BSD-licensed implementation of rsync"
+HOMEPAGE="https://www.openrsync.org/"
+
+if [[ ${PV} == *_p* ]] ; then
+ MY_COMMIT="f50d0f8204ea18306a0c29c6ae850292ea826995"
+ SRC_URI="https://github.com/kristapsdz/openrsync/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${MY_COMMIT}
+else
+ SRC_URI="https://github.com/kristapsdz/openrsync/archive/refs/tags/VERSION_$(ver_rs 3 _).tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.0_p20220508-extern-stdint-include.patch
+)
+
+src_configure() {
+ tc-export CC
+
+ local confargs=(
+ PREFIX="${EPREFIX}"/usr
+ MANDIR="${EPREFIX}"/usr/share/man
+ )
+
+ edo ./configure "${confargs[@]}"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}