summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-03-19 01:12:36 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-03-19 01:12:36 +0100
commite2eeca2b2ba588a70f3ac403114b61decbf5e9f2 (patch)
treef194e70df65469b8b234a86c4bcb6172d412dab5 /net-misc/nx
parentnet-misc/nx: fix musl build (diff)
downloadgentoo-e2eeca2b2ba588a70f3ac403114b61decbf5e9f2.tar.gz
gentoo-e2eeca2b2ba588a70f3ac403114b61decbf5e9f2.tar.bz2
gentoo-e2eeca2b2ba588a70f3ac403114b61decbf5e9f2.zip
net-misc/nx: drop 3.5.99.25
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-misc/nx')
-rw-r--r--net-misc/nx/Manifest1
-rw-r--r--net-misc/nx/nx-3.5.99.25.ebuild141
2 files changed, 0 insertions, 142 deletions
diff --git a/net-misc/nx/Manifest b/net-misc/nx/Manifest
index 2ed611fcd37c..a26e72b420fc 100644
--- a/net-misc/nx/Manifest
+++ b/net-misc/nx/Manifest
@@ -1,2 +1 @@
-DIST nx-libs-3.5.99.25.tar.gz 11065489 BLAKE2B 9210441fd2dc38fec14c90018ead4e3ddacd5ac266a26b1d985f874af0abdef3fdc2255614e45ec23816f1194ebe6ffe2beb776901eb1ed206658e8175b1ff57 SHA512 142378ae9a81542ed1bc969e9fcb2d421f1d63f7d46185c80e1e07493298e62379697ca2a367301c0f3df631acb19510113f3852922454fdc964767c36a81004
DIST nx-libs-3.5.99.26.tar.gz 11070624 BLAKE2B f67f522b127858aa2ddf1c9723468a74722a5ef2fa1e7f438844a8e5b05b868cacac22abf2c604c67d5e83a346217b192773f5debe67945d085768ae43205cb7 SHA512 1aead6161e4d7b8d7229ff80937935b23ad1f87135a578ae483a00348d0df7de35e9f9b78c47c473fda3ab2cc896ef23e845cc5656344a43520b091af9663211
diff --git a/net-misc/nx/nx-3.5.99.25.ebuild b/net-misc/nx/nx-3.5.99.25.ebuild
deleted file mode 100644
index 90e978be610a..000000000000
--- a/net-misc/nx/nx-3.5.99.25.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit autotools toolchain-funcs
-
-DESCRIPTION="NX compression technology core libraries"
-HOMEPAGE="https://github.com/ArcticaProject/nx-libs"
-
-SRC_URI="https://github.com/ArcticaProject/nx-libs/archive/${PV}.tar.gz -> nx-libs-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~ppc x86"
-
-RDEPEND="dev-libs/libxml2
- >=media-libs/libpng-1.2.8:0=
- >=sys-libs/zlib-1.2.3
- virtual/jpeg:*
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXdmcp
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libXfont2
- x11-libs/libXinerama
- x11-libs/libXpm
- x11-libs/libXrandr
- x11-libs/libXrender
- x11-libs/libXtst
- x11-libs/pixman"
-
-DEPEND="${RDEPEND}
- x11-base/xorg-proto
- x11-libs/libfontenc"
-
-BDEPEND="sys-apps/which
- virtual/pkgconfig
- x11-misc/gccmakedep
- x11-misc/imake"
-
-S="${WORKDIR}/nx-libs-${PV}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-3.5.99.25-musl.patch"
-)
-
-src_prepare() {
- default
-
- # We want predictable behavior. So let's assume we never
- # have quilt installed.
- sed 's@which quilt@false@' -i mesa-quilt || die
-
- # Do not compress man pages by default
- sed '/^[[:space:]]*gzip.*man/d' -i Makefile || die
-
- # run autoreconf in all needed folders
- local subdir
- for subdir in nxcomp nxdialog nx-X11/lib nxcompshad nxproxy ; do
- pushd ${subdir} || die
- eautoreconf
- popd || die
- done
-}
-
-src_configure() {
- # From xorg-x11-6.9.0-r3.ebuild
- pushd nx-X11 || die
- HOSTCONF="config/cf/host.def"
- echo "#define CcCmd $(tc-getCC)" >> ${HOSTCONF}
- echo "#define OptimizedCDebugFlags ${CFLAGS} GccAliasingArgs" >> ${HOSTCONF}
- echo "#define OptimizedCplusplusDebugFlags ${CXXFLAGS} GccAliasingArgs" >> ${HOSTCONF}
- # Respect LDFLAGS
- echo "#define ExtraLoadFlags ${LDFLAGS}" >> ${HOSTCONF}
- echo "#define SharedLibraryLoadFlags -shared ${LDFLAGS}" >> ${HOSTCONF}
- # Disable SunRPC, #370767
- echo "#define HasSecureRPC NO" >> ${HOSTCONF}
- popd || die
-
- local subdir
- for subdir in nxcomp nxdialog nxcompshad nxproxy ; do
- pushd ${subdir} || die
- econf
- popd || die
- done
-
- pushd "nx-X11/lib" || die
- econf --disable-poll
- popd || die
-}
-
-src_compile() {
- # First set up the build environment
- emake build-env
-
- # We replicate the "build-full" make target here because
- # we cannot call "make build-full" as it
- # - calls autoreconf several times
- # - invokes make directly but we prefer our emake
-
- emake -C nxcomp
- emake -C nx-X11/lib
-
- mkdir -p nx-X11/exports/lib/ || die
- local nxlib
- for nxlib in libNX_X11.so{,.6{,.3.0}} ; do
- ln -s ../../lib/src/.libs/${nxlib} nx-X11/exports/lib/${nxlib} || die
- done
-
- emake -C nxcompshad
-
- ./mesa-quilt push -a || die
-
- emake -C nx-X11 BuildDependsOnly
- # Parallel make issue resurfaced, upstream working on autotools switch
- emake -j1 -C nx-X11 World \
- USRLIBDIR="${EPREFIX}/usr/$(get_libdir)/${PN}/X11" \
- SHLIBDIR="${EPREFIX}/usr/$(get_libdir)" \
- ETCDIR_NX="${EPREFIX}/etc/nxagent"
-
- emake -C nxproxy
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- PREFIX="${EPREFIX}/usr" \
- NXLIBDIR="${EPREFIX}/usr/$(get_libdir)/${PN}" \
- SHLIBDIR="${EPREFIX}/usr/$(get_libdir)" \
- USRLIBDIR="${EPREFIX}/usr/$(get_libdir)/${PN}/X11" \
- ETCDIR_NX="${EPREFIX}/etc/nxagent" \
- install
-
- # Already provided by mesa & related packages
- rm -r "${ED}"/usr/include/GL || die
-
- # Get rid of libtool files and static libs.
- find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
-}