summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-16 19:48:35 -0300
committerMatt Turner <mattst88@gentoo.org>2023-09-16 19:00:39 -0400
commit72529cb45bc79b8fcbb5ba8fdf481014c9bb890f (patch)
treec4af9dd25a2e518cb56b020698d5b0c0e00cff39 /net-misc/gnome-connections
parentdev-python/werkzeug: Stabilize 2.3.7 sparc, #914331 (diff)
downloadgentoo-72529cb45bc79b8fcbb5ba8fdf481014c9bb890f.tar.gz
gentoo-72529cb45bc79b8fcbb5ba8fdf481014c9bb890f.tar.bz2
gentoo-72529cb45bc79b8fcbb5ba8fdf481014c9bb890f.zip
net-misc/gnome-connections: Version bump to 45.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32860 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-misc/gnome-connections')
-rw-r--r--net-misc/gnome-connections/Manifest1
-rw-r--r--net-misc/gnome-connections/gnome-connections-45.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/gnome-connections/Manifest b/net-misc/gnome-connections/Manifest
index 49db12c1aa25..b1d0a5e14f19 100644
--- a/net-misc/gnome-connections/Manifest
+++ b/net-misc/gnome-connections/Manifest
@@ -1,2 +1,3 @@
DIST gnome-connections-44.1.tar.xz 3999000 BLAKE2B 62f811a5cf530d3b38b576217d004d982f051a12bd3e525499d7fa4466538a1c8a2d4713f15cb0862d753f06a1f624f8fa87b80498ecbb461e7e7a545cb8c4d5 SHA512 34878e51ae67b222f8c5a00524bf2f3f24b9bc989ceccd707028ecdec612d81d3dc5e187e000f6e870e1cf816a66342cb8e9e9aaf7a6296950e1efa5b8a0d47e
+DIST gnome-connections-45.0.tar.xz 4009108 BLAKE2B 10f3f98df6fd6a090c226192229c3eeba7d707c1a109eaaf3a6427b9eadd375a136da9f089b904b66d9e94f27b9b6f982f1c0392ac9eb00936f46450b48bfbf6 SHA512 a2c5f8cd3076fc370cdd34f909bd02d07b9391a606133a46d17a5fd92644ee971c7dddb09674d660a462b9f0d99e83ef2b595095173274e54bbdc0f8411fffe4
DIST gnome-connections-45.rc.tar.xz 4006984 BLAKE2B 84b496f650dcd867fb52b90837e31bd9c9308e555a486372ee612f74b41ea2ea4497d9d60e0e64172977d93c1b314fdcccde50dbdf828817561ce0348d9c440d SHA512 866e15632928a1a996f4388cf08c15c403dde81dfd4d24cb0c53ded268f67066162584b44aee7067f3a08fc117ab01abb357d227494182c73d04074137c90b57
diff --git a/net-misc/gnome-connections/gnome-connections-45.0.ebuild b/net-misc/gnome-connections/gnome-connections-45.0.ebuild
new file mode 100644
index 000000000000..a4191f751d58
--- /dev/null
+++ b/net-misc/gnome-connections/gnome-connections-45.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="A remote desktop client for the GNOME desktop environment"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/connections"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/gobject-introspection
+ >=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3[introspection]
+ >=sys-fs/fuse-3.9.1
+ >=net-libs/gtk-vnc-0.4.4[pulseaudio,vala]
+ >=gui-libs/libhandy-1.6.0:1[vala]
+ >=dev-libs/libxml2-2.7.8
+ app-crypt/libsecret[vala]
+
+ >=net-misc/freerdp-2.0.0:0=
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/glib
+ dev-util/glib-utils
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ test? (
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ )
+"
+
+src_prepare() {
+ default
+ vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofile=default
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}