summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-04-15 23:05:18 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-04-15 23:05:32 +0200
commitc6e40fe1a17557aac9380ca81b93b856d28dbb71 (patch)
treea1224cc7262c7aaf42088e6f946df85f0dd33e8a /net-misc/gallery-dl
parentnet-misc/gallery-dl: drop old 1.24.4 (diff)
downloadgentoo-c6e40fe1a17557aac9380ca81b93b856d28dbb71.tar.gz
gentoo-c6e40fe1a17557aac9380ca81b93b856d28dbb71.tar.bz2
gentoo-c6e40fe1a17557aac9380ca81b93b856d28dbb71.zip
net-misc/gallery-dl: bump to 1.25.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc/gallery-dl')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.25.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index 923aee81fec6..6502e04a8172 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1,3 +1,4 @@
DIST gallery-dl-1.24.5.gh.tar.gz 525743 BLAKE2B 6b8611242bbb6a6dc76508ec452c3618fe75d6ffdc3185b5f246e5568f32861647649d63e9479b187f086aeb4ea4f567567fc387bbe1df0cb4994a00d4ba76f1 SHA512 648707e5be450501aa66f34b89aae1cf7b80c93bee5105c9eeae4fa19e34df41b231066a23113e963119105050e6aed8e654d10d107086ab5a815095dcf562c2
DIST gallery-dl-1.25.0.gh.tar.gz 540793 BLAKE2B e02daf0b2deb8196fc587a3fd17e4bb8b0d14ca67c6384e120d3fadaa261b5d9143885c2717d0e98dc0467285a7ebfa9f9bc5da7ad5bd39a239a6975e0a900eb SHA512 e0cc041343130acf47f0ab4b7b7ac0ac42389bc457748404b9b0bc17f8a8690b225ab30c0c3d523925138608508417ecc4052981a5615d0747a2a064f6236ed4
DIST gallery-dl-1.25.1.gh.tar.gz 543977 BLAKE2B ab6437ebb4f840fb3fac27a3f0d2536215dc02376b0129d9b7d4c9420cc64405edf5961c0155d7fb9d7001028bf218a299bfd44bbf2ef2b60f567e51050e504e SHA512 96f929af5cf70c7a89eca2ac8380cd7ba36ed806d062a6e339238ebfec2387aa4806d432cd28599b37382a69d7cdb33306069d41954e1421dff2523e2ae6a8df
+DIST gallery-dl-1.25.2.gh.tar.gz 546468 BLAKE2B ee40766e581afa8ab1119d656131a1e467fc1b6b5d92491ee384428ee4a02fd2b0b261657f175cb6d6bc8e79a622a14b7308ccb0e129535e7718503a6828ae53 SHA512 99bc319427c067f039df7f34988b44da2db028afc33188454879c46abbacfaac6fb8a5d0d0aec1fd4d7ba97862b100675cab55094b9d8979a5240f516fe4b855
diff --git a/net-misc/gallery-dl/gallery-dl-1.25.2.ebuild b/net-misc/gallery-dl/gallery-dl-1.25.2.ebuild
new file mode 100644
index 000000000000..9dcd7bdbba2f
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.25.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# tests require network access
+RESTRICT="test"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/yt-dlp
+}