summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/flexget/flexget-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/flexget/flexget-9999.ebuild')
-rw-r--r--net-misc/flexget/flexget-9999.ebuild76
1 files changed, 76 insertions, 0 deletions
diff --git a/net-misc/flexget/flexget-9999.ebuild b/net-misc/flexget/flexget-9999.ebuild
new file mode 100644
index 000000000000..6e44c092d62a
--- /dev/null
+++ b/net-misc/flexget/flexget-9999.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+if [[ ${PV} != 9999 ]]; then
+ MY_P="FlexGet-${PV}"
+ SRC_URI="mirror://pypi/F/FlexGet/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+else
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/Flexget/Flexget.git
+ https://github.com/Flexget/Flexget.git"
+fi
+
+DESCRIPTION="Multipurpose automation tool for content like torrents, nzbs, podcasts, comics"
+HOMEPAGE="http://flexget.com/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test transmission"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/feedparser-5.1.3[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.7.5[${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.9.99
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/beautifulsoup-4.1:4[${PYTHON_USEDEP}]
+ <dev-python/beautifulsoup-4.4:4[${PYTHON_USEDEP}]
+ !~dev-python/beautifulsoup-4.2.0
+ >=dev-python/html5lib-0.11[${PYTHON_USEDEP}]
+ dev-python/PyRSS2Gen[${PYTHON_USEDEP}]
+ dev-python/pynzb[${PYTHON_USEDEP}]
+ dev-python/progressbar[${PYTHON_USEDEP}]
+ dev-python/rpyc[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.0[${PYTHON_USEDEP}]
+ <dev-python/requests-2.99[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ !~dev-python/python-dateutil-2.2
+ >=dev-python/jsonschema-2.0[${PYTHON_USEDEP}]
+ dev-python/python-tvrage[${PYTHON_USEDEP}]
+ dev-python/tmdb3[${PYTHON_USEDEP}]
+ dev-python/path-py[${PYTHON_USEDEP}]
+ >=dev-python/guessit-0.9.3[${PYTHON_USEDEP}]
+ dev-python/APScheduler[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}
+ transmission? ( dev-python/transmissionrpc[${PYTHON_USEDEP}] )
+"
+DEPEND+=" test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+=" dev-python/paver[${PYTHON_USEDEP}]"
+else
+ S="${WORKDIR}/${MY_P}"
+fi
+
+python_prepare_all() {
+ # Prevent setup from grabbing nose from pypi
+ sed -e /setup_requires/d -i pavement.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cp -lr tests setup.cfg "${BUILD_DIR}" || die
+ run_in_build_dir nosetests -v --attr=!online > "${T}/tests-${EPYTHON}.log" \
+ || die "Tests fail with ${EPYTHON}"
+}