summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-01-05 22:33:27 +0000
committerJustin Lecher <jlec@gentoo.org>2017-01-05 22:50:32 +0000
commit0fac1ac0049a31682bc0ea4cb7db51fc6ada45f6 (patch)
tree07f372ab53aac308d4b2849690cdd123fb0bb520 /net-misc/axel/axel-9999.ebuild
parentsys-block/fio: Version Bump (diff)
downloadgentoo-0fac1ac0049a31682bc0ea4cb7db51fc6ada45f6.tar.gz
gentoo-0fac1ac0049a31682bc0ea4cb7db51fc6ada45f6.tar.bz2
gentoo-0fac1ac0049a31682bc0ea4cb7db51fc6ada45f6.zip
net-misc/axel: Version Bump and live ebuild
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=385155 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=604522 Package-Manager: Portage-2.3.3, Repoman-2.3.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'net-misc/axel/axel-9999.ebuild')
-rw-r--r--net-misc/axel/axel-9999.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-misc/axel/axel-9999.ebuild b/net-misc/axel/axel-9999.ebuild
new file mode 100644
index 000000000000..e69e0ba95024
--- /dev/null
+++ b/net-misc/axel/axel-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools git-r3
+
+DESCRIPTION="Light Unix download accelerator"
+HOMEPAGE="https://github.com/eribertomota/axel"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/eribertomota/axel.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="debug libressl nls ssl"
+
+REQUIRED_USE="libressl? ( ssl )"
+
+CDEPEND="
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+DEPEND="${CDEPEND}
+ nls? ( sys-devel/gettext )"
+RDEPEND="${CDEPEND}
+ nls? ( virtual/libintl virtual/libiconv )"
+
+DOCS=( doc/. )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with ssl openssl)
+}
+
+pkg_postinst() {
+ einfo 'To use axel with portage, try these settings in your make.conf'
+ einfo
+ einfo ' FETCHCOMMAND='\''axel -a -o "\${DISTDIR}/\${FILE}.axel" "\${URI}" && mv "\${DISTDIR}/\${FILE}.axel" "\${DISTDIR}/\${FILE}"'\'
+ einfo ' RESUMECOMMAND="${FETCHCOMMAND}"'
+}