summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristophe Lermytte <gentoo@lermytte.be>2022-11-28 18:05:03 +0100
committerMatt Turner <mattst88@gentoo.org>2022-11-28 18:26:24 -0500
commitdaf448f27a18e8e36c2a391d71355903fb406e9c (patch)
tree6ecbec96def398d1802513744000350631ceb0ad /net-libs
parentdev-cpp/abseil-cpp: enable py3.11 in 20211102* (diff)
downloadgentoo-daf448f27a18e8e36c2a391d71355903fb406e9c.tar.gz
gentoo-daf448f27a18e8e36c2a391d71355903fb406e9c.tar.bz2
gentoo-daf448f27a18e8e36c2a391d71355903fb406e9c.zip
net-libs/gnome-online-accounts: add upstream patch for meson dependency fix
The patch is currently not yet in upstream's "gnome-43" branch (which produces the 3.46.x track), but I will ask ebassi to cherry-pick it so we can drop this patch in the near future. Closes: https://bugs.gentoo.org/882625 Closes: https://github.com/gentoo/gentoo/pull/28463 Signed-off-by: Christophe Lermytte <gentoo@lermytte.be> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gnome-online-accounts/files/gnome-online-accounts-3.46.0-fix-meson-dependencies.patch27
-rw-r--r--net-libs/gnome-online-accounts/gnome-online-accounts-3.46.0.ebuild4
2 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/gnome-online-accounts/files/gnome-online-accounts-3.46.0-fix-meson-dependencies.patch b/net-libs/gnome-online-accounts/files/gnome-online-accounts-3.46.0-fix-meson-dependencies.patch
new file mode 100644
index 000000000000..0014033fb1f0
--- /dev/null
+++ b/net-libs/gnome-online-accounts/files/gnome-online-accounts-3.46.0-fix-meson-dependencies.patch
@@ -0,0 +1,27 @@
+https://gitlab.gnome.org/GNOME/gnome-online-accounts/-/commit/f10c48ee114f719c63a8eabccdfb401a14219f46
+https://bugs.gentoo.org/882625
+
+From: Emmanuele Bassi <ebassi@gnome.org>
+Date: Wed, 5 Oct 2022 22:15:37 +0100
+Subject: [PATCH] build: Use the appropriate dependency object
+
+Just using `link_with` will not ensure that the GOA web extension shared
+module is properly built against libgoa-backend and libgoa; the
+generated headers must be transitively available by the time we build
+the shared module.
+
+Fixes: #226
+--- a/src/goabackend/meson.build
++++ b/src/goabackend/meson.build
+@@ -157,9 +157,8 @@ libgoa_web_extension = shared_module(
+ 'goawebextension',
+ libgoawebextension_sources,
+ include_directories: common_incs + [goa_inc],
+- dependencies: deps,
++ dependencies: [deps, libgoa_backend_dep],
+ c_args: cflags,
+- link_with: libgoa_backend,
+ install: true,
+ install_dir: join_paths(goa_pkglibdir, 'web-extensions')
+ )
+GitLab
diff --git a/net-libs/gnome-online-accounts/gnome-online-accounts-3.46.0.ebuild b/net-libs/gnome-online-accounts/gnome-online-accounts-3.46.0.ebuild
index cf7e18995da4..14fd00afc7fe 100644
--- a/net-libs/gnome-online-accounts/gnome-online-accounts-3.46.0.ebuild
+++ b/net-libs/gnome-online-accounts/gnome-online-accounts-3.46.0.ebuild
@@ -50,6 +50,10 @@ DEPEND="${RDEPEND}
"
BDEPEND="gtk-doc? ( dev-util/gtk-doc )"
+PATCHES=(
+ "${FILESDIR}/${P}-fix-meson-dependencies.patch"
+)
+
src_prepare() {
default
use vala && vala_setup