summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-02-20 21:03:02 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-02-20 21:03:02 -0500
commit944439b732b303c6bcc5369fba60b8fd6f640348 (patch)
treebfd232af84688997e884dbd2e32a3cc272f12ebf /net-libs
parentdev-util/gdbus-codegen: remove old (diff)
downloadgentoo-944439b732b303c6bcc5369fba60b8fd6f640348.tar.gz
gentoo-944439b732b303c6bcc5369fba60b8fd6f640348.tar.bz2
gentoo-944439b732b303c6bcc5369fba60b8fd6f640348.zip
net-libs/c-client: use ":" as pattern separator in a sed call.
Most of the "sed" calls in the c-client ebuilds use ":" as the pattern separator, because we expect to be replacing things with front-slashes in them. One exception was the call that replaced CC, AR, and RANLIB; and that finally bit us. A user with absolute paths in those variables reported the defect. This commit fixes the call to use ":" as the pattern separator, like everywhere else in the ebuild. Since it is a build-only fix, it was made without a new revision. Gentoo-Bug: 609744 Package-Manager: portage-2.3.3
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/c-client/c-client-2007f-r6.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-libs/c-client/c-client-2007f-r6.ebuild b/net-libs/c-client/c-client-2007f-r6.ebuild
index fc6ce38b6a84..e033b90a11d5 100644
--- a/net-libs/c-client/c-client-2007f-r6.ebuild
+++ b/net-libs/c-client/c-client-2007f-r6.ebuild
@@ -74,9 +74,9 @@ src_prepare() {
# Respect LDFLAGS
eapply "${FILESDIR}/${PN}-2007f-ldflags.patch"
- sed -e "s/CC=cc/CC=$(tc-getCC)/" \
- -e "s/ARRC=ar/ARRC=$(tc-getAR)/" \
- -e "s/RANLIB=ranlib/RANLIB=$(tc-getRANLIB)/" \
+ sed -e "s:CC=cc:CC=$(tc-getCC):" \
+ -e "s:ARRC=ar:ARRC=$(tc-getAR):" \
+ -e "s:RANLIB=ranlib:RANLIB=$(tc-getRANLIB):" \
-i src/osdep/unix/Makefile \
|| die "failed to fix build flags support in the Makefile"