summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-07-29 09:51:08 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-07-29 09:51:08 +0200
commit93dd53558807ac23f00cfa0fb8c8420511640e1f (patch)
treea52095668a5462d339967b5ce8ac45f6f0b8b85b /net-libs
parentsys-fs/xfsprogs: Removed old. (diff)
downloadgentoo-93dd53558807ac23f00cfa0fb8c8420511640e1f.tar.gz
gentoo-93dd53558807ac23f00cfa0fb8c8420511640e1f.tar.bz2
gentoo-93dd53558807ac23f00cfa0fb8c8420511640e1f.zip
net-libs/nghttp2: Removed old.
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nghttp2/Manifest3
-rw-r--r--net-libs/nghttp2/files/nghttp2-1.38.0-boost-1.70.0.patch50
-rw-r--r--net-libs/nghttp2/nghttp2-1.33.0.ebuild68
-rw-r--r--net-libs/nghttp2/nghttp2-1.38.0.ebuild90
4 files changed, 0 insertions, 211 deletions
diff --git a/net-libs/nghttp2/Manifest b/net-libs/nghttp2/Manifest
index d6c7e2be8297..42a7d750f384 100644
--- a/net-libs/nghttp2/Manifest
+++ b/net-libs/nghttp2/Manifest
@@ -1,4 +1 @@
-DIST nghttp2-1.33.0.tar.xz 1554776 BLAKE2B 1b995d6385188423acbcd7c8b3a626a622270bc3079972885a1f707a9cc4ebb053f7347930ce217d2cf4277eab0a3309accb8f9ff18bd8ccc55c86aefa6246c3 SHA512 eeb0bf64fea115444c685c8a01c1017ce96be18adf88ffcdecad067de7012ca61c6b2b6a627b18e2572bba7bd77ec56a3ca4b1109f7a4b21220e8e28687b5b74
-DIST nghttp2-1.38.0-unbundle_http_parser.patch.xz 2616 BLAKE2B 3f15154d33f32c91aad87f23f56d761501e19e0b53b99d4df720f9e04d6d9c49a52118acbe3da87f8585c2b71b7b430ef60fc33465605f3bf9933635aabb924d SHA512 1b4377b34cf6428164011be9fc86efdd7ab8d3443edf197c45768beea0f843084a842c4cb2abc5179d6036ec99174557e06344ce67a07d98992de64d99faf3a6
-DIST nghttp2-1.38.0.tar.xz 1628356 BLAKE2B 0568d4ac5c1e5e6d7adf762815836502524d59fb55c623f344a8427638407a19447fe1a7753142aa205898f7bda6ebce8ef6f4d85edc6da98ffa98b83d4e363e SHA512 e432d52bcf77379ed5c10ceafb587ec8d66c56bb728cda56487b237cbab1d0073689624419ed306162dab3a51b91cfe0f59cb173b5d81346e2b6d0abd56635bc
DIST nghttp2-1.39.1.tar.xz 1634512 BLAKE2B 66444de067200a7dd66f162c22fd258471d336b1ba02f579a675b5d9dfcbf1600fcfb92a37797842a0482bd0f5c850008508d3d41f7afddc47f7c9330fb34b43 SHA512 36558ed03c59086086abbf144ec7c54c60de3fea00a9ea594feea7186a779781cbb66a08c9b34265892dea382b42b875f551e85331cfa0086e357f9b27b919fa
diff --git a/net-libs/nghttp2/files/nghttp2-1.38.0-boost-1.70.0.patch b/net-libs/nghttp2/files/nghttp2-1.38.0-boost-1.70.0.patch
deleted file mode 100644
index cc1100a0b0ba..000000000000
--- a/net-libs/nghttp2/files/nghttp2-1.38.0-boost-1.70.0.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From cbba1ebf8fcecb24392f0cc07b1235b17d0de9d8 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Adam=20Go=C5=82=C4=99biowski?= <adamg@pld-linux.org>
-Date: Thu, 18 Apr 2019 12:35:54 +0200
-Subject: [PATCH] asio: support boost-1.70
-
-In boost 1.70, deprecated get_io_context() has finally been removed.
-Introduce GET_IO_SERVICE macro that based on boost version uses
-old get_io_service() interface (boost < 1.70), or get_executor().context()
-for boost 1.70+.
-
-Commit based idea seen in monero-project/monero@17769db9462e5201befcb05f86ccbaeabf35caf8
----
- src/asio_server_connection.h | 10 ++++++++--
- 1 file changed, 8 insertions(+), 2 deletions(-)
-
-diff --git a/src/asio_server_connection.h b/src/asio_server_connection.h
-index 6be794060..56924c71a 100644
---- a/src/asio_server_connection.h
-+++ b/src/asio_server_connection.h
-@@ -51,6 +51,12 @@
- #include "util.h"
- #include "template.h"
-
-+#if BOOST_VERSION >= 107000
-+#define GET_IO_SERVICE(s) ((boost::asio::io_context&)(s).get_executor().context())
-+#else
-+#define GET_IO_SERVICE(s) ((s).get_io_service())
-+#endif
-+
- namespace nghttp2 {
-
- namespace asio_http2 {
-@@ -71,7 +77,7 @@ class connection : public std::enable_shared_from_this<connection<socket_type>>,
- SocketArgs &&... args)
- : socket_(std::forward<SocketArgs>(args)...),
- mux_(mux),
-- deadline_(socket_.get_io_service()),
-+ deadline_(GET_IO_SERVICE(socket_)),
- tls_handshake_timeout_(tls_handshake_timeout),
- read_timeout_(read_timeout),
- writing_(false),
-@@ -82,7 +88,7 @@ class connection : public std::enable_shared_from_this<connection<socket_type>>,
- boost::system::error_code ec;
-
- handler_ = std::make_shared<http2_handler>(
-- socket_.get_io_service(), socket_.lowest_layer().remote_endpoint(ec),
-+ GET_IO_SERVICE(socket_), socket_.lowest_layer().remote_endpoint(ec),
- [this]() { do_write(); }, mux_);
- if (handler_->start() != 0) {
- stop();
diff --git a/net-libs/nghttp2/nghttp2-1.33.0.ebuild b/net-libs/nghttp2/nghttp2-1.33.0.ebuild
deleted file mode 100644
index 8e3d343e95f3..000000000000
--- a/net-libs/nghttp2/nghttp2-1.33.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# TODO: Add python support.
-
-EAPI=7
-
-inherit multilib-minimal
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd"
-fi
-
-DESCRIPTION="HTTP/2 C Library"
-HOMEPAGE="https://nghttp2.org/"
-
-LICENSE="MIT"
-SLOT="0/1.14" # <C++>.<C> SONAMEs
-IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
-
-SSL_DEPEND="
- !libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist,${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
-"
-RDEPEND="
- cxx? (
- ${SSL_DEPEND}
- dev-libs/boost:=[${MULTILIB_USEDEP},threads]
- )
- hpack-tools? ( >=dev-libs/jansson-2.5 )
- jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
- utils? (
- ${SSL_DEPEND}
- >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
- >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
- net-dns/c-ares:=[${MULTILIB_USEDEP}]
- )
- xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
-
-multilib_src_configure() {
- local myeconfargs=(
- --disable-examples
- --disable-failmalloc
- --disable-werror
- --without-cython
- --disable-python-bindings
- $(use_enable cxx asio-lib)
- $(use_enable debug)
- $(multilib_native_use_enable hpack-tools)
- $(use_enable static-libs static)
- $(use_enable threads)
- $(multilib_native_use_enable utils app)
- $(multilib_native_use_with jemalloc)
- $(multilib_native_use_with xml libxml2)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_install_all() {
- use static-libs || find "${ED%/}"/usr -name '*.la' -delete
-}
diff --git a/net-libs/nghttp2/nghttp2-1.38.0.ebuild b/net-libs/nghttp2/nghttp2-1.38.0.ebuild
deleted file mode 100644
index 23ae1e8d57ba..000000000000
--- a/net-libs/nghttp2/nghttp2-1.38.0.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# TODO: Add python support.
-
-EAPI=7
-
-inherit autotools multilib-minimal
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/nghttp2/nghttp2.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/nghttp2/nghttp2/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-fi
-
-# 675772
-SRC_URI+=" https://dev.gentoo.org/~polynomial-c/${PN}-1.38.0-unbundle_http_parser.patch.xz"
-
-DESCRIPTION="HTTP/2 C Library"
-HOMEPAGE="https://nghttp2.org/"
-
-LICENSE="MIT"
-SLOT="0/1.14" # <C++>.<C> SONAMEs
-IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
-
-SSL_DEPEND="
- !libressl? ( >=dev-libs/openssl-1.0.2:0=[-bindist,${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
-"
-RDEPEND="
- cxx? (
- ${SSL_DEPEND}
- dev-libs/boost:=[${MULTILIB_USEDEP},threads]
- >=net-libs/http-parser-2.9.1:=[${MULTILIB_USEDEP}]
- )
- hpack-tools? (
- >=dev-libs/jansson-2.5
- >=net-libs/http-parser-2.9.1:=
- )
- jemalloc? ( dev-libs/jemalloc[${MULTILIB_USEDEP}] )
- utils? (
- ${SSL_DEPEND}
- >=dev-libs/libev-4.15[${MULTILIB_USEDEP}]
- >=sys-libs/zlib-1.2.3[${MULTILIB_USEDEP}]
- net-dns/c-ares:=[${MULTILIB_USEDEP}]
- )
- xml? ( >=dev-libs/libxml2-2.7.7:2[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
-
-PATCHES=(
- "${WORKDIR}/${PN}-1.38.0-unbundle_http_parser.patch" # 675772
- "${FILESDIR}/${P}-boost-1.70.0.patch" #683368
-)
-
-src_prepare() {
- default
- # Remove bundled stuff
- rm -r third-party/http-parser || die
- eautoreconf
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --disable-examples
- --disable-failmalloc
- --disable-python-bindings
- --disable-werror
- --without-bundled-http_parser
- --without-cython
- $(use_enable cxx asio-lib)
- $(use_enable debug)
- $(multilib_native_use_enable hpack-tools)
- $(use_enable static-libs static)
- $(use_enable threads)
- $(multilib_native_use_enable utils app)
- $(multilib_native_use_with jemalloc)
- $(multilib_native_use_with xml libxml2)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_install_all() {
- if ! use static-libs ; then
- find "${ED}"/usr -name '*.la' -delete || die
- fi
-}