summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Zander <negril.nx+gentoo@gmail.com>2024-07-08 12:53:01 +0200
committerSam James <sam@gentoo.org>2024-07-09 13:51:25 +0100
commit4a585a254225a19337af2376970ba8a19eac1078 (patch)
treec67b74d4fc8d0b4ec1d4016ccf3fd8c508958b36 /net-libs
parentdev-python/protobuf-python: update 5.27.2, drop 9999 (diff)
downloadgentoo-4a585a254225a19337af2376970ba8a19eac1078.tar.gz
gentoo-4a585a254225a19337af2376970ba8a19eac1078.tar.bz2
gentoo-4a585a254225a19337af2376970ba8a19eac1078.zip
net-libs/grpc: 1.62.1 add python3_11
Fixed the typo that led to the omission of 3.11 Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/grpc/grpc-1.62.1.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/net-libs/grpc/grpc-1.62.1.ebuild b/net-libs/grpc/grpc-1.62.1.ebuild
index f8449433e9f8..868f18efcae3 100644
--- a/net-libs/grpc/grpc-1.62.1.ebuild
+++ b/net-libs/grpc/grpc-1.62.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
CMAKE_IN_SOURCE_BUILD=1
-PYTHON_COMPAT=( python3_{10,12} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake flag-o-matic python-any-r1
MY_PV="${PV//_pre/-pre}"
@@ -57,14 +57,12 @@ BDEPEND="
PATCHES=( "${FILESDIR}/${PN}-1.62.1-system-gtest.patch" )
python_check_deps() {
- python_has_version -b "dev-python/twisted[${PYTHON_USEDEP}]" &&
- python_has_version -b "dev-python/pyyaml[${PYTHON_USEDEP}]" &&
- python_has_version -b "dev-python/cffi[${PYTHON_USEDEP}]" &&
- python_has_version -b "dev-python/six[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- use test && python-any-r1_pkg_setup
+ if use test; then
+ python_has_version -b "dev-python/twisted[${PYTHON_USEDEP}]" &&
+ python_has_version -b "dev-python/pyyaml[${PYTHON_USEDEP}]" &&
+ python_has_version -b "dev-python/cffi[${PYTHON_USEDEP}]" &&
+ python_has_version -b "dev-python/six[${PYTHON_USEDEP}]"
+ fi
}
soversion_check() {