summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-03-02 22:06:31 -0300
committerPacho Ramos <pacho@gentoo.org>2024-08-07 12:45:16 +0200
commit022b90b454d5b278d2f5ab5c6eb44b8f0b8b257f (patch)
treef9c2a03ba04a1d9284d87f93a46f9fc7db748e55 /net-libs
parentdev-ruby/mime-types-data: Stabilize 3.2024.0702 ppc, #937477 (diff)
downloadgentoo-022b90b454d5b278d2f5ab5c6eb44b8f0b8b257f.tar.gz
gentoo-022b90b454d5b278d2f5ab5c6eb44b8f0b8b257f.tar.bz2
gentoo-022b90b454d5b278d2f5ab5c6eb44b8f0b8b257f.zip
net-libs/glib-networking: Bump to 2.80.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35605 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/glib-networking/Manifest1
-rw-r--r--net-libs/glib-networking/glib-networking-2.80.0.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-libs/glib-networking/Manifest b/net-libs/glib-networking/Manifest
index 023d9d387cf3..408b33f0f688 100644
--- a/net-libs/glib-networking/Manifest
+++ b/net-libs/glib-networking/Manifest
@@ -1,3 +1,4 @@
DIST glib-networking-2.76.1.tar.xz 280896 BLAKE2B d4fb8e30096e2e0bdca183795e5d6f86f13c887ad61a52a46dd2af90756ced41e540f286b2cdafb4655cf337758e3742508c0e62e0ea3850ab293cd04e12488e SHA512 9da7844dc767c8dc33953bf984aa9fcc12ac6f9945b55b9c0ec34ecf13592deefead37dc27b048f564dc423286224c041b9842034e197d90f93822128fab4f97
DIST glib-networking-2.78.0.tar.xz 282864 BLAKE2B 24b503a79e3a75c706e5aac98bb4593c6a282d980175633e77097ec8dcb7399f1e197ef42cad9f1f0a7c0456e0f09fbb7a197dcdf1ee2eff0f061ea826e2ee33 SHA512 7574e82aa018332edf99dd284c7fd74b5935bca4a6a70e950ae4b22bbe7be188433fea69e35c742cae120e7ff7d1a6b4f5bf3957fc31f220f50189d3958a3f58
DIST glib-networking-2.78.1.tar.xz 283472 BLAKE2B 424a7d1f05b8589e9f5ca4e53fe4aead2ded484799b984e80ba8c203633bb5c7cec47cf56d15df4af1cb900025a560b9f07a9ebaeb5428c051f600849630a310 SHA512 dc8076d3ff1c97c44c7ba04f74bed50117b07f703efc1bc4cc44989ffcfada0ab49813556ad5bb1831dfb114c4f74ec7bfe08c9b6b514ae7049700211606b288
+DIST glib-networking-2.80.0.tar.xz 287044 BLAKE2B cf407acf5876756dac1fae19b6442b718aa8cdcfd381b00a2d34acc9cac60b519df82a27ceca9af0cc25d54dac03bf43cf74e5f485e6c8fe6b84e11e71719200 SHA512 9707bd47a7f613bc24ac3212737b6b67c57fb6c5dc20e8659a6276750cb07d2af7d42277e4c7294644e8e833eb5aea28320f3d517073e1316860a1dee2e3dc2b
diff --git a/net-libs/glib-networking/glib-networking-2.80.0.ebuild b/net-libs/glib-networking/glib-networking-2.80.0.ebuild
new file mode 100644
index 000000000000..2bd4d6da77ff
--- /dev/null
+++ b/net-libs/glib-networking/glib-networking-2.80.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson-multilib xdg
+
+DESCRIPTION="Network-related giomodules for glib"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/glib-networking"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+gnome +libproxy +ssl test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.73.3:2[${MULTILIB_USEDEP}]
+ libproxy? ( >=net-libs/libproxy-0.4.16[${MULTILIB_USEDEP}] )
+ >=net-libs/gnutls-3.7.4:=[${MULTILIB_USEDEP}]
+ ssl? ( app-misc/ca-certificates )
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/gnutls[pkcs11] )
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ if ! use test ; then
+ # Don't build tests unconditionally
+ # This is a hack to avoid needing gnutls[pkcs11] when USE=-test
+ # It may become a real runtime dependency in future
+ # Please check!
+ # bug #777462
+ sed -i "/^subdir('tests')/d" tls/meson.build || die
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dgnutls=enabled
+ -Dopenssl=disabled
+ $(meson_feature !libproxy environment_proxy)
+ $(meson_feature libproxy)
+ $(meson_feature gnome gnome_proxy)
+ -Dinstalled_tests=false
+ -Ddebug_logs=false
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ # Pretend the network is available so we get real libproxy parsing
+ # output rather than it giving up early in e.g. systemd-nspawn in some
+ # cases.
+ # https://github.com/libproxy/libproxy/issues/260 (bug #914382)
+ local -x GIO_USE_NETWORK_MONITOR=base
+ dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ multilib_pkg_postinst() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+
+ multilib_pkg_postrm() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postrm
+}