summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-10-16 08:45:05 -0400
committerCraig Andrews <candrews@gentoo.org>2023-10-16 08:47:51 -0400
commit930ca541bc9b234269df6ba8beb6e5b25cf7e460 (patch)
tree21a2f6254554cb91e9955db7b13884a7314802e8 /net-libs/nghttp3
parentnet-libs/ngtcp2: drop versions (diff)
downloadgentoo-930ca541bc9b234269df6ba8beb6e5b25cf7e460.tar.gz
gentoo-930ca541bc9b234269df6ba8beb6e5b25cf7e460.tar.bz2
gentoo-930ca541bc9b234269df6ba8beb6e5b25cf7e460.zip
net-libs/nghttp3: add 1.0.0
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs/nghttp3')
-rw-r--r--net-libs/nghttp3/Manifest1
-rw-r--r--net-libs/nghttp3/nghttp3-1.0.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-libs/nghttp3/Manifest b/net-libs/nghttp3/Manifest
index f163cf6f2c84..bf11ceb41181 100644
--- a/net-libs/nghttp3/Manifest
+++ b/net-libs/nghttp3/Manifest
@@ -3,3 +3,4 @@ DIST nghttp3-0.12.0.tar.xz 369576 BLAKE2B 552fab00de7c6d1917ac1b680547aa57e02ae3
DIST nghttp3-0.13.0.tar.xz 367992 BLAKE2B 381677866a327cbb5638aa2e6f4a770d15879d05ca432c3fca7e92a8a815ae62857c386ba660805e97f649f9bc7c9c4c7077a92d2296b3303347e3d1dff12b6c SHA512 63de094ae62c641388ea909b28df2cce58df5e372237519fb6ef62bbd937ff20f6e571cb99f0fac8b8781e619fc229ec931fb5c6a1165727829d6b0c3a779ef8
DIST nghttp3-0.14.0.tar.xz 367992 BLAKE2B a7109d735b4fd9117caaec128bb9631e1a75514475bebcf039b605fcac4d68faa4bfa51c77123d456cba19c52e9436839adccd7449a126b5befe445860a3d5d3 SHA512 163bf8dee3e100dd95e73fbe0176d0dc9c86e9139d96cc98fa7e7c279dbcc699cee79998b2784fb21f8da745be98ba8e86c7387f8166907d89eace8f97176779
DIST nghttp3-0.15.0.tar.xz 368348 BLAKE2B 2488a944beb0165e8cad26ddc37b79eb50f7c16807902fc43f97afc57c46a9bb5857eb041c870dbdcd3d817c3b45e1849c325cbea5ef67c9198adec7421e38d6 SHA512 f65cb3b2de1abb12b13b214a60b83c9570a265f99e082cc62b6791a32c929cd78c3a228e38ccd5edd36c12998486633b660b6737fe6c1fbe1b03acdb9ca033dd
+DIST nghttp3-1.0.0.tar.xz 369384 BLAKE2B a36b0c75e3c3c44b76652ef7c344831abe6cc160724203b9cb0951416d19df5630ac09c4a5eaf60203a6afcb5eab452d53546d97082f06e4761533b5f7518556 SHA512 84d3207346da3807e56a6f9d7f826ae4174d5a0ba6c4bf1e71dd3f6a7e694eb8f2b9607ed862ffac7b29509521f8216aef3e0910425a65bc4e94ffa879f4d3d8
diff --git a/net-libs/nghttp3/nghttp3-1.0.0.ebuild b/net-libs/nghttp3/nghttp3-1.0.0.ebuild
new file mode 100644
index 000000000000..7f4078fba594
--- /dev/null
+++ b/net-libs/nghttp3/nghttp3-1.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/nghttp3/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~hppa"
+fi
+
+DESCRIPTION="HTTP/3 library written in C"
+HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="static-libs test"
+
+BDEPEND="virtual/pkgconfig"
+DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_LIB_ONLY=ON
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_EXAMPLES=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}