summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 18:27:00 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:34:09 +0100
commitde37bcf44e5eaa59a4a2745977fc9d11c0a556cf (patch)
tree780577a0c3821cc10b73d35cdc1592b089154b87 /net-libs/nfqueue-bindings
parentnet-libs/libsearpc: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-de37bcf44e5eaa59a4a2745977fc9d11c0a556cf.tar.gz
gentoo-de37bcf44e5eaa59a4a2745977fc9d11c0a556cf.tar.bz2
gentoo-de37bcf44e5eaa59a4a2745977fc9d11c0a556cf.zip
net-libs/nfqueue-bindings: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-libs/nfqueue-bindings')
-rw-r--r--net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild6
-rw-r--r--net-libs/nfqueue-bindings/nfqueue-bindings-0.6-r1.ebuild (renamed from net-libs/nfqueue-bindings/nfqueue-bindings-0.6.ebuild)6
2 files changed, 8 insertions, 4 deletions
diff --git a/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild b/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild
index 208daba1fd23..97d6ee2d4ac5 100644
--- a/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild
+++ b/net-libs/nfqueue-bindings/nfqueue-bindings-0.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,7 +19,9 @@ REQUIRED_USE="|| ( perl python ) python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
python? (
- dev-python/dpkt[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/dpkt[${PYTHON_MULTI_USEDEP}]
+ ')
${PYTHON_DEPS}
)"
DEPEND="${RDEPEND}
diff --git a/net-libs/nfqueue-bindings/nfqueue-bindings-0.6.ebuild b/net-libs/nfqueue-bindings/nfqueue-bindings-0.6-r1.ebuild
index fb8f566b9270..56b6ed038b47 100644
--- a/net-libs/nfqueue-bindings/nfqueue-bindings-0.6.ebuild
+++ b/net-libs/nfqueue-bindings/nfqueue-bindings-0.6-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,7 +19,9 @@ REQUIRED_USE="|| ( perl python ) python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
python? (
- dev-python/dpkt[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/dpkt[${PYTHON_MULTI_USEDEP}]
+ ')
${PYTHON_DEPS}
)"
DEPEND="${RDEPEND}