summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/loudmouth/loudmouth-1.4.3-r2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/loudmouth/loudmouth-1.4.3-r2.ebuild')
-rw-r--r--net-libs/loudmouth/loudmouth-1.4.3-r2.ebuild96
1 files changed, 96 insertions, 0 deletions
diff --git a/net-libs/loudmouth/loudmouth-1.4.3-r2.ebuild b/net-libs/loudmouth/loudmouth-1.4.3-r2.ebuild
new file mode 100644
index 000000000000..0a1453575be9
--- /dev/null
+++ b/net-libs/loudmouth/loudmouth-1.4.3-r2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GNOME_TARBALL_SUFFIX="bz2"
+GNOME2_LA_PUNT="yes"
+# Not using gnome macro, but behavior is similar, #434736
+GCONF_DEBUG="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="https://github.com/engineyard/loudmouth"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~ppc-macos"
+
+IUSE="asyncns ssl static-libs test"
+
+# Automagic libidn dependency
+RDEPEND="
+ >=dev-libs/glib-2.4:2
+ net-dns/libidn
+ ssl? ( >=net-libs/gnutls-1.4.0 )
+ asyncns? ( net-libs/libasyncns )
+"
+# FIXME:
+# openssl dropped because of bug #216705
+
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )
+ virtual/pkgconfig
+ >=dev-util/gtk-doc-am-1
+"
+
+src_prepare() {
+ # Use system libasyncns, bug #236844
+ epatch "${FILESDIR}/${P}-asyncns-system.patch"
+
+ # Fix detection of gnutls-2.8, bug #272027
+ epatch "${FILESDIR}/${P}-gnutls28.patch"
+
+ # Fix digest auth with SRV (or similar)
+ # Upstream: http://loudmouth.lighthouseapp.com/projects/17276-libloudmouth/tickets/44-md5-digest-uri-not-set-correctly-when-using-srv
+ epatch "${FILESDIR}/${P}-fix-sasl-md5-digest-uri.patch"
+
+ # Drop stanzas when failing to convert them to LmMessages
+ # From debian..
+ epatch "${FILESDIR}/${P}-drop-stanzas-on-fail.patch"
+
+ # Don't check for sync dns problems when using asyncns [#33]
+ # From debian..
+ epatch "${FILESDIR}/${P}-async-fix.patch"
+
+ # Don't append id tag in opening headers [#30]
+ epatch "${FILESDIR}/${P}-id-tag-in-opening-headers.patch"
+
+ # Silence chdir, from engineyard git
+ epatch "${FILESDIR}/${P}-silence-chdir.patch"
+
+ # Don't free connection internals before connection is closed [#34]
+ epatch "${FILESDIR}/${P}-free-before-closed.patch"
+
+ # Check for invalid utf8, bug #389127
+ # Upstream: http://loudmouth.lighthouseapp.com/projects/17276/tickets/61
+ epatch "${FILESDIR}/${P}-invalid-unicode.patch"
+
+ # http://loudmouth.lighthouseapp.com/projects/17276/tickets/63
+ epatch "${FILESDIR}/${P}-glib-2.32.patch"
+
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #467694
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf
+
+ if use ssl; then
+ myconf="${myconf} --with-ssl=gnutls"
+ else
+ myconf="${myconf} --with-ssl=no"
+ fi
+
+ if use asyncns; then
+ myconf="${myconf} --with-asyncns=system"
+ else
+ myconf="${myconf} --without-asyncns"
+ fi
+ gnome2_src_configure \
+ $(use_enable static-libs static) \
+ ${myconf}
+}