summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libnatpmp/files/respect-FLAGS-20140401.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libnatpmp/files/respect-FLAGS-20140401.patch')
-rw-r--r--net-libs/libnatpmp/files/respect-FLAGS-20140401.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/libnatpmp/files/respect-FLAGS-20140401.patch b/net-libs/libnatpmp/files/respect-FLAGS-20140401.patch
new file mode 100644
index 000000000000..0a007b169a79
--- /dev/null
+++ b/net-libs/libnatpmp/files/respect-FLAGS-20140401.patch
@@ -0,0 +1,36 @@
+diff -Naur libnatpmp-20140401.orig/Makefile libnatpmp-20140401/Makefile
+--- libnatpmp-20140401.orig/Makefile 2013-12-09 15:52:28.000000000 -0500
++++ libnatpmp-20140401/Makefile 2014-04-02 10:03:42.128609226 -0400
+@@ -5,7 +5,7 @@
+ # http://miniupnp.free.fr/libnatpmp.html
+
+ OS = $(shell uname -s)
+-CC = gcc
++CC ?= gcc
+ INSTALL = install -p
+ ARCH = $(shell uname -m | sed -e s/i.86/i686/)
+ VERSION = $(shell cat VERSION)
+@@ -153,19 +153,19 @@
+ $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+ natpmpc-static: natpmpc.o $(STATICLIB)
+- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+ natpmpc-shared: natpmpc.o $(SHAREDLIB)
+- $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+ $(STATICLIB): $(LIBOBJS)
+ $(AR) crs $@ $?
+
+ $(SHAREDLIB): $(LIBOBJS)
+ ifeq ($(OS), Darwin)
+- $(CC) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
++ $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
+ else
+- $(CC) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
++ $(CC) $(CFLAGS) $(LDFLAGS) -shared -Wl,-soname,$(SONAME) -o $@ $^ $(EXTRA_LD)
+ endif
+
+