summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2016-10-10 21:05:47 +0200
committerSlawomir Lis <slis@gentoo.org>2016-10-10 21:08:44 +0200
commit85629e4c04a16d5022ea6c7ccdf870e756389a1a (patch)
tree5e475a454f3bc45cd47ff600788fff221a95ac25 /net-libs/libhtp
parentx11-apps/xvfb-run: Move to x11-misc/ (bug #571864) (diff)
downloadgentoo-85629e4c04a16d5022ea6c7ccdf870e756389a1a.tar.gz
gentoo-85629e4c04a16d5022ea6c7ccdf870e756389a1a.tar.bz2
gentoo-85629e4c04a16d5022ea6c7ccdf870e756389a1a.zip
net-libs/libhtp: version bump to libhtp-0.5.22
As >=libhtp-0.5.20 is needed by latest net-analyzer/suricata I had to update this library (#587786 #595524) Package-Manager: portage-2.3.1
Diffstat (limited to 'net-libs/libhtp')
-rw-r--r--net-libs/libhtp/Manifest1
-rw-r--r--net-libs/libhtp/libhtp-0.5.22.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/libhtp/Manifest b/net-libs/libhtp/Manifest
index 79fe4babfcf6..194e86e2c408 100644
--- a/net-libs/libhtp/Manifest
+++ b/net-libs/libhtp/Manifest
@@ -1 +1,2 @@
DIST htp-0.5.18.tar.gz 799444 SHA256 53f81a2b639edbd9df9f1f0cebcfe9c2a2b381f9d61e2944c020b855a7e89a79 SHA512 e3efaedb74b8a0655b58922f2d0a079f5dfb5dcead117e21394d5d76ff93a3a7260ab56994468764ceeaa2dd584bcfa988b146efb85831e8a98efcda06b28876 WHIRLPOOL 816456580434b2254af8e88e24ff80e5721966ee742bbb89870324e9edcf12bfee4a54727855937c7bbb0d44ba9423dcf714f93a713287dbf0777ca5eeb93c86
+DIST libhtp-0.5.22.tar.gz 5773159 SHA256 0f5ba5b0316b3c0caaa5c45a792271a61d01c667e76f8e37f1d186cb865f5663 SHA512 3daf7241e8abca34bf348e0fc805c755472ebba01a869d5523637a81dfd6b9b3019941dff2e75d6e0978ebfbd60d917191e355aa43a2391500ecaaddab487ebc WHIRLPOOL 59a530fec6bba98c1714ca49394167cfb4a6ba079562a28e6c10a0b9fbf82e71e1ab7a7532050a20c2908a6b0673f55812cb9be81ad9da249b9296a1d6698b97
diff --git a/net-libs/libhtp/libhtp-0.5.22.ebuild b/net-libs/libhtp/libhtp-0.5.22.ebuild
new file mode 100644
index 000000000000..d04d3197d659
--- /dev/null
+++ b/net-libs/libhtp/libhtp-0.5.22.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="security-aware parser for the HTTP protocol and the related bits and pieces"
+HOMEPAGE="https://github.com/OISF/libhtp"
+SRC_URI="https://github.com/OISF/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+IUSE="debug static-libs"
+
+RDEPEND="sys-libs/zlib[static-libs?]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # The debug configure logic is broken.
+ ECONF_SOURCE=${S} \
+ econf \
+ $(usex debug '--enable-debug' '') \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}" -name '*.la' -delete
+}