summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-17 17:40:33 +0100
committerSam James <sam@gentoo.org>2022-04-17 17:40:33 +0100
commit3dea7adc7b30bcc775fbd7dda37bc169e40d50e7 (patch)
tree192fe9ed49a175b9b16c8c3ce44236e59f47f77a /net-irc
parentnet-firewall/firewalld: drop 1.0.2-r1, 1.0.3-r1 (diff)
downloadgentoo-3dea7adc7b30bcc775fbd7dda37bc169e40d50e7.tar.gz
gentoo-3dea7adc7b30bcc775fbd7dda37bc169e40d50e7.tar.bz2
gentoo-3dea7adc7b30bcc775fbd7dda37bc169e40d50e7.zip
net-irc/ergo: drop 2.9.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/ergo/ergo-2.9.1.ebuild69
-rw-r--r--net-irc/ergo/files/ergo.confd3
-rw-r--r--net-irc/ergo/files/ergo.initd19
3 files changed, 0 insertions, 91 deletions
diff --git a/net-irc/ergo/ergo-2.9.1.ebuild b/net-irc/ergo/ergo-2.9.1.ebuild
deleted file mode 100644
index b68c0cb2089c..000000000000
--- a/net-irc/ergo/ergo-2.9.1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit go-module systemd
-
-DESCRIPTION="A modern IRC server written in Go"
-HOMEPAGE="https://ergo.chat/ https://github.com/ergochat/ergo"
-SRC_URI="https://github.com/ergochat/ergo/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD-2 BSD ISC MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# No test files are included in release tarballs
-# We may even want to package irctest
-RESTRICT="test"
-
-BDEPEND=">=dev-lang/go-1.14"
-RDEPEND="
- acct-user/oragono
- acct-group/oragono
-"
-
-DOCS=( README.md docs/MANUAL.md docs/USERGUIDE.md )
-
-src_prepare() {
- default
-
- # Minor fiddling with paths
- sed -i \
- -e 's:/home/ergo/ergo:/usr/bin/ergo:' \
- -e 's:/home/ergo:/var/lib/ergo:' \
- -e 's:/var/lib/ergo/ircd.yaml:/etc/ergo/ircd.yaml:' \
- -e 's:User=ergo:User=oragono:' \
- distrib/systemd/ergo.service || die
-}
-
-src_compile() {
- go build -mod=vendor . || die
-}
-
-src_install() {
- einstalldocs
-
- dobin ergo
-
- insinto /etc/ergo
- doins default.yaml
-
- newinitd distrib/openrc/ergo.initd ergo
- newconfd distrib/openrc/ergo.confd ergo
-
- keepdir /var/lib/ergo
- fowners oragono:oragono /var/lib/ergo
-
- insinto /var/lib/ergo
- doins -r languages/
-
- systemd_dounit distrib/systemd/ergo.service
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]] ; then
- elog "Please copy the example config in ${EROOT}/etc/ergo:"
- elog "e.g. cp ${EROOT}/etc/ergo/default.yaml ${EROOT}/etc/ergo/ircd.yaml"
- fi
-}
diff --git a/net-irc/ergo/files/ergo.confd b/net-irc/ergo/files/ergo.confd
deleted file mode 100644
index 336ca1de7ab0..000000000000
--- a/net-irc/ergo/files/ergo.confd
+++ /dev/null
@@ -1,3 +0,0 @@
-# /etc/conf.d/ergo: config file for /etc/init.d/ergo
-ERGO_CONFIGFILE="/etc/ergo/ircd.yaml"
-
diff --git a/net-irc/ergo/files/ergo.initd b/net-irc/ergo/files/ergo.initd
deleted file mode 100644
index 025d6951862b..000000000000
--- a/net-irc/ergo/files/ergo.initd
+++ /dev/null
@@ -1,19 +0,0 @@
-#!/sbin/openrc-run
-command=/usr/bin/ergo
-command_args="run --conf ${ERGO_CONFIGFILE:-"/etc/ergo/ircd.yaml"}"
-command_background=true
-extra_started_commands="reload"
-pidfile=/var/run/ergo.pid
-name="ergo"
-description="ergo IRC daemon"
-
-depend() {
- use dns
- provide ircd
-}
-
-reload() {
- ebegin "Reloading ${RC_SVCNAME}"
- start-stop-daemon --signal HUP --pidfile "${pidfile}"
- eend $?
-}