summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 00:14:31 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:30:04 +0100
commite997346dd006ea93d3ed22cf3bc8a276f0cdd326 (patch)
tree3e630a79d38a6947a5be56ccae725f3950bfef00 /net-fs
parentnet-firewall/fwknop: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-e997346dd006ea93d3ed22cf3bc8a276f0cdd326.tar.gz
gentoo-e997346dd006ea93d3ed22cf3bc8a276f0cdd326.tar.bz2
gentoo-e997346dd006ea93d3ed22cf3bc8a276f0cdd326.zip
net-fs/samba: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/samba-4.13.10-r1.ebuild2
-rw-r--r--net-fs/samba/samba-4.13.9-r2.ebuild2
-rw-r--r--net-fs/samba/samba-4.14.4-r2.ebuild2
-rw-r--r--net-fs/samba/samba-4.14.5-r2.ebuild2
-rw-r--r--net-fs/samba/samba-4.14.6-r1.ebuild2
-rw-r--r--net-fs/samba/samba-4.15.0_rc1-r1.ebuild2
6 files changed, 12 insertions, 0 deletions
diff --git a/net-fs/samba/samba-4.13.10-r1.ebuild b/net-fs/samba/samba-4.13.10-r1.ebuild
index c5eb38eb2f50..d04cb92e5119 100644
--- a/net-fs/samba/samba-4.13.10-r1.ebuild
+++ b/net-fs/samba/samba-4.13.10-r1.ebuild
@@ -320,6 +320,8 @@ multilib_src_test() {
}
pkg_postinst() {
+ tmpfiles_process samba.conf
+
if [[ -z ${REPLACING_VERSIONS} ]] ; then
elog "Be aware that this release contains the best of all of Samba's"
elog "technology parts, both a file server (that you can reasonably expect"
diff --git a/net-fs/samba/samba-4.13.9-r2.ebuild b/net-fs/samba/samba-4.13.9-r2.ebuild
index 1042fb9c1b7f..494b48393144 100644
--- a/net-fs/samba/samba-4.13.9-r2.ebuild
+++ b/net-fs/samba/samba-4.13.9-r2.ebuild
@@ -320,6 +320,8 @@ multilib_src_test() {
}
pkg_postinst() {
+ tmpfiles_process samba.conf
+
if [[ -z ${REPLACING_VERSIONS} ]] ; then
elog "Be aware that this release contains the best of all of Samba's"
elog "technology parts, both a file server (that you can reasonably expect"
diff --git a/net-fs/samba/samba-4.14.4-r2.ebuild b/net-fs/samba/samba-4.14.4-r2.ebuild
index 8c1e9a652efc..ac4c338a3303 100644
--- a/net-fs/samba/samba-4.14.4-r2.ebuild
+++ b/net-fs/samba/samba-4.14.4-r2.ebuild
@@ -324,6 +324,8 @@ multilib_src_test() {
}
pkg_postinst() {
+ tmpfiles_process samba.conf
+
if [[ -z ${REPLACING_VERSIONS} ]] ; then
elog "Be aware that this release contains the best of all of Samba's"
elog "technology parts, both a file server (that you can reasonably expect"
diff --git a/net-fs/samba/samba-4.14.5-r2.ebuild b/net-fs/samba/samba-4.14.5-r2.ebuild
index 39f4db758764..52f211eaa846 100644
--- a/net-fs/samba/samba-4.14.5-r2.ebuild
+++ b/net-fs/samba/samba-4.14.5-r2.ebuild
@@ -324,6 +324,8 @@ multilib_src_test() {
}
pkg_postinst() {
+ tmpfiles_process samba.conf
+
if [[ -z ${REPLACING_VERSIONS} ]] ; then
elog "Be aware that this release contains the best of all of Samba's"
elog "technology parts, both a file server (that you can reasonably expect"
diff --git a/net-fs/samba/samba-4.14.6-r1.ebuild b/net-fs/samba/samba-4.14.6-r1.ebuild
index 8c1e9a652efc..ac4c338a3303 100644
--- a/net-fs/samba/samba-4.14.6-r1.ebuild
+++ b/net-fs/samba/samba-4.14.6-r1.ebuild
@@ -324,6 +324,8 @@ multilib_src_test() {
}
pkg_postinst() {
+ tmpfiles_process samba.conf
+
if [[ -z ${REPLACING_VERSIONS} ]] ; then
elog "Be aware that this release contains the best of all of Samba's"
elog "technology parts, both a file server (that you can reasonably expect"
diff --git a/net-fs/samba/samba-4.15.0_rc1-r1.ebuild b/net-fs/samba/samba-4.15.0_rc1-r1.ebuild
index 6f9535c6ca1b..600ade433775 100644
--- a/net-fs/samba/samba-4.15.0_rc1-r1.ebuild
+++ b/net-fs/samba/samba-4.15.0_rc1-r1.ebuild
@@ -320,6 +320,8 @@ multilib_src_test() {
}
pkg_postinst() {
+ tmpfiles_process samba.conf
+
if [[ -z ${REPLACING_VERSIONS} ]] ; then
elog "Be aware that this release contains the best of all of Samba's"
elog "technology parts, both a file server (that you can reasonably expect"