summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-11-18 14:14:20 -0700
committerTim Harder <radhermit@gentoo.org>2019-11-18 14:18:21 -0700
commitad58335bf89ecb5abd68ca3bd212340c3e6bde06 (patch)
treecd40d990a64d0c6e502ad843c97cf3cca092da9c /net-fs/sshfs/sshfs-3.6.0.ebuild
parentsys-fs/fuse-common: remove old (diff)
downloadgentoo-ad58335bf89ecb5abd68ca3bd212340c3e6bde06.tar.gz
gentoo-ad58335bf89ecb5abd68ca3bd212340c3e6bde06.tar.bz2
gentoo-ad58335bf89ecb5abd68ca3bd212340c3e6bde06.zip
net-fs/sshfs: version bump to 3.6.0
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'net-fs/sshfs/sshfs-3.6.0.ebuild')
-rw-r--r--net-fs/sshfs/sshfs-3.6.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-fs/sshfs/sshfs-3.6.0.ebuild b/net-fs/sshfs/sshfs-3.6.0.ebuild
new file mode 100644
index 000000000000..2bf50acbf8d6
--- /dev/null
+++ b/net-fs/sshfs/sshfs-3.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Fuse-filesystem utilizing the sftp service"
+HOMEPAGE="https://github.com/libfuse/sshfs"
+SRC_URI="https://github.com/libfuse/${PN}/releases/download/${P}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+DEPEND=">=sys-fs/fuse-3.1.0:3
+ >=dev-libs/glib-2.4.2"
+RDEPEND="${DEPEND}
+ >=net-misc/openssh-4.4"
+BDEPEND="dev-python/docutils
+ virtual/pkgconfig"
+
+# requires root privs and specific localhost sshd setup
+RESTRICT="test"
+
+DOCS=( AUTHORS ChangeLog.rst README.rst )