summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-firewall/sanewall
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-firewall/sanewall')
-rw-r--r--net-firewall/sanewall/Manifest1
-rw-r--r--net-firewall/sanewall/files/sanewall.confd5
-rw-r--r--net-firewall/sanewall/files/sanewall.initd57
-rw-r--r--net-firewall/sanewall/metadata.xml7
-rw-r--r--net-firewall/sanewall/sanewall-1.1.6-r1.ebuild57
5 files changed, 127 insertions, 0 deletions
diff --git a/net-firewall/sanewall/Manifest b/net-firewall/sanewall/Manifest
new file mode 100644
index 000000000000..c2fe9fa72022
--- /dev/null
+++ b/net-firewall/sanewall/Manifest
@@ -0,0 +1 @@
+DIST sanewall-1.1.6.tar.xz 585316 SHA256 c26a339a1ac945aa0ddffbbb92ac4dff07302da8d9de6983832e91e123c4b00e SHA512 73260197b88816e90b15fc244a5940c290ec99c82eb8e50338b4f0f88710900c8cd18920c6f319205e527859c0696da28798428ab04b03c7f355c1d8ba6f7ca0 WHIRLPOOL cf906c539c4d348837fc93e46e7cf3d1d94cadcd111db918c265fa78133b35befd69ea2bdef782a054b035f40130821291b11965c7846220eaf4551237bcfb78
diff --git a/net-firewall/sanewall/files/sanewall.confd b/net-firewall/sanewall/files/sanewall.confd
new file mode 100644
index 000000000000..2193b04d49bf
--- /dev/null
+++ b/net-firewall/sanewall/files/sanewall.confd
@@ -0,0 +1,5 @@
+# location of sanewall config
+SANEWALL_CONFIG="/etc/sanewall/sanewall.conf"
+
+# arguments for sanewall
+#SANEWALL_OPTS=""
diff --git a/net-firewall/sanewall/files/sanewall.initd b/net-firewall/sanewall/files/sanewall.initd
new file mode 100644
index 000000000000..665d3868ff4c
--- /dev/null
+++ b/net-firewall/sanewall/files/sanewall.initd
@@ -0,0 +1,57 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+extra_commands="save panic try"
+extra_started_commands="reload"
+
+depend() {
+ need localmount
+ after bootmisc
+ before net
+ provide firewall
+}
+
+start_pre() {
+ if [ ! -f ${SANEWALL_CONFIG} ]; then
+ eerror "Not starting sanewall, missing config file ${SANEWALL_CONFIG}."
+ return 1
+ fi
+}
+
+start() {
+ ebegin "Starting sanewall"
+ /usr/sbin/sanewall ${SANEWALL_OPTS} ${SANEWALL_CONFIG} start >/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping sanewall"
+ /usr/sbin/sanewall ${SANEWALL_OPTS} stop >/dev/null
+ eend $?
+}
+
+try() {
+ ebegin "Trying sanewall configuration"
+ /usr/sbin/sanewall ${SANEWALL_OPTS} ${SANEWALL_CONFIG} try
+ eend $?
+}
+
+status() {
+ ebegin "Showing sanewall status"
+ /usr/sbin/sanewall ${SANEWALL_OPTS} status
+ eend $?
+}
+
+panic() {
+ ebegin "sanewall panic"
+ /usr/sbin/sanewall ${SANEWALL_OPTS} panic
+ eend $?
+}
+
+save() {
+ ebegin "Saving sanewall configuration"
+ /usr/sbin/sanewall ${SANEWALL_OPTS} save
+ eend $?
+}
diff --git a/net-firewall/sanewall/metadata.xml b/net-firewall/sanewall/metadata.xml
new file mode 100644
index 000000000000..ccea844db312
--- /dev/null
+++ b/net-firewall/sanewall/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-firewall/sanewall/sanewall-1.1.6-r1.ebuild b/net-firewall/sanewall/sanewall-1.1.6-r1.ebuild
new file mode 100644
index 000000000000..93ebfa5bf2f2
--- /dev/null
+++ b/net-firewall/sanewall/sanewall-1.1.6-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info
+
+DESCRIPTION="iptables firewall generator (fork of firehol)"
+HOMEPAGE="http://www.sanewall.org/"
+SRC_URI="http://download.sanewall.org/releases/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="net-firewall/iptables[ipv6]
+ sys-apps/iproute2[-minimal]
+ virtual/modutils
+ || (
+ net-misc/wget
+ net-misc/curl
+ )"
+
+pkg_setup() {
+ local KCONFIG_OPTS="~NF_CONNTRACK_IPV4 ~NF_CONNTRACK_MARK ~NF_NAT ~NF_NAT_FTP ~NF_NAT_IRC \
+ ~IP_NF_IPTABLES ~IP_NF_FILTER ~IP_NF_TARGET_REJECT ~IP_NF_TARGET_LOG ~IP_NF_TARGET_ULOG \
+ ~IP_NF_TARGET_MASQUERADE ~IP_NF_TARGET_REDIRECT ~IP_NF_MANGLE \
+ ~NETFILTER_XT_MATCH_LIMIT ~NETFILTER_XT_MATCH_STATE ~NETFILTER_XT_MATCH_OWNER"
+
+ get_version
+ if [[ ${KV_PATCH} -ge 25 ]] ; then
+ CONFIG_CHECK="~NF_CONNTRACK ${KCONFIG_OPTS}"
+ else
+ CONFIG_CHECK="~NF_CONNTRACK_ENABLED ${KCONFIG_OPTS}"
+ fi
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${PF}"
+}
+
+src_install() {
+ default
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+}
+
+pkg_postinst() {
+ # install default configuration if it doesn't exist
+ if [[ ! -e "${ROOT}"/etc/${PN}/${PN}.conf ]] ; then
+ einfo "Installing a sample configuration to ${ROOT}/etc/${PN}/${PN}.conf"
+ cp "${ROOT}"/etc/${PN}/${PN}.conf.example "${ROOT}"/etc/${PN}/${PN}.conf || die
+ fi
+}