summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-11 08:31:58 +0000
committerSam James <sam@gentoo.org>2021-03-11 08:31:58 +0000
commit3e14cd8f9d3511f0bad52aaf5e7310222072d75f (patch)
tree1345c1efbc11bed1bceeafa3d2c86e1330aa68d0 /net-dns/mydns
parentapp-admin/sagan: add note re strstr (diff)
downloadgentoo-3e14cd8f9d3511f0bad52aaf5e7310222072d75f.tar.gz
gentoo-3e14cd8f9d3511f0bad52aaf5e7310222072d75f.tar.bz2
gentoo-3e14cd8f9d3511f0bad52aaf5e7310222072d75f.zip
net-dns/mydns: workaround GCC 10 failure
Closes: https://bugs.gentoo.org/775134 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dns/mydns')
-rw-r--r--net-dns/mydns/mydns-1.2.8.31-r2.ebuild21
1 files changed, 14 insertions, 7 deletions
diff --git a/net-dns/mydns/mydns-1.2.8.31-r2.ebuild b/net-dns/mydns/mydns-1.2.8.31-r2.ebuild
index 6c69c1c647b6..e81a5dfecaf3 100644
--- a/net-dns/mydns/mydns-1.2.8.31-r2.ebuild
+++ b/net-dns/mydns/mydns-1.2.8.31-r2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools
+inherit autotools flag-o-matic
-DESCRIPTION="A DNS-Server which gets its data from a MySQL-/PostgreSQL-database"
+DESCRIPTION="A DNS-Server which gets its data from a MySQL/PostgreSQL-database"
HOMEPAGE="http://www.mydns.pl/"
SRC_URI="mirror://sourceforge/mydns-ng/${P}.tar.gz"
@@ -14,14 +14,18 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc x86"
IUSE="alias debug nls mysql postgres ssl static status"
-RDEPEND="mysql? ( dev-db/mysql-connector-c:= )
+BDEPEND="sys-devel/bison"
+RDEPEND="
+ virtual/libiconv
+ mysql? ( dev-db/mysql-connector-c:= )
nls? ( virtual/libintl )
postgres? ( dev-db/postgresql )
ssl? ( dev-libs/openssl:0= )
- virtual/libiconv"
-DEPEND="${RDEPEND}
+"
+DEPEND="
+ ${RDEPEND}
nls? ( >=sys-devel/gettext-0.12 )
- sys-devel/bison"
+"
REQUIRED_USE="^^ ( mysql postgres )"
@@ -38,6 +42,9 @@ src_prepare() {
}
src_configure() {
+ # bug #775134
+ append-flags -fcommon
+
econf \
$(use_enable alias) \
$(use_enable nls) \