summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2017-04-14 14:39:49 +0300
committerSergey Popov <pinkbyte@gentoo.org>2017-04-14 14:40:10 +0300
commit7a1e2c4bd8f744b24763f35c66ae4e161611f29f (patch)
treec45f475c9781956903991a6d8a446f7034aefd25 /net-dialup
parentprofiles: Mask media-gfx/kuickshow for removal (diff)
downloadgentoo-7a1e2c4bd8f744b24763f35c66ae4e161611f29f.tar.gz
gentoo-7a1e2c4bd8f744b24763f35c66ae4e161611f29f.tar.bz2
gentoo-7a1e2c4bd8f744b24763f35c66ae4e161611f29f.zip
net-dialup/ueagle4-atm: update ebuild - new EAPI, replace deprecated built_with_use with has_version
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'net-dialup')
-rw-r--r--net-dialup/ueagle4-atm/ueagle4-atm-1.0.ebuild30
1 files changed, 6 insertions, 24 deletions
diff --git a/net-dialup/ueagle4-atm/ueagle4-atm-1.0.ebuild b/net-dialup/ueagle4-atm/ueagle4-atm-1.0.ebuild
index 868ae43a6382..80b2ba00625b 100644
--- a/net-dialup/ueagle4-atm/ueagle4-atm-1.0.ebuild
+++ b/net-dialup/ueagle4-atm/ueagle4-atm-1.0.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
inherit eutils linux-info
@@ -12,7 +12,6 @@ SRC_URI="http://eagle-usb.org/ueagle-atm/non-free/ueagle4-data-${PV}.tar.gz"
LICENSE="Ikanos"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
DEPEND=""
RDEPEND="net-dialup/ppp
@@ -20,30 +19,13 @@ RDEPEND="net-dialup/ppp
S="${WORKDIR}/ueagle4-data-${PV}"
-pkg_setup() {
- linux-info_pkg_setup
-
- if kernel_is lt 2 6 16 ; then
- eerror "The kernel-space driver exists only in kernels >= 2.6.16."
- eerror "Please emerge net-dialup/eagle-usb instead or upgrade the kernel."
- die "Unsupported kernel version"
- fi
-
- if ! has_version '>=sys-apps/baselayout-1.12.0' ; then
- ewarn "The best way of using this driver is through the PPP net module of the"
- ewarn " >=sys-apps/baselayout-1.12.0"
- ewarn "which is also the only documented mode of using ${PN} driver."
- ewarn "Please install baselayout-1.12.0 or else you will be on your own!"
- fi
-}
-
src_install() {
# Copy to the firmware directory
insinto /lib/firmware/ueagle-atm
- doins * || die "doins firmware failed"
+ doins *
# Documentation necessary to complete the setup
- dodoc "${FILESDIR}/README" || die "dodoc failed"
+ dodoc "${FILESDIR}/README"
}
pkg_postinst() {
@@ -57,13 +39,13 @@ pkg_postinst() {
echo
# Check user-space for PPPoA support
- if ! built_with_use net-dialup/ppp atm ; then
+ if ! has_version net-dialup/ppp[atm] ; then
ewarn "Run the following command if connecting via PPPoA protocol:"
ewarn " euse -E atm && emerge net-dialup/ppp"
echo
fi
# Check user-space for PPPoE support
- if ! has_version >=net-dialup/linux-atm-2.5.0 ; then
+ if ! has_version net-dialup/linux-atm ; then
ewarn "Run the following command if connecting via PPPoE protocol:"
ewarn " emerge net-dialup/linux-atm"
echo