summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-06-26 21:20:19 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-06-26 21:21:37 +0300
commitbebd7293cc8cfc0bd2c61009221fcfa35e0dd981 (patch)
tree229f365d4cd1ded4b610f86cfb8cde1b93acad9a /net-dialup/picocom/picocom-3.1.ebuild
parentdev-python/tqdm: Drop old (diff)
downloadgentoo-bebd7293cc8cfc0bd2c61009221fcfa35e0dd981.tar.gz
gentoo-bebd7293cc8cfc0bd2c61009221fcfa35e0dd981.tar.bz2
gentoo-bebd7293cc8cfc0bd2c61009221fcfa35e0dd981.zip
net-dialup/picocom: Version bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-dialup/picocom/picocom-3.1.ebuild')
-rw-r--r--net-dialup/picocom/picocom-3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-dialup/picocom/picocom-3.1.ebuild b/net-dialup/picocom/picocom-3.1.ebuild
new file mode 100644
index 000000000000..e5d52e872d4f
--- /dev/null
+++ b/net-dialup/picocom/picocom-3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="minimal dumb-terminal emulation program"
+HOMEPAGE="https://github.com/npat-efault/picocom"
+SRC_URI="https://github.com/npat-efault/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+src_compile() {
+ # CPPFLAGS is shared between CFLAGS and CXXFLAGS, but there is no
+ # C++ file, and the pre-processor is never called directly, this
+ # is easier than patching it out.
+ emake LDFLAGS="${LDFLAGS}" CFLAGS="${CFLAGS} ${CPPFLAGS} -Wall" \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin picocom pc{asc,xm,ym,zm}
+ doman picocom.1
+ dodoc CHANGES.old CONTRIBUTORS README.md
+}