summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-28 00:30:30 +0100
committerSam James <sam@gentoo.org>2022-09-28 00:43:36 +0100
commitdaf3068ed0384f9a1503fe6ba36855ffc2217540 (patch)
treeb98601b1622e6ac4bbd5bd969407cc8f2ac26a09 /net-dialup/dial/dial-1.2-r2.ebuild
parentdev-db/etcd: Keyword 3.4.16 riscv, #873196 (diff)
downloadgentoo-daf3068ed0384f9a1503fe6ba36855ffc2217540.tar.gz
gentoo-daf3068ed0384f9a1503fe6ba36855ffc2217540.tar.bz2
gentoo-daf3068ed0384f9a1503fe6ba36855ffc2217540.zip
net-dialup/dial: fix configure w/ clang 16
Closes: https://bugs.gentoo.org/870463 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dialup/dial/dial-1.2-r2.ebuild')
-rw-r--r--net-dialup/dial/dial-1.2-r2.ebuild19
1 files changed, 14 insertions, 5 deletions
diff --git a/net-dialup/dial/dial-1.2-r2.ebuild b/net-dialup/dial/dial-1.2-r2.ebuild
index fef44139988a..37302de0f879 100644
--- a/net-dialup/dial/dial-1.2-r2.ebuild
+++ b/net-dialup/dial/dial-1.2-r2.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+inherit autotools
DESCRIPTION="A simple client for DWUN"
HOMEPAGE="http://dwun.sourceforge.net/"
@@ -10,9 +12,16 @@ SRC_URI="mirror://sourceforge/dwun/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 x86"
-IUSE=""
-DEPEND=""
RDEPEND="net-dialup/dwun"
-PATCHES=( "${FILESDIR}/${P}-gcc3.3.patch" )
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc3.3.patch
+ "${FILESDIR}"/${P}-rename-configure.ac.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}