summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-21 14:49:35 +0100
committerSam James <sam@gentoo.org>2024-04-21 14:49:41 +0100
commit53628c828b9510425fc683f5d45dcd68e6766be5 (patch)
tree66c0bf4a865b8c60acde9d52f77afa776410f7a2 /net-analyzer
parentnet-dialup/xl2tpd: drop 1.3.16-r1, 1.3.18 (diff)
downloadgentoo-53628c828b9510425fc683f5d45dcd68e6766be5.tar.gz
gentoo-53628c828b9510425fc683f5d45dcd68e6766be5.tar.bz2
gentoo-53628c828b9510425fc683f5d45dcd68e6766be5.zip
net-analyzer/fping: add 5.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/fping/Manifest1
-rw-r--r--net-analyzer/fping/fping-5.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-analyzer/fping/Manifest b/net-analyzer/fping/Manifest
index 5d58b6f9d312..78cb10654baa 100644
--- a/net-analyzer/fping/Manifest
+++ b/net-analyzer/fping/Manifest
@@ -1 +1,2 @@
DIST fping-5.1.tar.gz 191224 BLAKE2B 2fb344e650b5a359fb8780f2c599455d39405ae823edf695ee4385aa2661dc5811e088bafa1b9f53846ee90c0afa959a92832381a03346d1fda048eb4e7ee098 SHA512 1a208da8dcd99093d0512af5d85ba5e7b5743ec97993d24c1fe612bb58d93090ac1ba0952f648aa075f16d390a77c4be65e394ae56dbede2a6914e0e8c68e2bd
+DIST fping-5.2.tar.gz 194259 BLAKE2B 7efb445f32ffe2d3766d598da5f1585270ae8e68ceb8b64e418040f330e7736bfaf0313077e28b12031af25ed7952943603d3a5908174c3f78d9a1af0b735da9 SHA512 062896662804c55ffe2d4e3eb7efc2ff796d20a77b367e16f8fa381e302986b5127ca55f0866bbf08f8ae2b2f6795ec4c5d43dc59ebec157fb3e8eff25d0bdb3
diff --git a/net-analyzer/fping/fping-5.2.ebuild b/net-analyzer/fping/fping-5.2.ebuild
new file mode 100644
index 000000000000..4cd7221d0476
--- /dev/null
+++ b/net-analyzer/fping/fping-5.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps
+
+DESCRIPTION="Utility to ping multiple hosts at once"
+HOMEPAGE="https://fping.org/ https://github.com/schweikert/fping/"
+SRC_URI="
+ https://fping.org/dist/${P}.tar.gz
+ https://github.com/schweikert/fping/releases/download/v${PV}/${P}.tar.gz
+"
+
+LICENSE="fping"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug suid"
+# There are some tests in ci/* but they don't seem to be for packaging
+# (they want to modify the live FS by e.g. copying to /tmp.)
+RESTRICT="test"
+
+FILECAPS=( cap_net_raw+ep usr/sbin/fping )
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --enable-ipv6
+}
+
+src_install() {
+ default
+
+ if use suid; then
+ fperms u+s /usr/sbin/fping
+ fi
+
+ dosym fping /usr/sbin/fping6
+}