summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/tcptrack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/tcptrack')
-rw-r--r--net-analyzer/tcptrack/Manifest1
-rw-r--r--net-analyzer/tcptrack/files/tcptrack-1.4.2-tinfo.patch11
-rw-r--r--net-analyzer/tcptrack/metadata.xml5
-rw-r--r--net-analyzer/tcptrack/tcptrack-1.4.2.ebuild29
4 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/tcptrack/Manifest b/net-analyzer/tcptrack/Manifest
new file mode 100644
index 000000000000..f9c1ac017819
--- /dev/null
+++ b/net-analyzer/tcptrack/Manifest
@@ -0,0 +1 @@
+DIST tcptrack-1.4.2.tar.gz 120569 SHA256 6607b1e1c778c49d3e8795e119065cf66eb2db28b3255dbc56b1612527107049 SHA512 a15e22b2d7cc144b2f3c662b6e289fe28b538188d234b262d801d4212027446534c9981ef9f2a48125657fa87a367c748a9d98e86b5f38f865a47dd24d478f89 WHIRLPOOL d957d588b54970db9f6da0f35eed3b9542fa374bccbb995c39525b57de37fb757b76ba1a24e6b3208f654316ab74b0552e6c588c68a11e3461e0f7f81d71dfdd
diff --git a/net-analyzer/tcptrack/files/tcptrack-1.4.2-tinfo.patch b/net-analyzer/tcptrack/files/tcptrack-1.4.2-tinfo.patch
new file mode 100644
index 000000000000..fe23b48221ec
--- /dev/null
+++ b/net-analyzer/tcptrack/files/tcptrack-1.4.2-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/configure.in
++++ b/configure.in
+@@ -26,7 +26,7 @@
+ AC_CHECK_LIB(socket,gethostbyname)
+ AC_CHECK_LIB(nsl,gethostbyname)
+ AC_CHECK_LIB(nsl,inet_addr)
+-AC_CHECK_LIB(ncurses, initscr)
++PKG_CHECK_MODULES(ncurses,ncurses,LIBS="$LIBS $ncurses_LIBS",AC_MSG_ERROR([ncurses is required]))
+ AC_CHECK_LIB(pcap, pcap_open_live)
+ AC_CHECK_LIB(pthread, pthread_create)
+ AC_CHECK_LIB(rt, nanosleep)
diff --git a/net-analyzer/tcptrack/metadata.xml b/net-analyzer/tcptrack/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-analyzer/tcptrack/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-analyzer/tcptrack/tcptrack-1.4.2.ebuild b/net-analyzer/tcptrack/tcptrack-1.4.2.ebuild
new file mode 100644
index 000000000000..9aa6d5179183
--- /dev/null
+++ b/net-analyzer/tcptrack/tcptrack-1.4.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Passive per-connection tcp bandwidth monitor"
+HOMEPAGE="http://www.rhythm.cx/~steve/devel/tcptrack/"
+SRC_URI="http://www.rhythm.cx/~steve/devel/tcptrack/release/${PV}/source/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+
+DEPEND="
+ net-libs/libpcap
+ sys-libs/ncurses
+"
+RDEPEND="
+ ${DEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ sed -i src/Makefile.am -e 's| -Werror||g' || die
+ eautoreconf
+}