summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-03-07 12:56:44 +0100
committerDavid Seifert <soap@gentoo.org>2021-03-07 12:56:44 +0100
commitf3087c2f60949a840f8d4d002c5f38b7690b0331 (patch)
tree6dffb30ce4b042727c26fd47e2c7604002e76581 /net-analyzer/suricata
parentnet-analyzer/smokeping: migrate to tmpfiles.eclass (diff)
downloadgentoo-f3087c2f60949a840f8d4d002c5f38b7690b0331.tar.gz
gentoo-f3087c2f60949a840f8d4d002c5f38b7690b0331.tar.bz2
gentoo-f3087c2f60949a840f8d4d002c5f38b7690b0331.zip
net-analyzer/suricata: migrate to tmpfiles.eclass
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer/suricata')
-rw-r--r--net-analyzer/suricata/suricata-5.0.6.ebuild4
-rw-r--r--net-analyzer/suricata/suricata-6.0.2.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/net-analyzer/suricata/suricata-5.0.6.ebuild b/net-analyzer/suricata/suricata-5.0.6.ebuild
index ef4c372ec11e..b3efab9fb841 100644
--- a/net-analyzer/suricata/suricata-5.0.6.ebuild
+++ b/net-analyzer/suricata/suricata-5.0.6.ebuild
@@ -6,7 +6,7 @@ EAPI=7
LUA_COMPAT=( lua5-1 luajit )
PYTHON_COMPAT=( python3_{7..9} )
-inherit autotools flag-o-matic linux-info lua-single python-single-r1 systemd
+inherit autotools flag-o-matic linux-info lua-single python-single-r1 systemd tmpfiles
DESCRIPTION="High performance Network IDS, IPS and Network Security Monitoring engine"
HOMEPAGE="https://suricata-ids.org/"
@@ -139,7 +139,7 @@ src_install() {
newinitd "${FILESDIR}/${PN}-5.0.1-init" ${PN}
newconfd "${FILESDIR}/${PN}-5.0.1-conf" ${PN}
systemd_dounit "${FILESDIR}"/${PN}.service
- systemd_newtmpfilesd "${FILESDIR}"/${PN}.tmpfiles ${PN}.conf
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfiles ${PN}.conf
if use logrotate; then
insopts -m0644
diff --git a/net-analyzer/suricata/suricata-6.0.2.ebuild b/net-analyzer/suricata/suricata-6.0.2.ebuild
index 028ea37b43e7..18b52aaae039 100644
--- a/net-analyzer/suricata/suricata-6.0.2.ebuild
+++ b/net-analyzer/suricata/suricata-6.0.2.ebuild
@@ -6,7 +6,7 @@ EAPI=7
LUA_COMPAT=( lua5-1 luajit )
PYTHON_COMPAT=( python3_{7..9} )
-inherit autotools flag-o-matic linux-info lua-single python-single-r1 systemd
+inherit autotools flag-o-matic linux-info lua-single python-single-r1 systemd tmpfiles
DESCRIPTION="High performance Network IDS, IPS and Network Security Monitoring engine"
HOMEPAGE="https://suricata-ids.org/"
@@ -139,7 +139,7 @@ src_install() {
newinitd "${FILESDIR}/${PN}-5.0.1-init" ${PN}
newconfd "${FILESDIR}/${PN}-5.0.1-conf" ${PN}
systemd_dounit "${FILESDIR}"/${PN}.service
- systemd_newtmpfilesd "${FILESDIR}"/${PN}.tmpfiles ${PN}.conf
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfiles ${PN}.conf
if use logrotate; then
insopts -m0644