summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-02-19 18:57:50 +0100
committerHans de Graaff <graaff@gentoo.org>2024-02-19 18:58:56 +0100
commitc55ce926a55775972ef619cbf9ed48b369eeadab (patch)
tree054357ab801992569a926b18de53451ef1c73230 /net-analyzer/sslscan
parentsys-libs/glibc: keyword 2.38-r11 (diff)
downloadgentoo-c55ce926a55775972ef619cbf9ed48b369eeadab.tar.gz
gentoo-c55ce926a55775972ef619cbf9ed48b369eeadab.tar.bz2
gentoo-c55ce926a55775972ef619cbf9ed48b369eeadab.zip
net-analyzer/sslscan: add ~ppc64, use openssl 3.0.13
Bug: https://bugs.gentoo.org/851720 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'net-analyzer/sslscan')
-rw-r--r--net-analyzer/sslscan/Manifest1
-rw-r--r--net-analyzer/sslscan/sslscan-2.1.3-r1.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/net-analyzer/sslscan/Manifest b/net-analyzer/sslscan/Manifest
index 9e2b6b97af1b..ed9de4f1eecb 100644
--- a/net-analyzer/sslscan/Manifest
+++ b/net-analyzer/sslscan/Manifest
@@ -3,3 +3,4 @@ DIST sslscan-2.1.2.tar.gz 113842 BLAKE2B b4c297b9b8619f559bae28debaeab5fae89ba60
DIST sslscan-2.1.3.tar.gz 113917 BLAKE2B 2c3dd21838bca82035dc4d1c48869d4d2c2a18ea603b947d39040744d2f51c4946e6ca6681d734aafc62cf71b6e380b31f6f29c7164c14c2d75e0d1ab5925245 SHA512 62dbb8c97598cdc5bf22cb8311eaba6cff186f6b874d8eb4165a80d0577cd0a13837222fe6ee4e015c353acef2691ff044f4538c04044869805b5455abf36155
DIST sslscan-openssl-3.0.11.tar.gz 15347070 BLAKE2B e9b0d6c53b66fc66b1dfe46b042adb9bad770fa60555eea65748ef59bd7231ea8882f16ddff7e5ebdd1c164a83264a5d7da37a4f0207a3bd88045cabcebe0ea8 SHA512 4dd485720a335879bd52d0045edf65fd8397b6f6b6afb3e2c756230937304975b3bd95f67933cadde175cae81d420a692fcf7e96b9f9d2b059ea387a8d9ac305
DIST sslscan-openssl-3.0.12.tar.gz 15352880 BLAKE2B 55a321609e97636173421e738bfb745b6e9a912744fba6d83bfecba199f8684b5625b8547e29305dacda91735cd329fc4c3f5c1f0f919d362a81995073781796 SHA512 8eb6141c1f3d43aa7dd5a5570c99302910feae0d25ab872c58432e5d11d3e330a069715fd4a0cd03234f3fb3e5e9fba38ef59977f7ecf162a2b048476dbb14c6
+DIST sslscan-openssl-3.0.13.tar.gz 15440228 BLAKE2B 00f66b5940b494c36ea8731f05691bf85206c7a93f6313f3ff2cea36d35ce99e71dadc9620188eee8ea0d7be523721af432d7fd74aa59e34634796cd0e4899a6 SHA512 272223fefae76759de40219dd05ff119b99688a807c1af01360470ac5f390426e45463c1445988bf0a6e4cca23a6e0b1649a78121f9d6f69f92563e307a7fd70
diff --git a/net-analyzer/sslscan/sslscan-2.1.3-r1.ebuild b/net-analyzer/sslscan/sslscan-2.1.3-r1.ebuild
new file mode 100644
index 000000000000..85086045d0da
--- /dev/null
+++ b/net-analyzer/sslscan/sslscan-2.1.3-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+# sslscan builds against a static openssl library to allow weak ciphers
+# to be enabled so that they can be tested.
+OPENSSL_RELEASE_TAG="openssl-3.0.13"
+
+DESCRIPTION="Fast SSL configuration scanner"
+HOMEPAGE="https://github.com/rbsec/sslscan"
+SRC_URI="https://github.com/rbsec/sslscan/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/openssl/openssl/archive/${OPENSSL_RELEASE_TAG}.tar.gz -> ${PN}-${OPENSSL_RELEASE_TAG}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+# Requires a docker environment
+RESTRICT="test"
+
+# S="${WORKDIR}/${P}-${MY_FORK}"
+
+src_prepare() {
+ ln -s ../openssl-${OPENSSL_RELEASE_TAG} openssl || die
+ touch .openssl_is_fresh || die
+ sed -i -e '/openssl\/.git/,/fi/d' \
+ -e '/openssl test/d' Makefile || die
+
+ # Copied from dev-libs/openssl
+ # allow openssl to be cross-compiled
+ cp "${FILESDIR}"/gentoo.config-1.0.2 gentoo.config || die
+ chmod a+rx gentoo.config || die
+
+ default
+}
+
+src_configure() {
+ # Copied from dev-libs/openssl
+ unset APPS #197996
+ unset SCRIPTS #312551
+ unset CROSS_COMPILE #311473
+
+ tc-export CC AR RANLIB RC
+
+ local sslout=$(./gentoo.config)
+ einfo "Use configuration ${sslout:-(openssl knows best)}"
+ local config="Configure"
+ [[ -z ${sslout} ]] && config="config"
+
+ # Clean out hardcoded flags that openssl uses
+ local DEFAULT_CFLAGS=$(grep ^CFLAGS= Makefile | LC_ALL=C sed \
+ -e 's:^CFLAGS=::' \
+ -e 's:\(^\| \)-fomit-frame-pointer::g' \
+ -e 's:\(^\| \)-O[^ ]*::g' \
+ -e 's:\(^\| \)-march=[^ ]*::g' \
+ -e 's:\(^\| \)-mcpu=[^ ]*::g' \
+ -e 's:\(^\| \)-m[^ ]*::g' \
+ -e 's:^ *::' \
+ -e 's: *$::' \
+ -e 's: \+: :g' \
+ -e 's:\\:\\\\:g'
+ )
+
+ # Now insert clean default flags with user flags
+ sed -i \
+ -e "/^CFLAGS=/s|=.*|=${DEFAULT_CFLAGS} ${CFLAGS}|" \
+ -e "/^LDFLAGS=/s|=[[:space:]]*$|=${LDFLAGS}|" \
+ Makefile || die
+}
+
+src_compile() {
+ emake static
+}
+
+src_install() {
+ DESTDIR="${D}" emake install
+
+ dodoc Changelog README.md
+}