summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2016-02-21 21:25:35 +0100
committerSlawomir Lis <slis@gentoo.org>2016-04-26 08:12:16 +0200
commit909c0f0babd784307cae0c3d88c0e9e1d16f63b7 (patch)
tree31a07b4ff7624c85cc346a7791ff9c86c13f973b /net-analyzer/ntopng
parentdev-games/cegui: fix so name (diff)
downloadgentoo-909c0f0babd784307cae0c3d88c0e9e1d16f63b7.tar.gz
gentoo-909c0f0babd784307cae0c3d88c0e9e1d16f63b7.tar.bz2
gentoo-909c0f0babd784307cae0c3d88c0e9e1d16f63b7.zip
drop system-htp use flag (#575144)
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-analyzer/ntopng')
-rw-r--r--net-analyzer/ntopng/ntopng-2.0.ebuild23
1 files changed, 21 insertions, 2 deletions
diff --git a/net-analyzer/ntopng/ntopng-2.0.ebuild b/net-analyzer/ntopng/ntopng-2.0.ebuild
index b8aa18dd5b8c..1f16266f6ea7 100644
--- a/net-analyzer/ntopng/ntopng-2.0.ebuild
+++ b/net-analyzer/ntopng/ntopng-2.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit autotools user
+inherit autotools eutils user
DESCRIPTION="Network traffic analyzer with web interface"
HOMEPAGE="http://www.ntop.org/"
@@ -27,7 +27,26 @@ RDEPEND="${DEPEND}
src_prepare() {
cat "${S}/configure.seed" | sed "s/@VERSION@/${PV}/g" | sed "s/@SHORT_VERSION@/${PV}/g" > "${S}/configure.ac"
+ epatch "${FILESDIR}/${P}-dont-build-ndpi.patch"
eautoreconf
+
+ cd "${S}/nDPI"
+ eautoreconf
+}
+
+src_configure() {
+ cd "${S}/nDPI"
+ econf
+ cd "${S}"
+ econf
+}
+
+src_compile() {
+ cd "${S}/nDPI"
+ emake
+
+ cd "${S}"
+ emake
}
src_install() {