summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2020-10-20 11:29:00 -0400
committerCraig Andrews <candrews@gentoo.org>2020-10-20 11:29:26 -0400
commit341afe3203d838514de4fe6a2ee217e7b8378a87 (patch)
treebb4e4f7065bfb17ef1e23ad4cbc1a6aa8acecd9a /net-analyzer/netdata
parentdev-lang/spidermonkey: re-add ia64 JIT patches (diff)
downloadgentoo-341afe3203d838514de4fe6a2ee217e7b8378a87.tar.gz
gentoo-341afe3203d838514de4fe6a2ee217e7b8378a87.tar.bz2
gentoo-341afe3203d838514de4fe6a2ee217e7b8378a87.zip
net-analyzer/netdata: add lto USE flag
Closes: https://bugs.gentoo.org/750428 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-analyzer/netdata')
-rw-r--r--net-analyzer/netdata/metadata.xml1
-rw-r--r--net-analyzer/netdata/netdata-1.26.0.ebuild3
-rw-r--r--net-analyzer/netdata/netdata-9999.ebuild3
3 files changed, 5 insertions, 2 deletions
diff --git a/net-analyzer/netdata/metadata.xml b/net-analyzer/netdata/metadata.xml
index 8c3dae0f9448..7eb822608727 100644
--- a/net-analyzer/netdata/metadata.xml
+++ b/net-analyzer/netdata/metadata.xml
@@ -11,6 +11,7 @@
<flag name="ipmi">Install <pkg>sys-apps/ipmitool</pkg> required for monitoring IPMI sensors.</flag>
<flag name="jsonc">Enable optimization of JSON using <pkg>dev-libs/json-c</pkg></flag>
<flag name="kinesis">Enable support for Amazon Kenesis as a backend</flag>
+ <flag name="lto">Build with Link Time Optimization (LTO)</flag>
<flag name="mongodb">Enable support for the mongodb backend</flag>
<flag name="nfacct">Enable the nfacct plugin</flag>
<flag name="nodejs">Enable use of nodejs (which some plugins use)</flag>
diff --git a/net-analyzer/netdata/netdata-1.26.0.ebuild b/net-analyzer/netdata/netdata-1.26.0.ebuild
index 48231022d056..f935e5a09fa2 100644
--- a/net-analyzer/netdata/netdata-1.26.0.ebuild
+++ b/net-analyzer/netdata/netdata-1.26.0.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
LICENSE="GPL-3+ MIT BSD"
SLOT="0"
-IUSE="caps +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc kinesis mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
+IUSE="caps +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc kinesis +lto mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
REQUIRED_USE="
mysql? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -106,6 +106,7 @@ src_configure() {
$(use_enable nfacct plugin-nfacct) \
$(use_enable ipmi plugin-freeipmi) \
$(use_enable kinesis backend-kinesis) \
+ $(use_enable lto lto) \
$(use_enable mongodb backend-mongodb) \
$(use_enable prometheus backend-prometheus-remote-write) \
$(use_enable xen plugin-xenstat) \
diff --git a/net-analyzer/netdata/netdata-9999.ebuild b/net-analyzer/netdata/netdata-9999.ebuild
index 48231022d056..f935e5a09fa2 100644
--- a/net-analyzer/netdata/netdata-9999.ebuild
+++ b/net-analyzer/netdata/netdata-9999.ebuild
@@ -19,7 +19,7 @@ HOMEPAGE="https://github.com/netdata/netdata https://my-netdata.io/"
LICENSE="GPL-3+ MIT BSD"
SLOT="0"
-IUSE="caps +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc kinesis mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
+IUSE="caps +compression cpu_flags_x86_sse2 cups +dbengine ipmi +jsonc kinesis +lto mongodb mysql nfacct nodejs postgres prometheus +python tor xen"
REQUIRED_USE="
mysql? ( python )
python? ( ${PYTHON_REQUIRED_USE} )
@@ -106,6 +106,7 @@ src_configure() {
$(use_enable nfacct plugin-nfacct) \
$(use_enable ipmi plugin-freeipmi) \
$(use_enable kinesis backend-kinesis) \
+ $(use_enable lto lto) \
$(use_enable mongodb backend-mongodb) \
$(use_enable prometheus backend-prometheus-remote-write) \
$(use_enable xen plugin-xenstat) \