summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/echoping/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/echoping/files')
-rw-r--r--net-analyzer/echoping/files/echoping-6.0.2-fix_implicit_declarations.patch20
-rw-r--r--net-analyzer/echoping/files/echoping-6.0.2-gnutls.patch41
-rw-r--r--net-analyzer/echoping/files/echoping-6.0.2_p434-fix_implicit_declarations.patch20
3 files changed, 81 insertions, 0 deletions
diff --git a/net-analyzer/echoping/files/echoping-6.0.2-fix_implicit_declarations.patch b/net-analyzer/echoping/files/echoping-6.0.2-fix_implicit_declarations.patch
new file mode 100644
index 000000000000..1b0bce850421
--- /dev/null
+++ b/net-analyzer/echoping/files/echoping-6.0.2-fix_implicit_declarations.patch
@@ -0,0 +1,20 @@
+--- echoping.h
++++ echoping.h 2009-09-15 00:55:43.000000000 +0200
+@@ -198,6 +198,7 @@
+ #endif
+ /* util.c */
+ char *random_string ();
++char *to_upper();
+ void tvsub ();
+ void tvadd ();
+ void tvavg ();
+--- plugins/ldap/ldap.c
++++ plugins/ldap/ldap.c
+@@ -9,6 +9,7 @@
+ #include "../../config.h"
+ #include "config.h"
+ #endif
++#define LDAP_DEPRECATED 1
+ #include <ldap.h>
+
+ const char *request = NULL;
diff --git a/net-analyzer/echoping/files/echoping-6.0.2-gnutls.patch b/net-analyzer/echoping/files/echoping-6.0.2-gnutls.patch
new file mode 100644
index 000000000000..b5be2d989776
--- /dev/null
+++ b/net-analyzer/echoping/files/echoping-6.0.2-gnutls.patch
@@ -0,0 +1,41 @@
+Date: 2009-06-30 14:26
+Sender: bortz
+
+The patch by ametzler seems indeed to work (thanks to him). I've committed
+it (r426) and will make a new release soon.
+
+http://sourceforge.net/tracker/index.php?func=detail&aid=2811861&group_id=4581&atid=104581
+
+
+--- trunk/SRC/configure.ac 2009/06/30 14:18:15 425
++++ trunk/SRC/configure.ac 2009/06/30 14:19:07 426
+@@ -92,14 +92,21 @@
+ AC_ARG_WITH(gnutls,
+ [ --with-gnutls[=DIR] SSL/TLS crypt support (needs GNU TLS), the argument DIR should not be necessary],dnl
+ [if test "$withval" != "no"; then
+- AC_DEFINE(GNUTLS,,[Crypto (TLS) support])
+- GNUTLS=1
+- CPPFLAGS="${CPPFLAGS} `libgnutls-config --cflags`"
+- LDFLAGS="${LDFLAGS} `libgnutls-config --libs`"
+- if test "$withval" != "yes"; then
+- GNUTLSROOT=$withval
+- LDFLAGS="${LDFLAGS} -L$GNUTLSROOT/lib"
+- CPPFLAGS="${CPPFLAGS} -I$GNUTLSROOT/include"
++ if test "$withval" = "yes"; then
++ PKG_CHECK_MODULES([LIBGNUTLS], [gnutls >= 1.0.0],
++ [
++ echo "GnuTLS found"
++ AC_DEFINE(GNUTLS,,[Crypto (TLS) support])
++ GNUTLS=1
++ CFLAGS="$CFLAGS $LIBGNUTLS_CFLAGS"
++ LIBS="$LIBS $LIBGNUTLS_LIBS"
++ ],)
++ else
++ AC_DEFINE(GNUTLS,,[Crypto (TLS) support])
++ GNUTLS=1
++ GNUTLSROOT=$withval
++ LDFLAGS="${LDFLAGS} -L$GNUTLSROOT/lib -lgnutls"
++ CPPFLAGS="${CPPFLAGS} -I$GNUTLSROOT/include"
+ fi
+ fi],
+ dnl Default: disable it
diff --git a/net-analyzer/echoping/files/echoping-6.0.2_p434-fix_implicit_declarations.patch b/net-analyzer/echoping/files/echoping-6.0.2_p434-fix_implicit_declarations.patch
new file mode 100644
index 000000000000..c2fd2f6886cb
--- /dev/null
+++ b/net-analyzer/echoping/files/echoping-6.0.2_p434-fix_implicit_declarations.patch
@@ -0,0 +1,20 @@
+--- a/echoping.h
++++ b/echoping.h
+@@ -194,6 +194,7 @@
+ #endif
+ /* util.c */
+ char *random_string();
++char *to_upper();
+ void tvsub();
+ void tvadd();
+ void tvavg();
+--- a/plugins/ldap/ldap.c
++++ b/plugins/ldap/ldap.c
+@@ -9,6 +9,7 @@
+ #include "../../config.h"
+ #include "config.h"
+ #endif
++#define LDAP_DEPRECATED 1
+ #include <ldap.h>
+
+ const char *request = NULL;