summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-09-12 19:16:56 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-09-12 21:37:43 +0300
commit75b2fa612d4902f5714b03a979cd9e4d88cbeb3d (patch)
tree508419c48ba10a43a1535ee066c8264f15643b33 /media-video
parent*/*: drop ia64 from depends (diff)
downloadgentoo-75b2fa612d4902f5714b03a979cd9e4d88cbeb3d.tar.gz
gentoo-75b2fa612d4902f5714b03a979cd9e4d88cbeb3d.tar.bz2
gentoo-75b2fa612d4902f5714b03a979cd9e4d88cbeb3d.zip
*/*: remove use ia64 calls
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpeg-chromium/ffmpeg-chromium-125.ebuild9
-rw-r--r--media-video/ffmpeg-chromium/ffmpeg-chromium-126.ebuild9
-rw-r--r--media-video/ffmpeg-chromium/ffmpeg-chromium-127.ebuild9
-rw-r--r--media-video/ffmpeg-chromium/ffmpeg-chromium-128.ebuild9
-rw-r--r--media-video/ffmpeg-chromium/ffmpeg-chromium-129.ebuild9
-rw-r--r--media-video/ffmpeg/ffmpeg-4.4.4-r10.ebuild9
-rw-r--r--media-video/ffmpeg/ffmpeg-4.4.4-r9.ebuild9
-rw-r--r--media-video/ffmpeg/ffmpeg-4.4.5.ebuild9
-rw-r--r--media-video/ffmpeg/ffmpeg-6.0.1-r4.ebuild9
-rw-r--r--media-video/ffmpeg/ffmpeg-6.1.1-r5.ebuild9
-rw-r--r--media-video/ffmpeg/ffmpeg-6.1.1-r8.ebuild9
-rw-r--r--media-video/ffmpeg/ffmpeg-6.1.2.ebuild9
-rw-r--r--media-video/ffmpeg/ffmpeg-7.0.1.ebuild9
-rw-r--r--media-video/ffmpeg/ffmpeg-7.0.2.ebuild9
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild9
15 files changed, 0 insertions, 135 deletions
diff --git a/media-video/ffmpeg-chromium/ffmpeg-chromium-125.ebuild b/media-video/ffmpeg-chromium/ffmpeg-chromium-125.ebuild
index 3186f0ec2b6a..7112d7b23cff 100644
--- a/media-video/ffmpeg-chromium/ffmpeg-chromium-125.ebuild
+++ b/media-video/ffmpeg-chromium/ffmpeg-chromium-125.ebuild
@@ -140,15 +140,6 @@ src_configure() {
# Bug #918997. Will probably be fixed upstream in the next release.
use vulkan && append-ldflags -Wl,-z,muldefs
- # bug 842201
- use ia64 && tc-is-gcc && append-flags \
- -fno-tree-ccp \
- -fno-tree-dominator-opts \
- -fno-tree-fre \
- -fno-code-hoisting \
- -fno-tree-pre \
- -fno-tree-vrp
-
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
for i in "${ffuse[@]#+}" ; do
diff --git a/media-video/ffmpeg-chromium/ffmpeg-chromium-126.ebuild b/media-video/ffmpeg-chromium/ffmpeg-chromium-126.ebuild
index e4db10a00285..30123f9c2d1f 100644
--- a/media-video/ffmpeg-chromium/ffmpeg-chromium-126.ebuild
+++ b/media-video/ffmpeg-chromium/ffmpeg-chromium-126.ebuild
@@ -140,15 +140,6 @@ src_configure() {
# Bug #918997. Will probably be fixed upstream in the next release.
use vulkan && append-ldflags -Wl,-z,muldefs
- # bug 842201
- use ia64 && tc-is-gcc && append-flags \
- -fno-tree-ccp \
- -fno-tree-dominator-opts \
- -fno-tree-fre \
- -fno-code-hoisting \
- -fno-tree-pre \
- -fno-tree-vrp
-
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
for i in "${ffuse[@]#+}" ; do
diff --git a/media-video/ffmpeg-chromium/ffmpeg-chromium-127.ebuild b/media-video/ffmpeg-chromium/ffmpeg-chromium-127.ebuild
index 91d93d2a4d58..f67cb20d79f3 100644
--- a/media-video/ffmpeg-chromium/ffmpeg-chromium-127.ebuild
+++ b/media-video/ffmpeg-chromium/ffmpeg-chromium-127.ebuild
@@ -140,15 +140,6 @@ src_configure() {
# Bug #918997. Will probably be fixed upstream in the next release.
use vulkan && append-ldflags -Wl,-z,muldefs
- # bug 842201
- use ia64 && tc-is-gcc && append-flags \
- -fno-tree-ccp \
- -fno-tree-dominator-opts \
- -fno-tree-fre \
- -fno-code-hoisting \
- -fno-tree-pre \
- -fno-tree-vrp
-
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
for i in "${ffuse[@]#+}" ; do
diff --git a/media-video/ffmpeg-chromium/ffmpeg-chromium-128.ebuild b/media-video/ffmpeg-chromium/ffmpeg-chromium-128.ebuild
index 947eddc83b5d..0669dac8dc36 100644
--- a/media-video/ffmpeg-chromium/ffmpeg-chromium-128.ebuild
+++ b/media-video/ffmpeg-chromium/ffmpeg-chromium-128.ebuild
@@ -140,15 +140,6 @@ src_configure() {
# Bug #918997. Will probably be fixed upstream in the next release.
use vulkan && append-ldflags -Wl,-z,muldefs
- # bug 842201
- use ia64 && tc-is-gcc && append-flags \
- -fno-tree-ccp \
- -fno-tree-dominator-opts \
- -fno-tree-fre \
- -fno-code-hoisting \
- -fno-tree-pre \
- -fno-tree-vrp
-
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
for i in "${ffuse[@]#+}" ; do
diff --git a/media-video/ffmpeg-chromium/ffmpeg-chromium-129.ebuild b/media-video/ffmpeg-chromium/ffmpeg-chromium-129.ebuild
index c5b82639dda6..b17b9937116a 100644
--- a/media-video/ffmpeg-chromium/ffmpeg-chromium-129.ebuild
+++ b/media-video/ffmpeg-chromium/ffmpeg-chromium-129.ebuild
@@ -140,15 +140,6 @@ src_configure() {
# Bug #918997. Will probably be fixed upstream in the next release.
use vulkan && append-ldflags -Wl,-z,muldefs
- # bug 842201
- use ia64 && tc-is-gcc && append-flags \
- -fno-tree-ccp \
- -fno-tree-dominator-opts \
- -fno-tree-fre \
- -fno-code-hoisting \
- -fno-tree-pre \
- -fno-tree-vrp
-
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
for i in "${ffuse[@]#+}" ; do
diff --git a/media-video/ffmpeg/ffmpeg-4.4.4-r10.ebuild b/media-video/ffmpeg/ffmpeg-4.4.4-r10.ebuild
index 51b02fd3e260..9e0ffd130260 100644
--- a/media-video/ffmpeg/ffmpeg-4.4.4-r10.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.4.4-r10.ebuild
@@ -404,15 +404,6 @@ src_prepare() {
multilib_src_configure() {
local myconf=( )
- # bug 842201
- use ia64 && tc-is-gcc && append-flags \
- -fno-tree-ccp \
- -fno-tree-dominator-opts \
- -fno-tree-fre \
- -fno-code-hoisting \
- -fno-tree-pre \
- -fno-tree-vrp
-
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
use openssl && myconf+=( --enable-nonfree )
use samba && myconf+=( --enable-version3 )
diff --git a/media-video/ffmpeg/ffmpeg-4.4.4-r9.ebuild b/media-video/ffmpeg/ffmpeg-4.4.4-r9.ebuild
index d8a293dadad7..155021576490 100644
--- a/media-video/ffmpeg/ffmpeg-4.4.4-r9.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.4.4-r9.ebuild
@@ -403,15 +403,6 @@ src_prepare() {
multilib_src_configure() {
local myconf=( )
- # bug 842201
- use ia64 && tc-is-gcc && append-flags \
- -fno-tree-ccp \
- -fno-tree-dominator-opts \
- -fno-tree-fre \
- -fno-code-hoisting \
- -fno-tree-pre \
- -fno-tree-vrp
-
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
use openssl && myconf+=( --enable-nonfree )
use samba && myconf+=( --enable-version3 )
diff --git a/media-video/ffmpeg/ffmpeg-4.4.5.ebuild b/media-video/ffmpeg/ffmpeg-4.4.5.ebuild
index b8ce9c1d72c1..fcdff1e2f2ef 100644
--- a/media-video/ffmpeg/ffmpeg-4.4.5.ebuild
+++ b/media-video/ffmpeg/ffmpeg-4.4.5.ebuild
@@ -400,15 +400,6 @@ src_prepare() {
multilib_src_configure() {
local myconf=( )
- # bug 842201
- use ia64 && tc-is-gcc && append-flags \
- -fno-tree-ccp \
- -fno-tree-dominator-opts \
- -fno-tree-fre \
- -fno-code-hoisting \
- -fno-tree-pre \
- -fno-tree-vrp
-
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
use openssl && myconf+=( --enable-nonfree )
use samba && myconf+=( --enable-version3 )
diff --git a/media-video/ffmpeg/ffmpeg-6.0.1-r4.ebuild b/media-video/ffmpeg/ffmpeg-6.0.1-r4.ebuild
index d087a4303b19..d0a3bb596892 100644
--- a/media-video/ffmpeg/ffmpeg-6.0.1-r4.ebuild
+++ b/media-video/ffmpeg/ffmpeg-6.0.1-r4.ebuild
@@ -390,15 +390,6 @@ src_prepare() {
multilib_src_configure() {
local myconf=( )
- # bug 842201
- use ia64 && tc-is-gcc && append-flags \
- -fno-tree-ccp \
- -fno-tree-dominator-opts \
- -fno-tree-fre \
- -fno-code-hoisting \
- -fno-tree-pre \
- -fno-tree-vrp
-
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
use openssl && myconf+=( --enable-nonfree )
use samba && myconf+=( --enable-version3 )
diff --git a/media-video/ffmpeg/ffmpeg-6.1.1-r5.ebuild b/media-video/ffmpeg/ffmpeg-6.1.1-r5.ebuild
index 2b29d0775b10..8ca3ffa196ed 100644
--- a/media-video/ffmpeg/ffmpeg-6.1.1-r5.ebuild
+++ b/media-video/ffmpeg/ffmpeg-6.1.1-r5.ebuild
@@ -427,15 +427,6 @@ multilib_src_configure() {
# Conditional patch options
use soc && myconf+=( --enable-v4l2-request --enable-libudev --enable-sand )
- # bug 842201
- use ia64 && tc-is-gcc && append-flags \
- -fno-tree-ccp \
- -fno-tree-dominator-opts \
- -fno-tree-fre \
- -fno-code-hoisting \
- -fno-tree-pre \
- -fno-tree-vrp
-
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
use openssl && myconf+=( --enable-nonfree )
use samba && myconf+=( --enable-version3 )
diff --git a/media-video/ffmpeg/ffmpeg-6.1.1-r8.ebuild b/media-video/ffmpeg/ffmpeg-6.1.1-r8.ebuild
index e4af2dbdb704..f83fcb1a0176 100644
--- a/media-video/ffmpeg/ffmpeg-6.1.1-r8.ebuild
+++ b/media-video/ffmpeg/ffmpeg-6.1.1-r8.ebuild
@@ -437,15 +437,6 @@ multilib_src_configure() {
# Conditional patch options
use soc && myconf+=( --enable-v4l2-request --enable-libudev --enable-sand )
- # bug 842201
- use ia64 && tc-is-gcc && append-flags \
- -fno-tree-ccp \
- -fno-tree-dominator-opts \
- -fno-tree-fre \
- -fno-code-hoisting \
- -fno-tree-pre \
- -fno-tree-vrp
-
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
use openssl && myconf+=( --enable-nonfree )
use samba && myconf+=( --enable-version3 )
diff --git a/media-video/ffmpeg/ffmpeg-6.1.2.ebuild b/media-video/ffmpeg/ffmpeg-6.1.2.ebuild
index b5656bbecb91..cf2f2c615aaf 100644
--- a/media-video/ffmpeg/ffmpeg-6.1.2.ebuild
+++ b/media-video/ffmpeg/ffmpeg-6.1.2.ebuild
@@ -435,15 +435,6 @@ multilib_src_configure() {
# Conditional patch options
use soc && myconf+=( --enable-v4l2-request --enable-libudev --enable-sand )
- # bug 842201
- use ia64 && tc-is-gcc && append-flags \
- -fno-tree-ccp \
- -fno-tree-dominator-opts \
- -fno-tree-fre \
- -fno-code-hoisting \
- -fno-tree-pre \
- -fno-tree-vrp
-
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
use openssl && myconf+=( --enable-nonfree )
use samba && myconf+=( --enable-version3 )
diff --git a/media-video/ffmpeg/ffmpeg-7.0.1.ebuild b/media-video/ffmpeg/ffmpeg-7.0.1.ebuild
index 03be411aedcc..467c8c4a6bb7 100644
--- a/media-video/ffmpeg/ffmpeg-7.0.1.ebuild
+++ b/media-video/ffmpeg/ffmpeg-7.0.1.ebuild
@@ -434,15 +434,6 @@ multilib_src_configure() {
# Conditional patch options
use soc && myconf+=( --enable-v4l2-request --enable-libudev --enable-sand )
- # bug 842201
- use ia64 && tc-is-gcc && append-flags \
- -fno-tree-ccp \
- -fno-tree-dominator-opts \
- -fno-tree-fre \
- -fno-code-hoisting \
- -fno-tree-pre \
- -fno-tree-vrp
-
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
use openssl && myconf+=( --enable-nonfree )
use samba && myconf+=( --enable-version3 )
diff --git a/media-video/ffmpeg/ffmpeg-7.0.2.ebuild b/media-video/ffmpeg/ffmpeg-7.0.2.ebuild
index 03be411aedcc..467c8c4a6bb7 100644
--- a/media-video/ffmpeg/ffmpeg-7.0.2.ebuild
+++ b/media-video/ffmpeg/ffmpeg-7.0.2.ebuild
@@ -434,15 +434,6 @@ multilib_src_configure() {
# Conditional patch options
use soc && myconf+=( --enable-v4l2-request --enable-libudev --enable-sand )
- # bug 842201
- use ia64 && tc-is-gcc && append-flags \
- -fno-tree-ccp \
- -fno-tree-dominator-opts \
- -fno-tree-fre \
- -fno-code-hoisting \
- -fno-tree-pre \
- -fno-tree-vrp
-
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
use openssl && myconf+=( --enable-nonfree )
use samba && myconf+=( --enable-version3 )
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 9bcc84fb80e0..2c36d52fbafe 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -435,15 +435,6 @@ multilib_src_configure() {
# Conditional patch options
use soc && myconf+=( --enable-v4l2-request --enable-libudev --enable-sand )
- # bug 842201
- use ia64 && tc-is-gcc && append-flags \
- -fno-tree-ccp \
- -fno-tree-dominator-opts \
- -fno-tree-fre \
- -fno-code-hoisting \
- -fno-tree-pre \
- -fno-tree-vrp
-
local ffuse=( "${FFMPEG_FLAG_MAP[@]}" )
use openssl && myconf+=( --enable-nonfree )
use samba && myconf+=( --enable-version3 )