summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-06-21 10:25:15 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-06-21 10:29:43 +0200
commit032d9f3e8f89b760dc4d179a79128ae0490387b7 (patch)
treec7b8759db255461d04e23af5a19d4b2f67dc8fb5 /media-video/v4l2loopback
parentdev-perl/MIME-Charset: Stabilize 1.13.1 hppa, #908931 (diff)
downloadgentoo-032d9f3e8f89b760dc4d179a79128ae0490387b7.tar.gz
gentoo-032d9f3e8f89b760dc4d179a79128ae0490387b7.tar.bz2
gentoo-032d9f3e8f89b760dc4d179a79128ae0490387b7.zip
media-video/v4l2loopback: migrate to linux-mod-r1.eclass, EAPI bump
This should also fix Bug 843053 (please confirm that it works now) Should also fix the open CVE-2022-2652, the mentioned patch is in this release Bug: https://bugs.gentoo.org/864442 Bug: https://bugs.gentoo.org/843053 Closes: https://bugs.gentoo.org/888649 Closes: https://bugs.gentoo.org/908723 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'media-video/v4l2loopback')
-rw-r--r--media-video/v4l2loopback/Manifest1
-rw-r--r--media-video/v4l2loopback/v4l2loopback-0.12.7.ebuild59
-rw-r--r--media-video/v4l2loopback/v4l2loopback-9999.ebuild19
3 files changed, 70 insertions, 9 deletions
diff --git a/media-video/v4l2loopback/Manifest b/media-video/v4l2loopback/Manifest
index 1421e2da2b68..8df167f2e7a4 100644
--- a/media-video/v4l2loopback/Manifest
+++ b/media-video/v4l2loopback/Manifest
@@ -1 +1,2 @@
DIST v4l2loopback-0.12.5.tar.gz 51468 BLAKE2B 514f686fc6f87feebedb1b047e764fa03938c265c88db0fedfb6aba3544f5b8b495631fc0bcdf4b88c1c4d522f6b4d7546b4d0d10381f6be2efc7f405511033a SHA512 5fd2affbb4a7f38bb78f996179de6570b2bd69cfed2a79c4505e7ea2cdf5b65c0a6807f1f4e03f320b667f5cbe62f26fadd412bc0fec5944e4e394635bf5fb3d
+DIST v4l2loopback-0.12.7.tar.gz 52145 BLAKE2B 08b0dd6dfd065f8bc450aad8d711d1723fe65bbee6be4624038f34e8ad8bc2ed6e544fc5771fb42b0e8c92213c2db71aff5857c0b1fd6343c6900bf27df618d7 SHA512 fcfe55396e9ddad56e592ffccd955c8ceff49c11cfbc5af382123ee0c15b41729b78cb763acbb17d288c48498f2183a4b24f146758ae67e1982b7ab2b07ff973
diff --git a/media-video/v4l2loopback/v4l2loopback-0.12.7.ebuild b/media-video/v4l2loopback/v4l2loopback-0.12.7.ebuild
new file mode 100644
index 000000000000..20dda14f748d
--- /dev/null
+++ b/media-video/v4l2loopback/v4l2loopback-0.12.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1 toolchain-funcs
+
+case ${PV} in
+9999)
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/umlaeute/v4l2loopback.git"
+ ;;
+*)
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/umlaeute/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ ;;
+esac
+
+DESCRIPTION="v4l2 loopback device whose output is its own input"
+HOMEPAGE="https://github.com/umlaeute/v4l2loopback"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples"
+
+CONFIG_CHECK="VIDEO_DEV"
+
+pkg_setup() {
+ linux-mod-r1_pkg_setup
+ export KERNELRELEASE=${KV_FULL}
+}
+
+src_prepare() {
+ default
+ sed -i -e 's/gcc /$(CC) /' examples/Makefile || die
+}
+
+src_compile() {
+ local modlist=(
+ v4l2loopback=video:
+ )
+
+ linux-mod-r1_src_compile
+ if use examples; then
+ emake CC="$(tc-getCC)" -C examples
+ fi
+}
+
+src_install() {
+ linux-mod-r1_src_install
+ dosbin utils/v4l2loopback-ctl
+ dodoc doc/kernel_debugging.txt
+ dodoc doc/docs.txt
+ if use examples; then
+ dosbin examples/yuv4mpeg_to_v4l2
+ docinto examples
+ dodoc examples/{*.sh,*.c,Makefile}
+ fi
+}
diff --git a/media-video/v4l2loopback/v4l2loopback-9999.ebuild b/media-video/v4l2loopback/v4l2loopback-9999.ebuild
index 760951059416..20dda14f748d 100644
--- a/media-video/v4l2loopback/v4l2loopback-9999.ebuild
+++ b/media-video/v4l2loopback/v4l2loopback-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit linux-mod toolchain-funcs
+inherit linux-mod-r1 toolchain-funcs
case ${PV} in
9999)
@@ -11,7 +11,6 @@ case ${PV} in
EGIT_REPO_URI="https://github.com/umlaeute/v4l2loopback.git"
;;
*)
- inherit vcs-snapshot
KEYWORDS="~amd64 ~x86"
SRC_URI="https://github.com/umlaeute/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
;;
@@ -25,11 +24,9 @@ SLOT="0"
IUSE="examples"
CONFIG_CHECK="VIDEO_DEV"
-MODULE_NAMES="v4l2loopback(video:)"
-BUILD_TARGETS="all"
pkg_setup() {
- linux-mod_pkg_setup
+ linux-mod-r1_pkg_setup
export KERNELRELEASE=${KV_FULL}
}
@@ -39,14 +36,18 @@ src_prepare() {
}
src_compile() {
- linux-mod_src_compile
+ local modlist=(
+ v4l2loopback=video:
+ )
+
+ linux-mod-r1_src_compile
if use examples; then
emake CC="$(tc-getCC)" -C examples
fi
}
src_install() {
- linux-mod_src_install
+ linux-mod-r1_src_install
dosbin utils/v4l2loopback-ctl
dodoc doc/kernel_debugging.txt
dodoc doc/docs.txt