summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/clive
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/clive')
-rw-r--r--media-video/clive/Manifest1
-rw-r--r--media-video/clive/clive-2.3.0.1.ebuild58
-rw-r--r--media-video/clive/metadata.xml19
3 files changed, 78 insertions, 0 deletions
diff --git a/media-video/clive/Manifest b/media-video/clive/Manifest
new file mode 100644
index 000000000000..fa39c350a679
--- /dev/null
+++ b/media-video/clive/Manifest
@@ -0,0 +1 @@
+DIST clive-2.3.0.1.tar.gz 43551 SHA256 69b5d6014bdb097395b2d2ac945ebb5f6a73aff78d48fd67f533ddf33a615f33 SHA512 7426d6e8f19c358b30a7d33257d7ee536802eb35442d3cac68f6742613696ab1b280457a65d980237b53b692c5cf311725e46a5d8c27c7f2200172d050337cfc WHIRLPOOL 2e0a03dd700932eaf996ef5eea6059fdca197818ebc886fc4a1e1a6a846a1335334397115aed3c616005882e378ddbbcf3802423494f306360087dd74fc3cf5d
diff --git a/media-video/clive/clive-2.3.0.1.ebuild b/media-video/clive/clive-2.3.0.1.ebuild
new file mode 100644
index 000000000000..a4db5317b7d6
--- /dev/null
+++ b/media-video/clive/clive-2.3.0.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit perl-app
+
+DESCRIPTION="Command line tool for extracting videos from various websites"
+HOMEPAGE="http://clive.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PV:0:3}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="clipboard pager password test"
+
+RDEPEND=">=dev-perl/BerkeleyDB-0.34
+ >=dev-perl/Config-Tiny-2.12
+ >=virtual/perl-Digest-SHA-5.47
+ >=dev-perl/HTML-TokeParser-Simple-2.37
+ >=dev-perl/Class-Singleton-1.4
+ >=dev-perl/WWW-Curl-4.05
+ >=dev-perl/XML-Simple-2.18
+ >=dev-perl/Getopt-ArgvFile-1.11
+ dev-perl/JSON-XS
+ dev-perl/URI
+ virtual/perl-Getopt-Long
+ virtual/perl-File-Spec
+ clipboard? ( >=dev-perl/Clipboard-0.09 )
+ pager? ( >=dev-perl/IO-Pager-0.05 )
+ password? ( >=dev-perl/Expect-1.21 )
+ media-libs/quvi
+ || ( net-misc/wget net-misc/curl )"
+DEPEND="test? ( dev-perl/Test-Pod ${RDEPEND} )"
+
+SRC_TEST=do
+mydoc="NEWS"
+
+src_install() {
+ perl-module_src_install
+ dodir /etc/clive
+ cat <<-EOF > "${ED}"/etc/clive/config || die
+ --quvi "quvi %u"
+ --get-with "if type -P wget >/dev/null 2>&1; then wget -c -O %f %u; else curl -L -C - -o %f %u; fi"
+ --filename-format "%t.%s"
+ EOF
+}
+
+src_test() {
+ if [ -z "${I_WANT_CLIVE_HOSTS_TESTS}" ] ; then
+ elog "If you wish to run the full testsuite of ${PN}"
+ elog "Please set the variable 'I_WANT_CLIVE_HOSTS_TESTS' variable"
+ elog "Note that the tests try to download some videos from various websites"
+ elog "and thus may randomly fail depending on the site's status."
+ export NO_INTERNET=1
+ fi
+ perl-module_src_test
+}
diff --git a/media-video/clive/metadata.xml b/media-video/clive/metadata.xml
new file mode 100644
index 000000000000..3af39e89a618
--- /dev/null
+++ b/media-video/clive/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">Command line tool for extracting videos from Youtube, Google Video,
+ Dailymotion, Guba (free) and Stage6 websites</longdescription>
+ <use>
+ <flag name="clipboard">Support reading from X clipboard</flag>
+ <flag name="pager">Support pager!?</flag>
+ <flag name="password">Support password controlled sites</flag>
+ </use>
+ <upstream>
+ <remote-id type="google-code">clive</remote-id>
+ <remote-id type="sourceforge">clive</remote-id>
+ </upstream>
+</pkgmetadata>