summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-01 07:45:39 +0100
committerSam James <sam@gentoo.org>2024-04-01 07:45:53 +0100
commitfc2e39ec03509d1eea8aa101c7446df215bf5872 (patch)
treead2cbcb6c089a45cd69f51042a484ca2d0490842 /media-sound
parentgames-strategy/0ad: fix build w/ libxml2-2.12 (diff)
downloadgentoo-fc2e39ec03509d1eea8aa101c7446df215bf5872.tar.gz
gentoo-fc2e39ec03509d1eea8aa101c7446df215bf5872.tar.bz2
gentoo-fc2e39ec03509d1eea8aa101c7446df215bf5872.zip
media-sound/hydrogen: fix build w/o PCH
We recently disabled PCH in cmake.eclass (3867345f8c2d9f24157508bc6372f479a82cf33f) which had some fallout. Add a missing include which this exposes. Thanks to Christian for giving the patch on the bug. Closes: https://bugs.gentoo.org/922034 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/hydrogen/files/hydrogen-1.2.2-no-pch-include.patch11
-rw-r--r--media-sound/hydrogen/hydrogen-1.2.2-r1.ebuild1
2 files changed, 12 insertions, 0 deletions
diff --git a/media-sound/hydrogen/files/hydrogen-1.2.2-no-pch-include.patch b/media-sound/hydrogen/files/hydrogen-1.2.2-no-pch-include.patch
new file mode 100644
index 000000000000..fd0ee64b76a0
--- /dev/null
+++ b/media-sound/hydrogen/files/hydrogen-1.2.2-no-pch-include.patch
@@ -0,0 +1,11 @@
+https://bugs.gentoo.org/922034
+--- a/src/gui/src/Widgets/FileDialog.h
++++ b/src/gui/src/Widgets/FileDialog.h
+@@ -23,6 +23,7 @@
+ #define FILEDIALOG_H
+
+ #include <QDialog>
++#include <QFileDialog>
+ #include <core/Object.h>
+
+ /** Custom file dialog checking whether the user has write access to
diff --git a/media-sound/hydrogen/hydrogen-1.2.2-r1.ebuild b/media-sound/hydrogen/hydrogen-1.2.2-r1.ebuild
index 08ca329f3266..71df9f243599 100644
--- a/media-sound/hydrogen/hydrogen-1.2.2-r1.ebuild
+++ b/media-sound/hydrogen/hydrogen-1.2.2-r1.ebuild
@@ -61,6 +61,7 @@ DOCS=( AUTHORS ChangeLog DEVELOPERS README.md )
PATCHES=(
"${FILESDIR}/${PN}-1.2.1-gnuinstalldirs.patch"
"${FILESDIR}/${PN}-1.2.2-cflags.patch"
+ "${FILESDIR}/${P}-no-pch-include.patch"
)
src_prepare() {